summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-04 17:22:15 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-04 17:22:15 +0000
commit11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808 (patch)
treef4a35f8e85de489b29e338dd4c4afb91d42faf14 /sci-biology
parentamd64 stable, security bug 283624. (diff)
downloadgentoo-2-11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808.tar.gz
gentoo-2-11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808.tar.bz2
gentoo-2-11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808.zip
Version bump, clean up, fix bug 248338, take maintainership
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/njplot/ChangeLog10
-rw-r--r--sci-biology/njplot/metadata.xml4
-rw-r--r--sci-biology/njplot/njplot-2.3.ebuild33
-rw-r--r--sci-biology/njplot/njplot-20050109.ebuild35
4 files changed, 45 insertions, 37 deletions
diff --git a/sci-biology/njplot/ChangeLog b/sci-biology/njplot/ChangeLog
index dc070cfb64bd..f9d828aa1e6c 100644
--- a/sci-biology/njplot/ChangeLog
+++ b/sci-biology/njplot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/njplot
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/njplot/ChangeLog,v 1.9 2007/07/22 07:30:55 dberkholz Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/njplot/ChangeLog,v 1.10 2009/09/04 17:22:15 weaver Exp $
+
+*njplot-2.3 (04 Sep 2009)
+
+ 04 Sep 2009; Andrey Kislyuk <weaver@gentoo.org> metadata.xml,
+ +njplot-2.3.ebuild, -njplot-20050109.ebuild:
+ Version bump, clean up, fix bug 248338, take maintainership
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
njplot-20050109.ebuild:
diff --git a/sci-biology/njplot/metadata.xml b/sci-biology/njplot/metadata.xml
index 7fdc0274cfac..e522a3428e3c 100644
--- a/sci-biology/njplot/metadata.xml
+++ b/sci-biology/njplot/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
<herd>sci-biology</herd>
<longdescription>
NJplot is a tree drawing program able to draw any phylogenetic tree
diff --git a/sci-biology/njplot/njplot-2.3.ebuild b/sci-biology/njplot/njplot-2.3.ebuild
new file mode 100644
index 000000000000..147592cd5c05
--- /dev/null
+++ b/sci-biology/njplot/njplot-2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/njplot/njplot-2.3.ebuild,v 1.1 2009/09/04 17:22:15 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A phylogenetic tree drawing program which supports tree rooting"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/njplot.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/njplot-${PV}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXmu"
+DEPEND="sci-biology/ncbi-tools[X]
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's|/banques0/ncbiJun04|/usr/include/ncbi|' \
+ -e 's/CC = gcc/CC='$(tc-getCC)'/' -e 's/CFLAGS =/CFLAGS +=/' \
+ makefile || die
+ sed -i -e "s%njplot.help%/usr/share/doc/${PF}/njplot.help%" njplot-vib.c || die
+}
+
+src_install() {
+ dobin newicktops newicktotxt njplot unrooted || die
+ doman *.1 || die
+ dodoc README njplot.help
+}
diff --git a/sci-biology/njplot/njplot-20050109.ebuild b/sci-biology/njplot/njplot-20050109.ebuild
deleted file mode 100644
index feb35f9c5e2e..000000000000
--- a/sci-biology/njplot/njplot-20050109.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/njplot/njplot-20050109.ebuild,v 1.5 2007/07/22 07:30:55 dberkholz Exp $
-
-DESCRIPTION="A phylogenetic tree drawing program which supports tree rooting"
-HOMEPAGE="http://pbil.univ-lyon1.fr/software/njplot.html"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="public-domain"
-
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-RDEPEND="x11-libs/libXmu"
-
-DEPEND="sci-biology/ncbi-tools
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e "s%njplot.help%/usr/share/doc/${PF}/njplot.help%" njplot-vib.c || die
-}
-
-src_compile() {
- make all -e || die
-}
-
-src_install() {
- dobin add_root newicktops newicktotxt njplot unrooted
- insinto /usr/share/doc/${PF}
- doins njplot.help
- insinto /usr/share/${PN}
- doins test.ph
-}