summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-13 07:56:29 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-13 07:56:29 +0000
commit7c24ea978e556be5345c19a1e21629aa2b527500 (patch)
treeca826658528777ac27b7afa4a6661a31df32d456 /sci-biology
parentSet safe minimal versions of multilib dependencies, bug #513790. (diff)
downloadgentoo-2-7c24ea978e556be5345c19a1e21629aa2b527500.tar.gz
gentoo-2-7c24ea978e556be5345c19a1e21629aa2b527500.tar.bz2
gentoo-2-7c24ea978e556be5345c19a1e21629aa2b527500.zip
sci-biology/express: Version BUmp; thanks Michael Schubert for the initial patch, #525188
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/express/ChangeLog8
-rw-r--r--sci-biology/express/express-1.5.1.ebuild37
-rw-r--r--sci-biology/express/files/express-1.5.1-buildsystem.patch55
3 files changed, 99 insertions, 1 deletions
diff --git a/sci-biology/express/ChangeLog b/sci-biology/express/ChangeLog
index 6a0a592f12a0..51bc0c74b08c 100644
--- a/sci-biology/express/ChangeLog
+++ b/sci-biology/express/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/express
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/express/ChangeLog,v 1.5 2014/02/05 07:33:56 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/express/ChangeLog,v 1.6 2014/10/13 07:56:29 jlec Exp $
+
+*express-1.5.1 (13 Oct 2014)
+
+ 13 Oct 2014; Justin Lecher <jlec@gentoo.org> +express-1.5.1.ebuild,
+ +files/express-1.5.1-buildsystem.patch:
+ Version BUmp; thanks Michael Schubert for the initial patch, #525188
*express-0.9.5-r1 (05 Feb 2014)
diff --git a/sci-biology/express/express-1.5.1.ebuild b/sci-biology/express/express-1.5.1.ebuild
new file mode 100644
index 000000000000..9d9f50c6a49e
--- /dev/null
+++ b/sci-biology/express/express-1.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/express/express-1.5.1.ebuild,v 1.1 2014/10/13 07:56:29 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Streaming RNA-Seq Analysis"
+HOMEPAGE="http://bio.math.berkeley.edu/eXpress/"
+SRC_URI="http://bio.math.berkeley.edu/eXpress/downloads/${P}/${P}-src.tgz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/boost-1.52.0:=
+ dev-libs/protobuf
+ dev-util/google-perftools
+ sys-libs/zlib
+ sci-biology/bamtools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildsystem.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBAMTOOLS_INCLUDE="${EPREFIX}/usr/include/bamtools"
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-biology/express/files/express-1.5.1-buildsystem.patch b/sci-biology/express/files/express-1.5.1-buildsystem.patch
new file mode 100644
index 000000000000..fca5feadd111
--- /dev/null
+++ b/sci-biology/express/files/express-1.5.1-buildsystem.patch
@@ -0,0 +1,55 @@
+ CMakeLists.txt | 8 +++-----
+ src/CMakeLists.txt | 4 ++--
+ 2 files changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c768e28..65d5633 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,14 +6,12 @@ set(${PROJECT_NAME}_VERSION_MAJOR 1)
+ set(${PROJECT_NAME}_VERSION_MINOR 5)
+ set(${PROJECT_NAME}_VERSION_PATCH 1)
+
+-set(CMAKE_CXX_FLAGS "-Wall")
+-
+ set(CMAKE_CXX_FLAGS_DEBUG "-g ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS_RHDEBINFO "-O3 -g ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS_MINSIZEREL "-Os ${CMAKE_CXX_FLAGS}")
+
+ set(CMAKE_BUILD_TYPE Release)
+-set(Boost_USE_STATIC_LIBS ON)
++set(Boost_USE_STATIC_LIBS OFF)
+
+ find_package(Boost 1.39
+ COMPONENTS
+@@ -33,10 +31,10 @@ endif(GPERFTOOLS_TCMALLOC_LIB)
+
+ find_package(Protobuf)
+ if (PROTOBUF_FOUND)
+- include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
++ include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} ${BAMTOOLS_INCLUDE})
+ set(PROTO_INT 1)
+ else (PROTOBUF_FOUND)
+- include_directories(${Boost_INCLUDE_DIRS} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
++ include_directories(${Boost_INCLUDE_DIRS} ${BAMTOOLS_INCLUDE})
+ set(PROTO_INT 0)
+ endif(PROTOBUF_FOUND)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1cc0c01..8929d1f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -16,11 +16,11 @@ endif (GPERFTOOLS_TCMALLOC)
+ if(WIN32)
+ set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.lib" "${CMAKE_CURRENT_SOURCE_DIR}/../win_build/zlibd.lib")
+ else(WIN32)
+- set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.a" "pthread")
++ set(LIBRARIES ${LIBRARIES} "bamtools" "pthread")
+ endif(WIN32)
+
+ if (PROTOBUF_FOUND)
+- set(LIBRARIES ${LIBRARIES} "libprotobuf.a")
++ set(LIBRARIES ${LIBRARIES} "protobuf")
+ endif(PROTOBUF_FOUND)
+
+ target_link_libraries(express ${LIBRARIES})