summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2008-01-30 02:53:59 +0000
committerOlivier Fisette <ribosome@gentoo.org>2008-01-30 02:53:59 +0000
commit7e1d645849a41aece16dbe10a402d650d5a7fbc0 (patch)
tree5a4b6e0d2fbb4f5f88870237f425622b1fe003a8 /sci-biology
parentStable on x86 wrt bug #207682 (diff)
downloadgentoo-2-7e1d645849a41aece16dbe10a402d650d5a7fbc0.tar.gz
gentoo-2-7e1d645849a41aece16dbe10a402d650d5a7fbc0.tar.bz2
gentoo-2-7e1d645849a41aece16dbe10a402d650d5a7fbc0.zip
Fixed six_frame_translations function (bug #202606).
(Portage version: 2.1.3.19)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/ChangeLog11
-rw-r--r--sci-biology/biopython/biopython-1.44.ebuild44
-rw-r--r--sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch32
-rw-r--r--sci-biology/biopython/files/digest-biopython-1.443
4 files changed, 88 insertions, 2 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 92407eef7a2e..74a67af5c96a 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/biopython
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.18 2007/05/17 18:47:30 ribosome Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.19 2008/01/30 02:53:58 ribosome Exp $
+
+*biopython-1.44 (30 Jan 2008)
+
+ 30 Jan 2008; Olivier Fisette <ribosome@gentoo.org>
+ +files/biopython-1.44-sequtils-complement.patch, +biopython-1.44.ebuild:
+ Fixed six_frame_translations function. Thanks to JTRiley
+ <justin.t.riley@gmail.com> for his patch. (Fixes bug #202606.)
*biopython-1.43 (17 May 2007)
diff --git a/sci-biology/biopython/biopython-1.44.ebuild b/sci-biology/biopython/biopython-1.44.ebuild
new file mode 100644
index 000000000000..d60bbfdb1712
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.44.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.44.ebuild,v 1.1 2008/01/30 02:53:58 ribosome Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+LICENSE="as-is"
+HOMEPAGE="http://www.biopython.org"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+SLOT="0"
+IUSE="kdtree"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-python/numeric-19.0
+ >=dev-python/reportlab-1.11"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.43-buildkdtree.patch"
+ epatch "${FILESDIR}/${P}-sequtils-complement.patch"
+ if use kdtree; then
+ sed -i -e 's/USE_KDTREE = False/USE_KDTREE = True/' \
+ setup.py || die "Could not apply patch for KDTree support."
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="Doc/*.txt Doc/*.tex Doc/install/*.txt"
+ distutils_src_install
+
+ dohtml Doc/install/*.html || die "Failed to install HTML install docs."
+ dohtml Doc/*.html || die "Failed to install HTML docs."
+ cp -r Doc/examples/ Doc/*.pdf ${D}/usr/share/doc/${PF}/ || \
+ die "Failed to install documentation."
+}
diff --git a/sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch b/sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch
new file mode 100644
index 000000000000..16fc44d77cd0
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch
@@ -0,0 +1,32 @@
+--- biopython-1.44/Bio/SeqUtils/__init__.py.old 2007-09-14 09:38:35.000000000 -0400
++++ biopython-1.44/Bio/SeqUtils/__init__.py 2007-12-17 11:07:27.000000000 -0500
+@@ -7,8 +7,7 @@
+ # license. Please see the LICENSE file that should have been included
+ # as part of this package.
+
+-import os, sys, getopt, re, time
+-from string import maketrans
++import re, time
+ from Bio import SeqIO
+ from Bio import Translate
+ from Bio.Seq import Seq
+@@ -277,8 +276,9 @@
+ nice looking 6 frame translation with GC content - code from xbbtools
+ similar to DNA Striders six-frame translation
+ """
+- comp = complement(seq)
+- anti = reverse(comp)
++ from Bio.Seq import reverse_complement
++ anti = reverse_complement(seq)
++ comp = anti[::-1]
+ length = len(seq)
+ frames = {}
+ for i in range(0,3):
+@@ -399,6 +399,7 @@
+ # {{{
+
+ if __name__ == '__main__':
++ import sys, getopt
+ # crude command line options to use most functions directly on a FASTA file
+ options = {'apply_on_multi_fasta':0,
+ 'quick':0,
diff --git a/sci-biology/biopython/files/digest-biopython-1.44 b/sci-biology/biopython/files/digest-biopython-1.44
new file mode 100644
index 000000000000..d690618f53f6
--- /dev/null
+++ b/sci-biology/biopython/files/digest-biopython-1.44
@@ -0,0 +1,3 @@
+MD5 762c7a358af9dc58b712b8b4bb99d0c2 biopython-1.44.tar.gz 3840036
+RMD160 ecbbe2f46f0e5d124d910632dc9a7fd051202c0b biopython-1.44.tar.gz 3840036
+SHA256 e47c4a7c612e11cb6c1c0515274ce231646b31bbf1c9e3ac58998928c0ad3c72 biopython-1.44.tar.gz 3840036