summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-06-03 19:40:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-06-03 19:40:26 +0000
commit58ede0bc4ae1b165c1ea5709abb7aae40c202a42 (patch)
treeda0d0a5bbd920f2d257c27c4fe63b65f36305264 /sci-calculators/orpie
parentMasked games-simulation/secondlife (diff)
downloadgentoo-2-58ede0bc4ae1b165c1ea5709abb7aae40c202a42.tar.gz
gentoo-2-58ede0bc4ae1b165c1ea5709abb7aae40c202a42.tar.bz2
gentoo-2-58ede0bc4ae1b165c1ea5709abb7aae40c202a42.zip
Now build with system ocamlgsl. Added a fix for more recent ocaml, thanks Dylan Simon for his patch. Closing bug #297409 and bug #314651. Dropping ppc until we have ocamlgsl keyworded
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators/orpie')
-rw-r--r--sci-calculators/orpie/ChangeLog13
-rw-r--r--sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch30
-rw-r--r--sci-calculators/orpie/files/orpie-1.5.1-ocaml311.patch200
-rw-r--r--sci-calculators/orpie/files/orpie-1.5.1-orpierc.patch11
-rw-r--r--sci-calculators/orpie/orpie-1.5.1-r1.ebuild35
5 files changed, 287 insertions, 2 deletions
diff --git a/sci-calculators/orpie/ChangeLog b/sci-calculators/orpie/ChangeLog
index 668ef518e167..999405ab2f02 100644
--- a/sci-calculators/orpie/ChangeLog
+++ b/sci-calculators/orpie/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-calculators/orpie
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/ChangeLog,v 1.15 2009/02/03 14:37:55 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/ChangeLog,v 1.16 2010/06/03 19:40:26 bicatali Exp $
+
+*orpie-1.5.1-r1 (03 Jun 2010)
+
+ 03 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +orpie-1.5.1-r1.ebuild, +files/orpie-1.5.1-nogsl.patch,
+ +files/orpie-1.5.1-ocaml311.patch, +files/orpie-1.5.1-orpierc.patch:
+ Now build with system ocamlgsl. Added a fix for more recent ocaml, thanks
+ Dylan Simon for his patch. Closing bug #297409 and bug #314651. Dropping
+ ppc until we have ocamlgsl keyworded
03 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
-files/orpie-1.4.3-quote-down-crash.patch,
diff --git a/sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch b/sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch
new file mode 100644
index 000000000000..45894f2039dc
--- /dev/null
+++ b/sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch
@@ -0,0 +1,30 @@
+--- Makefile.in.orig 2010-06-03 21:02:14.000000000 +0100
++++ Makefile.in 2010-06-03 21:02:49.000000000 +0100
+@@ -38,7 +38,7 @@
+ CURSES_LIB = @CURSES_LIB@
+ GSL_LIB = @GSL_LIB@
+
+-INCLUDES = -I ./curses -I ./gsl -I ./units
++INCLUDES = -I ./curses -I /usr/lib/ocaml/gsl -I ./units
+ BFLAGS = -pp camlp4o -g $(INCLUDES) -thread
+ OFLAGS = -pp camlp4o $(INCLUDES) -thread
+ BLFLAGS = -custom -cclib '@LDFLAGS@ $(CURSES_LIB) $(GSL_LIB) -lm'
+@@ -72,16 +72,8 @@
+ CURSES_BOBJS = $(CURSES_CMO) $(CURSES_COBJS)
+ CURSES_OOBJS = $(CURSES_CMX) $(CURSES_COBJS)
+
+-GSL_CMO = gsl/gsl_error.cmo gsl/gsl_blas.cmo gsl/gsl_complex.cmo gsl/gsl_matrix.cmo gsl/gsl_matrix_complex.cmo \
+- gsl/gsl_vector.cmo gsl/gsl_vector_complex.cmo gsl/gsl_vector_flat.cmo gsl/gsl_matrix_flat.cmo \
+- gsl/gsl_vector_complex_flat.cmo gsl/gsl_matrix_complex_flat.cmo gsl/gsl_vectmat.cmo \
+- gsl/gsl_permut.cmo gsl/gsl_linalg.cmo gsl/gsl_fun.cmo
+-GSL_CMX = $(GSL_CMO:.cmo=.cmx)
+-GSL_COBJS = gsl/mlgsl_error.o gsl/mlgsl_blas.o gsl/mlgsl_blas_complex.o gsl/mlgsl_complex.o \
+- gsl/mlgsl_matrix_complex.o gsl/mlgsl_matrix_double.o gsl/mlgsl_vector_double.o gsl/mlgsl_permut.o \
+- gsl/mlgsl_linalg.o gsl/mlgsl_linalg_complex.o gsl/mlgsl_fun.o gsl/mlgsl_math.o gsl/mlgsl_sf.o
+-GSL_BOBJS = $(GSL_COBJS) $(GSL_CMO)
+-GSL_OOBJS = $(GSL_COBJS) $(GSL_CMX)
++GSL_BOBJS = /usr/lib/ocaml/gsl/gsl.cma
++GSL_OOBJS = /usr/lib/ocaml/gsl/gsl.cmxa
+
+ UNITS_CMO = units/units.cmo
+ UNITS_CMX = $(UNITS_CMO:.cmo=.cmx)
diff --git a/sci-calculators/orpie/files/orpie-1.5.1-ocaml311.patch b/sci-calculators/orpie/files/orpie-1.5.1-ocaml311.patch
new file mode 100644
index 000000000000..d1535f900958
--- /dev/null
+++ b/sci-calculators/orpie/files/orpie-1.5.1-ocaml311.patch
@@ -0,0 +1,200 @@
+diff -Naru orpie-1.5.1/Makefile.in orpie-1.5.1_1/Makefile.in
+--- orpie-1.5.1/Makefile.in 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/Makefile.in 2010-05-12 11:44:33.000000000 -0400
+@@ -257,10 +257,7 @@
+ units/%.cmo : units/%.ml
+ $(OCAMLC) -c $(UNITS_BFLAGS) $<
+
+-units/%.o : units/%.ml
+- $(OCAMLOPT) -c $(UNITS_OFLAGS) $<
+-
+-units/%.cmx : units/%.ml
++units/%.o units/%.cmx : units/%.ml
+ $(OCAMLOPT) -c $(UNITS_OFLAGS) $<
+
+
+@@ -271,22 +268,15 @@
+ %.cmo : %.ml
+ $(OCAMLC) -c $(BFLAGS) $<
+
+-%.o : %.ml
+- $(OCAMLOPT) -c $(OFLAGS) $<
+-
+-%.cmx : %.ml
++%.o %.cmx : %.ml
+ $(OCAMLOPT) -c $(OFLAGS) $<
+
+ %.ml : %.mll
+ $(OCAMLLEX) $<
+
+-%.ml : %.mly
++%.ml %.mli : %.mly
+ $(OCAMLYACC) -v $<
+
+-%.mli : %.mly
+- $(OCAMLYACC) -v $<
+-
+-
+
+ # Emacs tags
+ ############
+diff -Naru orpie-1.5.1/gsl/gsl_blas.ml orpie-1.5.1_1/gsl/gsl_blas.ml
+--- orpie-1.5.1/gsl/gsl_blas.ml 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_blas.ml 2010-05-12 11:24:11.000000000 -0400
+@@ -118,6 +118,7 @@
+
+ (** {3 Single precision} *)
+
++(*
+ open Gsl_vector.Single
+ open Gsl_matrix.Single
+
+@@ -187,6 +188,7 @@
+ alpha:float -> a:matrix -> b:matrix -> unit
+ = "ml_gsl_blas_strsm_bc" "ml_gsl_blas_strsm"
+ end
++*)
+
+
+ (** {3 Complex} *)
+@@ -274,6 +276,7 @@
+
+ (** {3 Complex single precision} *)
+
++(*
+ open Gsl_vector_complex.Single
+ open Gsl_matrix_complex.Single
+ open Gsl_complex
+@@ -354,3 +357,4 @@
+ a:matrix -> b:matrix -> beta:float -> c:matrix -> unit
+ = "ml_gsl_blas_cher2k_bc" "ml_gsl_blas_cher2k"
+ end
++*)
+diff -Naru orpie-1.5.1/gsl/gsl_blas.mli orpie-1.5.1_1/gsl/gsl_blas.mli
+--- orpie-1.5.1/gsl/gsl_blas.mli 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_blas.mli 2010-05-12 11:23:36.000000000 -0400
+@@ -118,6 +118,7 @@
+
+ (** {3 Single precision} *)
+
++(*
+ open Gsl_vector.Single
+ open Gsl_matrix.Single
+
+@@ -187,6 +188,7 @@
+ alpha:float -> a:matrix -> b:matrix -> unit
+ = "ml_gsl_blas_strsm_bc" "ml_gsl_blas_strsm"
+ end
++*)
+
+
+ (** {3 Complex} *)
+@@ -274,6 +276,7 @@
+
+ (** {3 Complex single precision} *)
+
++(*
+ open Gsl_vector_complex.Single
+ open Gsl_matrix_complex.Single
+ open Gsl_complex
+@@ -354,3 +357,4 @@
+ a:matrix -> b:matrix -> beta:float -> c:matrix -> unit
+ = "ml_gsl_blas_cher2k_bc" "ml_gsl_blas_cher2k"
+ end
++*)
+diff -Naru orpie-1.5.1/gsl/gsl_matrix.ml orpie-1.5.1_1/gsl/gsl_matrix.ml
+--- orpie-1.5.1/gsl/gsl_matrix.ml 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_matrix.ml 2010-05-12 11:22:51.000000000 -0400
+@@ -86,6 +86,7 @@
+
+
+
++(*
+ module Single =
+ struct
+ type float_mat_bigarr =
+@@ -164,3 +165,4 @@
+ external transpose : matrix -> matrix -> unit = "ml_gsl_matrix_float_transpose_memcpy"
+ external transpose_in_place : matrix -> unit = "ml_gsl_matrix_float_transpose"
+ end
++*)
+diff -Naru orpie-1.5.1/gsl/gsl_matrix.mli orpie-1.5.1_1/gsl/gsl_matrix.mli
+--- orpie-1.5.1/gsl/gsl_matrix.mli 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_matrix.mli 2010-05-12 11:22:42.000000000 -0400
+@@ -45,6 +45,7 @@
+ external transpose_in_place : matrix -> unit = "ml_gsl_matrix_transpose"
+
+
++(*
+ module Single : sig
+
+ type float_mat_bigarr =
+@@ -87,3 +88,4 @@
+ external transpose : matrix -> matrix -> unit = "ml_gsl_matrix_float_transpose_memcpy"
+ external transpose_in_place : matrix -> unit = "ml_gsl_matrix_float_transpose"
+ end
++*)
+diff -Naru orpie-1.5.1/gsl/gsl_matrix_complex.ml orpie-1.5.1_1/gsl/gsl_matrix_complex.ml
+--- orpie-1.5.1/gsl/gsl_matrix_complex.ml 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_matrix_complex.ml 2010-05-12 11:24:59.000000000 -0400
+@@ -108,6 +108,7 @@
+
+
+
++(*
+ module Single =
+ struct
+ type complex_float_mat_bigarr =
+@@ -208,3 +209,4 @@
+ external transpose : matrix -> matrix -> unit = "ml_gsl_matrix_complex_float_transpose_memcpy"
+ external transpose_in_place : matrix -> unit = "ml_gsl_matrix_complex_float_transpose"
+ end
++*)
+diff -Naru orpie-1.5.1/gsl/gsl_matrix_complex.mli orpie-1.5.1_1/gsl/gsl_matrix_complex.mli
+--- orpie-1.5.1/gsl/gsl_matrix_complex.mli 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_matrix_complex.mli 2010-05-12 11:25:00.000000000 -0400
+@@ -51,6 +51,7 @@
+ external transpose_in_place : matrix -> unit = "ml_gsl_matrix_complex_transpose"
+
+
++(*
+ module Single : sig
+
+ type complex_float_mat_bigarr =
+@@ -96,3 +97,4 @@
+ external transpose : matrix -> matrix -> unit = "ml_gsl_matrix_complex_float_transpose_memcpy"
+ external transpose_in_place : matrix -> unit = "ml_gsl_matrix_complex_float_transpose"
+ end
++*)
+diff -Naru orpie-1.5.1/gsl/gsl_vector.ml orpie-1.5.1_1/gsl/gsl_vector.ml
+--- orpie-1.5.1/gsl/gsl_vector.ml 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_vector.ml 2010-05-12 11:22:19.000000000 -0400
+@@ -95,6 +95,7 @@
+
+
+
++(*
+ module Single =
+ struct
+ type float_vector_bigarr =
+@@ -178,3 +179,4 @@
+ external minmax_index : vector -> int * int
+ = "ml_gsl_vector_float_minmaxindex"
+ end
++*)
+diff -Naru orpie-1.5.1/gsl/gsl_vector.mli orpie-1.5.1_1/gsl/gsl_vector.mli
+--- orpie-1.5.1/gsl/gsl_vector.mli 2007-09-13 23:31:23.000000000 -0400
++++ orpie-1.5.1_1/gsl/gsl_vector.mli 2010-05-12 11:22:19.000000000 -0400
+@@ -65,6 +65,7 @@
+
+ (** {3 Single precision} *)
+
++(*
+ module Single : sig
+ type float_vector_bigarr =
+ (float, Bigarray.float32_elt, Bigarray.c_layout) Bigarray.Array1.t
+@@ -121,3 +122,4 @@
+
+ val subvector : vector -> off:int -> len:int -> vector
+ end
++*)
diff --git a/sci-calculators/orpie/files/orpie-1.5.1-orpierc.patch b/sci-calculators/orpie/files/orpie-1.5.1-orpierc.patch
new file mode 100644
index 000000000000..a9ca1dd366f0
--- /dev/null
+++ b/sci-calculators/orpie/files/orpie-1.5.1-orpierc.patch
@@ -0,0 +1,11 @@
+--- orpie-1.5.1.orig/orpierc
++++ orpie-1.5.1/orpierc
+@@ -4,7 +4,7 @@
+ # directory for storing Orpie data
+ set datadir="~/.orpie/"
+ # editor used for fullscreen viewing of stack elements
+-set editor="vi"
++set editor="${EDITOR}"
+ # whether or not to hide the help panel
+ set hide_help="false"
+ # whether or not to conserve memory in favor of faster rendering
diff --git a/sci-calculators/orpie/orpie-1.5.1-r1.ebuild b/sci-calculators/orpie/orpie-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..11cf750b9328
--- /dev/null
+++ b/sci-calculators/orpie/orpie-1.5.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/orpie-1.5.1-r1.ebuild,v 1.1 2010/06/03 19:40:26 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="A fullscreen RPN calculator for the console"
+HOMEPAGE="http://pessimization.com/software/orpie/"
+SRC_URI="http://pessimization.com/software/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-ocaml/ocamlgsl
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ocaml311.patch
+ epatch "${FILESDIR}"/${P}-nogsl.patch
+ epatch "${FILESDIR}"/${P}-orpierc.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog doc/TODO
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/manual.pdf doc/manual.html
+ fi
+}