summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-13 20:50:29 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-13 20:50:29 +0000
commit38a8e0b064bb23eaa5ec4735e9abf525616a0ef4 (patch)
tree4a07b68a14404a1884c6267ce9a4a93a3bc38491 /sci-chemistry/PyMca
parentdev-python/h5py: Move to new python eclasses (diff)
downloadgentoo-2-38a8e0b064bb23eaa5ec4735e9abf525616a0ef4.tar.gz
gentoo-2-38a8e0b064bb23eaa5ec4735e9abf525616a0ef4.tar.bz2
gentoo-2-38a8e0b064bb23eaa5ec4735e9abf525616a0ef4.zip
sci-chemistry/PyMca: Move to new python eclasses; drop old
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry/PyMca')
-rw-r--r--sci-chemistry/PyMca/ChangeLog10
-rw-r--r--sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild45
-rw-r--r--sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild41
-rw-r--r--sci-chemistry/PyMca/metadata.xml16
4 files changed, 57 insertions, 55 deletions
diff --git a/sci-chemistry/PyMca/ChangeLog b/sci-chemistry/PyMca/ChangeLog
index f3fff3b122ee..5e52a291471c 100644
--- a/sci-chemistry/PyMca/ChangeLog
+++ b/sci-chemistry/PyMca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/PyMca
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/ChangeLog,v 1.4 2012/10/28 21:37:00 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/ChangeLog,v 1.5 2013/02/13 20:50:29 jlec Exp $
+
+*PyMca-4.6.2-r1 (13 Feb 2013)
+
+ 13 Feb 2013; Justin Lecher <jlec@gentoo.org> -PyMca-4.4.1_p1.ebuild,
+ +PyMca-4.6.2-r1.ebuild, metadata.xml:
+ Move to new python eclasses; drop old
*PyMca-4.6.2 (28 Oct 2012)
diff --git a/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild b/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild
deleted file mode 100644
index 88ea21e26c23..000000000000
--- a/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild,v 1.4 2012/10/28 21:37:00 jlec Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
-
-inherit distutils eutils
-
-MY_PV="${PV/_}"
-
-DESCRIPTION="X-ray Fluorescence Toolkit"
-HOMEPAGE="http://pymca.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/pymca/pymca/${PN}${PV/_p1}/pymca${MY_PV}-src.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="X hdf5 matplotlib"
-
-DEPEND="
- dev-python/numpy
- dev-python/sip
- virtual/opengl
- dev-python/pyopengl
- X? (
- dev-python/PyQt4
- dev-python/pyqwt
- )
- hdf5? ( dev-python/h5py )
- matplotlib? ( dev-python/matplotlib )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}${MY_PV}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}"/${PV}-impl-dec.patch
- export SPECFILE_USE_GNU_SOURCE=1
- distutils_src_prepare
-}
diff --git a/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild b/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild
new file mode 100644
index 000000000000..1560a1ce4b3e
--- /dev/null
+++ b/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild,v 1.1 2013/02/13 20:50:29 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PV="${PV/_}"
+
+DESCRIPTION="X-ray Fluorescence Toolkit"
+HOMEPAGE="http://pymca.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/pymca/pymca/${PN}${PV/_p1}/pymca${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X hdf5 matplotlib"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ virtual/opengl
+ X? (
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyqwt[${PYTHON_USEDEP}]
+ )
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+#S="${WORKDIR}/${PN}${MY_PV}"
+
+python_prepare_all() {
+ local PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+ export SPECFILE_USE_GNU_SOURCE=1
+ distutils-r1_python_prepare_all
+}
diff --git a/sci-chemistry/PyMca/metadata.xml b/sci-chemistry/PyMca/metadata.xml
index f843ca9d3d30..4edafb672739 100644
--- a/sci-chemistry/PyMca/metadata.xml
+++ b/sci-chemistry/PyMca/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
The PyMca Toolkit is a collection of Python tools for visualization and
analysis of energy-dispersive X-ray fluorescence data. It builds its graphic
interface and plotting routines on top of the C++ libraries Qt and Qwt
@@ -13,7 +13,7 @@ through their respective Python bindings PyQt and PyQwt. Nevertheless,
the data analysis routines can be used independently of any graphical
interface.
</longdescription>
- <use>
- <flag name="matplotlib">Support for plotting through matplotlib</flag>
- </use>
+ <use>
+ <flag name="matplotlib">Support for plotting through matplotlib</flag>
+ </use>
</pkgmetadata>