summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-22 09:05:05 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-22 09:05:05 +0000
commit0ef9516c9e2c68cb2fa7b5d07d664eb52c7e5290 (patch)
tree4024a691ea22a580b5224e096ef6440b01a0cae4 /sci-chemistry/apbs
parentold (diff)
downloadgentoo-2-0ef9516c9e2c68cb2fa7b5d07d664eb52c7e5290.tar.gz
gentoo-2-0ef9516c9e2c68cb2fa7b5d07d664eb52c7e5290.tar.bz2
gentoo-2-0ef9516c9e2c68cb2fa7b5d07d664eb52c7e5290.zip
sci-chemistry/apbs: Drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r3.ebuild166
-rw-r--r--sci-chemistry/apbs/apbs-1.4.1-r1.ebuild125
3 files changed, 5 insertions, 292 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 13ceeb972cbe..dd3e75012ba4 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.71 2015/01/04 19:08:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.72 2015/01/22 09:05:05 jlec Exp $
+
+ 22 Jan 2015; Justin Lecher <jlec@gentoo.org> -apbs-1.3-r3.ebuild,
+ -apbs-1.4.1-r1.ebuild:
+ Drop old
04 Jan 2015; Justin Lecher <jlec@gentoo.org> apbs-1.4.1-r2.ebuild:
Make test use newly build libs
diff --git a/sci-chemistry/apbs/apbs-1.3-r3.ebuild b/sci-chemistry/apbs/apbs-1.3-r3.ebuild
deleted file mode 100644
index 154132c2fce1..000000000000
--- a/sci-chemistry/apbs/apbs-1.3-r3.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r3.ebuild,v 1.5 2013/05/02 15:16:35 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="python? 2"
-
-inherit autotools-utils eutils fortran-2 python toolchain-funcs versionator
-
-MY_PV=$(get_version_component_range 1-3)
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Evaluation of electrostatic properties of nanoscale biomolecular systems"
-HOMEPAGE="http://www.poissonboltzmann.org/apbs/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="arpack doc examples fetk mpi openmp python static-libs tools"
-REQUIRED_USE="mpi? ( !python )"
-
-RDEPEND="
- dev-libs/maloc[mpi=]
- virtual/blas
- sys-libs/readline
- arpack? ( sci-libs/arpack )
- fetk? (
- sci-libs/fetk
- sci-libs/amd
- sci-libs/umfpack
- sci-libs/superlu )
- mpi? ( virtual/mpi )"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}"/"${MY_P}-source"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-MAKEOPTS+=" -j1"
-
-pkg_setup() {
- fortran-2_pkg_setup
- use python && python_set_active_version 2 && python_pkg_setup
- if [[ -z ${MAXMEM} ]]; then
- einfo "You can specify the max amount of RAM used"
- einfo "by setting MAXMEM=\"your size in MB\""
- else
- einfo "Settings max memory usage to ${MAXMEM} MB"
- fi
-}
-
-# git clone ssh://woodpecker/home/jlec/apbs.git
-PATCHES=( "${FILESDIR}"/${P}/00{01..16}* )
-
-src_prepare() {
- rm -rf contrib/{blas,maloc,opal,zlib} || die
- find -name "._*" -delete || die
-
- EPATCH_OPTS="-p1" \
- autotools-utils_src_prepare
-
- sed \
- -e "s:GENTOO_PKG_NAME:${PN}:g" \
- -i Makefile.am || die "Cannot correct package name"
- sed \
- -e 's:libmaloc.a:libmaloc.so:g' \
- -e 's:-lblas::g' \
- -i configure.ac || die
- sed -e 's:opal::g' -i contrib/Makefile.am || die
- sed \
- -e 's:noinst_PROGRAMS:bin_PROGRAMS:g' \
- -i tools/*/Makefile.am || die
-
- sed \
- -e "s:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g" \
- -e "s:AM_PROG_CC_STDC:AC_PROG_CC:g" \
- -i configure.ac || die
-
- AT_NOELIBTOOLIZE=yes eautoreconf
-}
-
-src_configure() {
- local myeconfargs=( --docdir="${EPREFIX}/usr/share/doc/${PF}" )
- use arpack && myeconfargs+=( --with-arpack="${EPREFIX}/usr/$(get_libdir)" )
-
- # check which mpi version is installed and tell configure
- if use mpi; then
- export CC="${EPREFIX}/usr/bin/mpicc"
- export F77="${EPREFIX}/usr/bin/mpif77"
-
- if has_version sys-cluster/mpich; then
- myeconfargs+=( --with-mpich="${EPREFIX}/usr" )
- elif has_version sys-cluster/mpich2; then
- myeconfargs+=( --with-mpich2="${EPREFIX}/usr" )
- elif has_version sys-cluster/openmpi; then
- myeconfargs+=( --with-openmpi="${EPREFIX}/usr" )
- fi
- fi || die "Failed to select proper mpi implementation"
-
- if use fetk; then
- myeconfargs+=( --with-fetk-include="${EPREFIX}/usr/include" --with-fetk-library="${EPREFIX}/usr/$(get_libdir)" )
- else
- myeconfargs+=( --disable-fetk )
- fi
-
- [[ -n ${MAXMEM} ]] && myeconfargs+=( --with-maxmem=${MAXMEM} )
-
- if use python; then
- myeconfargs+=( --enable-tools )
- else
- myeconfargs+=( $(use_enable tools) )
- fi
-
- myeconfargs+=(
- --disable-maloc-rebuild
- --enable-shared
- $(use_enable openmp)
- $(use_enable python)
- )
- autotools-utils_src_configure
-}
-
-src_test() {
- export LC_NUMERIC=C
- cd examples && make test \
- || die "Tests failed"
- grep -q 'FAILED' "${S}"/examples/TESTRESULTS.log && die "Tests failed"
-}
-
-src_install() {
- autotools-utils_src_install
-
- use doc && dohtml -r doc/*
- use examples && insinto /usr/share/${PN} && doins -r examples
- use tools && emake DESTDIR="${D}" install-tools
-
- if use python && ! use mpi; then
- insinto $(python_get_sitedir)/${PN}
- doins tools/manip/*.py
- doins tools/python/{*.py,*.pqr}
- doins tools/python/*/{*.py,*.so}
- python_clean_installation_image
- fi
-
- if use python || use tools; then
- mv "${ED}"/usr/bin/analysis{,_apbs} || die
- mv "${ED}"/usr/bin/smooth{,_apbs} || die
- fi
-}
-
-pkg_postinst() {
- use python && python_mod_optimize ${PN}
- if use python || use tools; then
- echo
- elog "Following apps have been renamed"
- elog "${EPREFIX}/usr/bin/analysis -> ${EPREFIX}/usr/bin/analysis_apbs"
- elog "${EPREFIX}/usr/bin/smooth -> ${EPREFIX}/usr/bin/smooth_apbs"
- echo
- fi
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/apbs/apbs-1.4.1-r1.ebuild b/sci-chemistry/apbs/apbs-1.4.1-r1.ebuild
deleted file mode 100644
index f005123c55bd..000000000000
--- a/sci-chemistry/apbs/apbs-1.4.1-r1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.4.1-r1.ebuild,v 1.2 2014/10/30 07:30:54 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils distutils-r1 flag-o-matic multilib toolchain-funcs
-
-GITHUB_REV="74fcb8676de69ed04ddab8976a8b05a6caaf4d65"
-
-DESCRIPTION="Evaluation of electrostatic properties of nanoscale biomolecular systems"
-HOMEPAGE="http://www.poissonboltzmann.org/apbs/"
-#SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
-SRC_URI="https://github.com/Electrostatics/apbs-pdb2pqr/archive/${GITHUB_REV}.zip -> ${P}.zip"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc examples fast +fetk mpi openmp python tools"
-
-REQUIRED_USE="
- mpi? ( !python )
- python? ( tools fetk ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-cpp/eigen:3
- dev-libs/maloc[mpi=]
- virtual/blas
- sys-libs/readline
- fetk? (
- sci-libs/fetk
- sci-libs/amd
- sci-libs/umfpack
- sci-libs/superlu
- )
- mpi? ( virtual/mpi )
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${DEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-
-S="${WORKDIR}"/${PN}-pdb2pqr-${GITHUB_REV}/${PN}
-
-PATCHES=(
- "${FILESDIR}"/${P}-multilib.patch
- "${FILESDIR}"/${P}-manip.patch
- "${FILESDIR}"/${P}-python.patch
-)
-
-src_prepare() {
- cmake-utils_src_prepare
- append-cppflags $($(tc-getPKG_CONFIG) --cflags eigen3)
-
- sed \
- -e "s:-lblas:$($(tc-getPKG_CONFIG) --libs blas):g" \
- -e "/TOOLS_PATH/d" \
- -i CMakeLists.txt || die
- use doc && MAKEOPTS+=" -j1"
- if use python; then
- unset PATCHES || die
- cd tools/python && distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=ON
- -DTOOLS_PATH="${ED}"/usr
- -DSYS_LIBPATHS="${EPREFIX}"/usr/$(get_libdir)
- -DLIBRARY_INSTALL_PATH=$(get_libdir)
- -DFETK_PATH="${EPREFIX}"/usr/
- -DBUILD_SHARED_LIBS=ON
- -DENABLE_QUIT=OFF
- $(cmake-utils_use_build doc DOC)
- $(cmake-utils_use_build tools TOOLS)
- -DENABLE_BEM=OFF
-# ENABLE_BEM: Boundary element method using TABIPB
- $(cmake-utils_use_enable debug DEBUG)
- $(cmake-utils_use_enable debug VERBOSE_DEBUG)
- $(cmake-utils_use_enable fast FAST)
- $(cmake-utils_use_enable fetk FETK)
- $(cmake-utils_use_enable mpi MPI)
- $(cmake-utils_use_enable python PYTHON)
-# ENABLE_TINKER: Enable TINKER support
-# ENABLE_iAPBS: Enable iAPBS
- -DENABLE_iAPBS=ON
-# MAX_MEMORY: Set the maximum memory (in MB) to be used for a job
- )
- cmake-utils_src_configure
- if use python; then
- cd tools/python && distutils-r1_src_configure
- fi
-}
-
-src_compile(){
- cmake-utils_src_compile
- if use python; then
- append-ldflags -L"${S}"/lib
- cd tools/python && distutils-r1_src_compile
- fi
-}
-
-src_test() {
- cd tests || die
- "${PYTHON}" apbs_tester.py -l log || die
- grep -q 'FAILED' log && die "Tests failed"
-}
-
-src_install() {
- dodir /usr/bin
- cmake-utils_src_install
- local i
- for i in "${ED}"/usr/bin/*; do
- if [[ ! "${i}" =~ .*apbs$ ]]; then
- mv "${i}" "${i}-apbs" || die
- fi
- done
- if use python; then
- cd tools/python && distutils-r1_src_install
- fi
-}