summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2008-01-03 15:29:48 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2008-01-03 15:29:48 +0000
commit933332fea4954812b13b4247c3d1fb2927e37a8a (patch)
tree3d18d1b94a3813d8987da43245397c103038fedd /sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
parentAdd guidexml USE-Flag for xmlcopyeditor (diff)
downloadgentoo-2-933332fea4954812b13b4247c3d1fb2927e37a8a.tar.gz
gentoo-2-933332fea4954812b13b4247c3d1fb2927e37a8a.tar.bz2
gentoo-2-933332fea4954812b13b4247c3d1fb2927e37a8a.zip
Die if imagemagick isn't emerged with USE=xml. Thanks to My Th on bug #204091.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild')
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
index 7df1bbfbe458..722a60fc1188 100644
--- a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild,v 1.1 2007/12/11 04:36:01 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild,v 1.2 2008/01/03 15:29:48 je_fro Exp $
-inherit fdo-mime
+inherit eutils fdo-mime
DESCRIPTION="A collection of data files to add support for chemical MIME types."
HOMEPAGE="http://chemical-mime.sourceforge.net/"
@@ -23,6 +23,15 @@ DEPEND="dev-util/pkgconfig
RDEPEND=""
+pkg_setup() {
+
+ if ! built_with_use 'media-gfx/imagemagick' xml; then
+ eerror "media-gfx/imagemagick must be built with the xml USE-flag enabled"
+ die "emerge media-gfx/imagemagick with the xml USE-flag enabled"
+ fi
+
+}
+
src_compile() {
econf --disable-update-database --htmldir=/usr/share/doc/${PN}/html