summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-09-05 07:03:30 +0000
committerJustin Lecher <jlec@gentoo.org>2012-09-05 07:03:30 +0000
commit6a52cb177c01992dcd51faa27d73ebc0d0dd4a11 (patch)
tree6bba1f45f3366201243324c39ce00f2407f2fcad /sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
parentsci-chemistry/vmd: Bumped to EAPI=4; use domenu; drop old (diff)
downloadgentoo-2-6a52cb177c01992dcd51faa27d73ebc0d0dd4a11.tar.gz
gentoo-2-6a52cb177c01992dcd51faa27d73ebc0d0dd4a11.tar.bz2
gentoo-2-6a52cb177c01992dcd51faa27d73ebc0d0dd4a11.zip
sci-chemistry/gperiodic: Bump EAPI to 4; fix desktop file
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild')
-rw-r--r--sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild b/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
index 8b25609aaaa8..53b6f69fee91 100644
--- a/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
+++ b/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild,v 1.5 2012/05/04 07:02:32 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild,v 1.6 2012/09/05 07:03:30 jlec Exp $
-EAPI="2"
+EAPI=4
-inherit toolchain-funcs eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Periodic table application for Linux"
-SRC_URI="http://www.frantz.fi/software/${P}.tar.gz"
HOMEPAGE="http://www.frantz.fi/software/gperiodic.php"
+SRC_URI="http://www.frantz.fi/software/${P}.tar.gz"
KEYWORDS="amd64 x86"
SLOT="0"
LICENSE="GPL-2"
IUSE="nls"
-RDEPEND=">=sys-libs/ncurses-5.2
+RDEPEND="
+ sys-libs/ncurses:5
x11-libs/gtk+:2
x11-libs/cairo[X]
nls? ( sys-devel/gettext )"
@@ -27,18 +28,21 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-makefile.patch \
"${FILESDIR}"/${P}-nls.patch
+ sed \
+ -e '/Encoding/d' \
+ -i ${PN}.desktop || die
}
src_compile() {
local myopts
use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
- emake CC=$(tc-getCC) ${myopts} || die
+ emake CC=$(tc-getCC) ${myopts}
}
src_install() {
local myopts
use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
- emake DESTDIR="${D}" ${myopts} install || die
- dodoc AUTHORS ChangeLog README NEWS || die
- newdoc po/README README.translation || die
+ emake DESTDIR="${D}" ${myopts} install
+ dodoc AUTHORS ChangeLog README NEWS
+ newdoc po/README README.translation
}