summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-09-06 09:16:48 +0000
committerJustin Lecher <jlec@gentoo.org>2012-09-06 09:16:48 +0000
commit2981221267093e06c885ff6428608f594627d3e5 (patch)
tree7b0133690c0002debb16841d95e9f8ae16353fa7 /sci-chemistry/mars/mars-1.2.ebuild
parentImprove respect for *FLAGS. Fixes part of bug #427782. (diff)
downloadgentoo-2-2981221267093e06c885ff6428608f594627d3e5.tar.gz
gentoo-2-2981221267093e06c885ff6428608f594627d3e5.tar.bz2
gentoo-2-2981221267093e06c885ff6428608f594627d3e5.zip
sci-chemistry/mars: Version Bump
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/mars/mars-1.2.ebuild')
-rw-r--r--sci-chemistry/mars/mars-1.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/mars/mars-1.2.ebuild b/sci-chemistry/mars/mars-1.2.ebuild
new file mode 100644
index 000000000000..f9d2f4fc19b9
--- /dev/null
+++ b/sci-chemistry/mars/mars-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mars/mars-1.2.ebuild,v 1.1 2012/09/06 09:16:48 jlec Exp $
+
+EAPI=4
+
+MY_P="${P}_linux"
+
+DESCRIPTION="Robust automatic backbone assignment of proteins"
+HOMEPAGE="http://www.mpibpc.mpg.de/groups/zweckstetter/_links/software_mars.htm"
+SRC_URI="http://www.mpibpc.mpg.de/groups/zweckstetter/_software_files/_${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="as-is"
+IUSE="examples"
+
+RDEPEND="sci-biology/psipred"
+DEPEND=""
+
+S="${WORKDIR}"/${MY_P}
+
+QA_PREBUILT="opt/mars/*"
+
+src_install() {
+ dobin bin/runmars*
+
+ exeinto /opt/${PN}/
+ doexe bin/{${PN},calcJC-S2,runmars*,*.awk} *.awk
+ insinto /opt/${PN}/
+ doins bin/*.{tab,txt}
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r examples
+ fi
+
+ cat >> "${T}"/23mars <<- EOF
+ MARSHOME="${EPREFIX}/opt/${PN}"
+ EOF
+
+ doenvd "${T}"/23mars
+}