summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-23 11:21:23 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-23 11:21:23 +0000
commit7a64a209b80b150128474b1f08b220bbe1ffbfff (patch)
tree1e2a8a42ba4583b4c29ddcda479a8e05f61e53e7 /sci-chemistry/molden
parentDon't install docs that are no longer there, thanks to David Abbott for the p... (diff)
downloadgentoo-2-7a64a209b80b150128474b1f08b220bbe1ffbfff.tar.gz
gentoo-2-7a64a209b80b150128474b1f08b220bbe1ffbfff.tar.bz2
gentoo-2-7a64a209b80b150128474b1f08b220bbe1ffbfff.zip
sci-chemistry/molden: Fix buffer overflow, #342907; Version Bump, #355741; Fix build failures, #358917, #423015; drop old
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/molden')
-rw-r--r--sci-chemistry/molden/ChangeLog14
-rw-r--r--sci-chemistry/molden/files/molden-4.8-overflow.patch34
-rw-r--r--sci-chemistry/molden/files/molden-5.0-ambfor.patch16
-rw-r--r--sci-chemistry/molden/metadata.xml2
-rw-r--r--sci-chemistry/molden/molden-4.8-r2.ebuild (renamed from sci-chemistry/molden/molden-4.8-r1.ebuild)34
-rw-r--r--sci-chemistry/molden/molden-4.8.ebuild66
-rw-r--r--sci-chemistry/molden/molden-5.0.ebuild (renamed from sci-chemistry/molden/molden-4.7-r1.ebuild)42
7 files changed, 104 insertions, 104 deletions
diff --git a/sci-chemistry/molden/ChangeLog b/sci-chemistry/molden/ChangeLog
index 07ab84ae6da4..dda69226ab63 100644
--- a/sci-chemistry/molden/ChangeLog
+++ b/sci-chemistry/molden/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-chemistry/molden
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/ChangeLog,v 1.38 2011/06/21 16:03:06 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/ChangeLog,v 1.39 2012/06/23 11:21:23 jlec Exp $
+
+*molden-5.0 (23 Jun 2012)
+*molden-4.8-r2 (23 Jun 2012)
+
+ 23 Jun 2012; Justin Lecher <jlec@gentoo.org> -molden-4.7-r1.ebuild,
+ -molden-4.8.ebuild, -molden-4.8-r1.ebuild, +molden-4.8-r2.ebuild,
+ files/molden-4.8-overflow.patch, +molden-5.0.ebuild,
+ +files/molden-5.0-ambfor.patch, metadata.xml:
+ Fix buffer overflow, #342907; Version Bump, #355741; Fix build failures,
+ #358917, #423015; drop old
21 Jun 2011; Justin Lecher <jlec@gentoo.org> molden-4.7.ebuild,
molden-4.7-r1.ebuild, molden-4.8.ebuild, molden-4.8-r1.ebuild:
diff --git a/sci-chemistry/molden/files/molden-4.8-overflow.patch b/sci-chemistry/molden/files/molden-4.8-overflow.patch
index 811664d4923b..7cbd7f436f57 100644
--- a/sci-chemistry/molden/files/molden-4.8-overflow.patch
+++ b/sci-chemistry/molden/files/molden-4.8-overflow.patch
@@ -1,7 +1,33 @@
-diff -Naur molden4.8/xwin.c molden4.8.new//xwin.c
---- molden4.8/xwin.c 2010-02-01 08:04:08.000000000 -0500
-+++ molden4.8.new//xwin.c 2010-02-26 00:03:36.000000000 -0500
-@@ -27353,7 +27353,7 @@
+ xwin.c | 10 ++++++----
+ 1 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/xwin.c b/xwin.c
+index f395909..092edff 100644
+--- a/xwin.c
++++ b/xwin.c
+@@ -13552,7 +13552,7 @@ void NewActiveStruct()
+ #ifdef CRAY
+ _fcd ztr;
+ #else
+- char ztr;
++ char ztr[4];
+ #endif
+ #endif
+
+@@ -13650,8 +13650,10 @@ void NewActiveStruct()
+ */
+ clfpstr->ihashz = 0;
+ #else
+- strncpy(&ztr,HetAtm[j],3);
+- parhet_(&j1,&ztr);
++ if (HetAtm[j] != NULL) {
++ strncpy(ztr,HetAtm[j],3);
++ parhet_(&j1,ztr);
++ }
+ #endif
+ #endif
+ }
+@@ -27353,7 +27355,7 @@ char *errstr;
UpdateZME();
RedrawScroll(&zscroll);
}
diff --git a/sci-chemistry/molden/files/molden-5.0-ambfor.patch b/sci-chemistry/molden/files/molden-5.0-ambfor.patch
new file mode 100644
index 000000000000..9656ff7a79be
--- /dev/null
+++ b/sci-chemistry/molden/files/molden-5.0-ambfor.patch
@@ -0,0 +1,16 @@
+ ambfor/makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/ambfor/makefile b/ambfor/makefile
+index 8627a11..dbc23a1 100644
+--- a/ambfor/makefile
++++ b/ambfor/makefile
+@@ -47,7 +47,7 @@ ambmd: md.o verlet.o qvdw.o allocmd.o $(OBJS)
+ $(LDR) -o ambmd md.o verlet.o qvdw.o allocmd.o $(OBJS) $(LIBS)
+
+ ambfor.o: ambfor.f
+- ${FC} -c -g -ffast-math -funroll-loops -o ambfor.o ambfor.f
++ ${FC} $(FFLAGS) -c -o ambfor.o ambfor.f
+
+ allocmd.o: alloc.c
+ $(CC) $(CFLAGS) -DMD -c alloc.c -o allocmd.o
diff --git a/sci-chemistry/molden/metadata.xml b/sci-chemistry/molden/metadata.xml
index 9ac9ffdb3a41..e42d0af60f42 100644
--- a/sci-chemistry/molden/metadata.xml
+++ b/sci-chemistry/molden/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>
diff --git a/sci-chemistry/molden/molden-4.8-r1.ebuild b/sci-chemistry/molden/molden-4.8-r2.ebuild
index 3981bb455aee..4935980f2615 100644
--- a/sci-chemistry/molden/molden-4.8-r1.ebuild
+++ b/sci-chemistry/molden/molden-4.8-r2.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/molden-4.8-r1.ebuild,v 1.6 2011/06/21 16:03:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/molden-4.8-r2.ebuild,v 1.1 2012/06/23 11:21:23 jlec Exp $
-EAPI="3"
+EAPI=4
inherit eutils fortran-2 flag-o-matic toolchain-funcs
MY_P="${PN}${PV}"
-DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac."
+DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac"
HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.gz"
@@ -19,7 +19,6 @@ IUSE="opengl"
RDEPEND="
virtual/fortran
-
x11-libs/libXmu
opengl? (
media-libs/freeglut
@@ -36,7 +35,11 @@ src_prepare() {
"${FILESDIR}"/${P}-overflow.patch \
"${FILESDIR}"/${P}-ldflags.patch \
"${FILESDIR}"/${PN}-4.7-implicit-dec.patch
- sed 's:makedepend:gccmakedep:g' -i surf/Makefile
+ sed \
+ -e 's:makedepend:gccmakedep:g' \
+ -e "s:/usr/include/sgidefs.h::g" \
+ -i surf/Makefile || die
+ sed 's:shell g77:shell $(FC):g' -i makefile || die
}
src_compile() {
@@ -47,24 +50,27 @@ src_compile() {
# unfortunately a bash bug prevents us from doing typeset and
# assignment on the same line.
typeset -a args
- args=( CC="$(tc-getCC) ${CFLAGS}" \
- FC="$(tc-getFC)" LDR="$(tc-getFC)" FFLAGS="${FFLAGS}" )
+ args=(
+ CC="$(tc-getCC) ${CFLAGS}" \
+ FC="$(tc-getFC)" \
+ LDR="$(tc-getFC)" \
+ FFLAGS="${FFLAGS}" )
einfo "Building Molden..."
- emake -j1 "${args[@]}" || die "molden emake failed"
+ emake -j1 "${args[@]}"
if use opengl ; then
einfo "Building Molden OpenGL helper..."
- emake -j1 "${args[@]}" moldenogl || die "moldenogl emake failed"
+ emake -j1 "${args[@]}" moldenogl
fi
}
src_install() {
- dobin ${PN} g${PN} || die "failed to install molden executable."
+ dobin ${PN} g${PN}
if use opengl ; then
- dobin ${PN}ogl || die "failed to install moldenogl."
+ dobin ${PN}ogl
fi
- dodoc HISTORY README REGISTER || die "failed to install docs."
+ dodoc HISTORY README REGISTER
cd doc
- uncompress * && dodoc * || die "failed to install docs."
+ uncompress * && dodoc *
}
diff --git a/sci-chemistry/molden/molden-4.8.ebuild b/sci-chemistry/molden/molden-4.8.ebuild
deleted file mode 100644
index 00968699b1e7..000000000000
--- a/sci-chemistry/molden/molden-4.8.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/molden-4.8.ebuild,v 1.5 2011/06/21 16:03:06 jlec Exp $
-
-EAPI="2"
-
-inherit eutils fortran-2 toolchain-funcs flag-o-matic
-
-MY_P="${PN}${PV}"
-
-DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac."
-HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
-SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
-IUSE="opengl"
-
-RDEPEND="
- virtual/fortran
- opengl? ( media-libs/freeglut
- virtual/opengl )
- x11-libs/libXmu"
-DEPEND="${RDEPEND}
- app-editors/vim"
- # vim provides ex, which the build system uses (surf/Makefile, at least)
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-ambfor.patch \
- "${FILESDIR}"/${P}-overflow.patch \
- "${FILESDIR}"/${P}-ldflags.patch
-}
-
-src_compile() {
- # Use -mieee on alpha, according to the Makefile
- use alpha && append-flags -mieee
-
- # Honor CC, CFLAGS, FC, and FFLAGS from environment;
- # unfortunately a bash bug prevents us from doing typeset and
- # assignment on the same line.
- typeset -a args
- args=( CC="$(tc-getCC) ${CFLAGS}" \
- FC="$(tc-getFC)" LDR="$(tc-getFC)" FFLAGS="${FFLAGS}" )
-
- einfo "Building Molden..."
- emake -j1 "${args[@]}" || die "molden emake failed"
- if use opengl ; then
- einfo "Building Molden OpenGL helper..."
- emake -j1 "${args[@]}" moldenogl || die "moldenogl emake failed"
- fi
-}
-
-src_install() {
- dobin molden || die "failed to install molden executable."
- if use opengl ; then
- dobin moldenogl || die "failed to install moldenogl."
- fi
-
- dodoc HISTORY README REGISTER || die "failed to install docs."
- cd doc
- uncompress * && dodoc * || die "failed to install docs."
-}
diff --git a/sci-chemistry/molden/molden-4.7-r1.ebuild b/sci-chemistry/molden/molden-5.0.ebuild
index 801ebe8d5ad5..d8064afec832 100644
--- a/sci-chemistry/molden/molden-4.7-r1.ebuild
+++ b/sci-chemistry/molden/molden-5.0.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/molden-4.7-r1.ebuild,v 1.6 2011/06/21 16:03:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/molden-5.0.ebuild,v 1.1 2012/06/23 11:21:23 jlec Exp $
-EAPI="3"
+EAPI=4
inherit eutils fortran-2 flag-o-matic toolchain-funcs
MY_P="${PN}${PV}"
-DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac."
+DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac"
HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.gz"
@@ -19,7 +19,6 @@ IUSE="opengl"
RDEPEND="
virtual/fortran
-
x11-libs/libXmu
opengl? (
media-libs/freeglut
@@ -32,10 +31,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-glibc-2.11.patch \
- "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${P}-implicit-dec.patch
- sed 's:makedepend:gccmakedep:g' -i surf/Makefile
+ epatch \
+ "${FILESDIR}"/${P}-ambfor.patch \
+ "${FILESDIR}"/${PN}-4.8-overflow.patch \
+ "${FILESDIR}"/${PN}-4.8-ldflags.patch \
+ "${FILESDIR}"/${PN}-4.7-implicit-dec.patch
+ sed \
+ -e 's:makedepend:gccmakedep:g' \
+ -e "s:/usr/include/sgidefs.h::g" \
+ -i surf/Makefile || die
+ sed 's:shell g77:shell $(FC):g' -i makefile || die
}
src_compile() {
@@ -46,24 +51,27 @@ src_compile() {
# unfortunately a bash bug prevents us from doing typeset and
# assignment on the same line.
typeset -a args
- args=( CC="$(tc-getCC) ${CFLAGS}" \
- FC="$(tc-getFC)" LDR="$(tc-getFC) ${LDFLAGS}" FFLAGS="${FFLAGS}" )
+ args=(
+ CC="$(tc-getCC) ${CFLAGS}" \
+ FC="$(tc-getFC)" \
+ LDR="$(tc-getFC)" \
+ FFLAGS="${FFLAGS}" )
einfo "Building Molden..."
- emake -j1 "${args[@]}" || die "molden emake failed"
+ emake -j1 "${args[@]}"
if use opengl ; then
einfo "Building Molden OpenGL helper..."
- emake -j1 "${args[@]}" moldenogl || die "moldenogl emake failed"
+ emake -j1 "${args[@]}" moldenogl
fi
}
src_install() {
- dobin ${PN} g${PN} || die "failed to install molden executable."
+ dobin ${PN} g${PN}
if use opengl ; then
- dobin ${PN}ogl || die "failed to install moldenogl."
+ dobin ${PN}ogl
fi
- dodoc HISTORY README REGISTER || die "failed to install docs."
+ dodoc HISTORY README REGISTER
cd doc
- uncompress * && dodoc * || die "failed to install docs."
+ uncompress * && dodoc *
}