summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-04 21:47:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-04 21:47:00 +0000
commitff7af471fe940b141669652e5061603c45488d33 (patch)
treec3dedba7db261e670ae1a9ad61f8e09088be447b /sci-chemistry/refmac
parentVersion bump. (diff)
downloadgentoo-2-ff7af471fe940b141669652e5061603c45488d33.tar.gz
gentoo-2-ff7af471fe940b141669652e5061603c45488d33.tar.bz2
gentoo-2-ff7af471fe940b141669652e5061603c45488d33.zip
Version Bump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/refmac')
-rw-r--r--sci-chemistry/refmac/ChangeLog7
-rw-r--r--sci-chemistry/refmac/refmac-5.6.0090.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/sci-chemistry/refmac/ChangeLog b/sci-chemistry/refmac/ChangeLog
index 4d74a4822a5b..4d52c97f4be3 100644
--- a/sci-chemistry/refmac/ChangeLog
+++ b/sci-chemistry/refmac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/refmac
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.21 2010/11/04 06:53:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.22 2010/11/04 21:47:00 jlec Exp $
+
+*refmac-5.6.0090 (04 Nov 2010)
+
+ 04 Nov 2010; Justin Lecher <jlec@gentoo.org> +refmac-5.6.0090.ebuild:
+ Version Bump
*refmac-5.6.0089 (04 Nov 2010)
diff --git a/sci-chemistry/refmac/refmac-5.6.0090.ebuild b/sci-chemistry/refmac/refmac-5.6.0090.ebuild
new file mode 100644
index 000000000000..5281d12e2d9e
--- /dev/null
+++ b/sci-chemistry/refmac/refmac-5.6.0090.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.6.0090.ebuild,v 1.1 2010/11/04 21:47:00 jlec Exp $
+
+EAPI="2"
+
+inherit fortran base toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)_source_v${PV}"
+
+DESCRIPTION="Macromolecular crystallographic refinement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~garib/refmac/"
+SRC_URI="${HOMEPAGE}data/refmac_experimental/${PN}${MY_PV}.tar.gz
+ test? ( http://dev.gentooexperimental.org/~jlec/distfiles/test-framework.tar.gz )"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ sci-libs/mmdb
+ >sci-libs/monomer-db-1
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/5.6.0089-allow-dynamic-linking.patch
+ )
+
+src_prepare() {
+ base_src_prepare
+ use test && epatch "${FILESDIR}"/5.5-test.log.patch
+}
+
+src_compile() {
+ emake \
+ FC=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ COPTIM="${CFLAGS}" \
+ FOPTIM="${FFLAGS:- -O2}" \
+ VERSION="" \
+ XFFLAGS="-fno-second-underscore" \
+ LLIBCCP="-lccp4f -lccp4c -lccif -lmmdb -lstdc++" \
+ LLIBLAPACK="$(pkg-config --libs lapack blas)" \
+ || die
+}
+
+src_test() {
+ einfo "Starting tests ..."
+ export PATH="${WORKDIR}/test-framework/scripts:${S}:${PATH}"
+ export CCP4_TEST="${WORKDIR}"/test-framework
+ export CCP4_SCR="${T}"
+ ln -sf refmac "${S}"/refmac5
+ sed '/^ANISOU/d' -i ${CCP4_TEST}/data/pdb/1vr7.pdb
+ ccp4-run-thorough-tests -v test_refmac5 || die
+}
+
+src_install() {
+ for i in refmac libcheck FreeTwin header2matr; do
+ exeinto /usr/libexec/ccp4/bin/
+ doexe ${i} || die
+ dosym ../libexec/ccp4/bin/${i} /usr/bin/${i}
+ done
+ dosym refmac /usr/bin/refmac5 || die
+}