summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2010-08-20 15:11:08 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2010-08-20 15:11:08 +0000
commitf8e17d75ed24ab4964d5e78a4c7d9d0d737e4502 (patch)
tree5c36ca143864ad12c1fbd6d5c9da4ff7607c2aec /sci-chemistry/shelx/shelx-20060317-r1.ebuild
parentMake tc-getF77() fall back to the gcc-provided gfortran, not some nonexistent... (diff)
downloadgentoo-2-f8e17d75ed24ab4964d5e78a4c7d9d0d737e4502.tar.gz
gentoo-2-f8e17d75ed24ab4964d5e78a4c7d9d0d737e4502.tar.bz2
gentoo-2-f8e17d75ed24ab4964d5e78a4c7d9d0d737e4502.zip
OpenMP: Handle full specifier for gfortran correctly so that the default, unset compiler works.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/shelx/shelx-20060317-r1.ebuild')
-rw-r--r--sci-chemistry/shelx/shelx-20060317-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-chemistry/shelx/shelx-20060317-r1.ebuild b/sci-chemistry/shelx/shelx-20060317-r1.ebuild
index 701d275d762d..19efced4e67d 100644
--- a/sci-chemistry/shelx/shelx-20060317-r1.ebuild
+++ b/sci-chemistry/shelx/shelx-20060317-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/shelx-20060317-r1.ebuild,v 1.5 2010/06/28 08:37:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/shelx-20060317-r1.ebuild,v 1.6 2010/08/20 15:11:08 dberkholz Exp $
inherit autotools eutils flag-o-matic fortran
@@ -54,7 +54,7 @@ src_unpack() {
src_compile() {
case $(tc-getF77) in
- gfortran) append-flags -fopenmp ;;
+ *gfortran) append-flags -fopenmp ;;
ifort) append-flags -openmp ;;
*) ewarn "Please add any necessary OpenMP build flags to F77FLAGS." ;;
esac