summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 13:59:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 13:59:36 +0000
commitfb0307104a0dc02bc98a79a9e602a7100ea40f4b (patch)
tree0b48f4b0914478a147261f74762667864730b6d5 /sci-chemistry/tinker
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-fb0307104a0dc02bc98a79a9e602a7100ea40f4b.tar.gz
gentoo-2-fb0307104a0dc02bc98a79a9e602a7100ea40f4b.tar.bz2
gentoo-2-fb0307104a0dc02bc98a79a9e602a7100ea40f4b.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/tinker')
-rw-r--r--sci-chemistry/tinker/ChangeLog6
-rw-r--r--sci-chemistry/tinker/tinker-5.1.09.ebuild9
-rw-r--r--sci-chemistry/tinker/tinker-6.ebuild13
3 files changed, 15 insertions, 13 deletions
diff --git a/sci-chemistry/tinker/ChangeLog b/sci-chemistry/tinker/ChangeLog
index cb98628bbdbf..ae4095747dd6 100644
--- a/sci-chemistry/tinker/ChangeLog
+++ b/sci-chemistry/tinker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/tinker
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.28 2010/12/02 22:15:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.29 2010/12/16 13:59:36 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> tinker-5.1.09.ebuild,
+ tinker-6.ebuild:
+ Removal of fortran.eclass, #348851
*tinker-6 (02 Dec 2010)
diff --git a/sci-chemistry/tinker/tinker-5.1.09.ebuild b/sci-chemistry/tinker/tinker-5.1.09.ebuild
index 4e70913715ab..5652258fc40d 100644
--- a/sci-chemistry/tinker/tinker-5.1.09.ebuild
+++ b/sci-chemistry/tinker/tinker-5.1.09.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-5.1.09.ebuild,v 1.3 2010/12/02 10:51:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-5.1.09.ebuild,v 1.4 2010/12/16 13:59:36 jlec Exp $
EAPI="2"
-FORTRAN="gfortran ifc"
-inherit eutils fortran java-pkg-opt-2 toolchain-funcs
+inherit eutils java-pkg-opt-2 toolchain-funcs
DESCRIPTION="Molecular modeling package that includes force fields, such as AMBER and CHARMM"
HOMEPAGE="http://dasher.wustl.edu/tinker/"
@@ -21,12 +20,12 @@ RDEPEND="
dev-libs/maloc
!dev-util/diffuse
>=virtual/jre-1.6"
+
RESTRICT="mirror"
S="${WORKDIR}"/tinker/source
pkg_setup() {
- fortran_pkg_setup
java-pkg-opt-2_pkg_setup
}
@@ -42,7 +41,7 @@ src_compile() {
done
emake -e \
-f ../make/Makefile \
- F77="${FORTRANC}" \
+ F77="$(tc-getFC)" \
CC="$(tc-getCC) -c" \
F77FLAGS=-c \
OPTFLAGS="${FFLAGS}" \
diff --git a/sci-chemistry/tinker/tinker-6.ebuild b/sci-chemistry/tinker/tinker-6.ebuild
index 687335483ebc..2a90d59d3261 100644
--- a/sci-chemistry/tinker/tinker-6.ebuild
+++ b/sci-chemistry/tinker/tinker-6.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-6.ebuild,v 1.1 2010/12/02 22:15:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-6.ebuild,v 1.2 2010/12/16 13:59:36 jlec Exp $
EAPI="2"
-FORTRAN="gfortran ifc"
-inherit fortran flag-o-matic java-pkg-opt-2 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 toolchain-funcs
DESCRIPTION="Molecular modeling package that includes force fields, such as AMBER and CHARMM"
HOMEPAGE="http://dasher.wustl.edu/tinker/"
@@ -22,19 +21,19 @@ RDEPEND="
dev-libs/maloc
!dev-util/diffuse
>=virtual/jre-1.6"
+
RESTRICT="mirror"
S="${WORKDIR}"/${PN}${PV}/source
pkg_setup() {
- fortran_pkg_setup
java-pkg-opt-2_pkg_setup
tc-has-openmp || die "Please use an openmp capable compiler like gcc[openmp]"
}
src_prepare() {
sed 's:strip:true:g' -i ../make/Makefile
- [[ ${FORTRANC} == "ifc" ]] || epatch "${FILESDIR}"/${PV}-openmp.patch
+ [[ $(tc-getFC) == "ifort" ]] || epatch "${FILESDIR}"/${PV}-openmp.patch
}
src_compile() {
@@ -46,7 +45,7 @@ src_compile() {
# use dummy routines in pmpb.f instead of apbs calls
rm pmpb.c || die
- if [[ ${FORTRANC} == "gfortran" ]]; then
+ if [[ $(tc-getFC) == "gfortran" ]]; then
append-flags -fopenmp
_omplib="-lgomp"
else
@@ -58,7 +57,7 @@ src_compile() {
emake \
-f ../make/Makefile \
- F77="${FORTRANC}" \
+ F77="$(tc-getFC)" \
CC="$(tc-getCC) -c" \
F77FLAGS=-c \
OPTFLAGS="${FFLAGS}" \