summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-11-01 14:34:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-11-01 14:34:22 +0000
commitce2b39496ff96c77cc52c595311b2aac0a587b55 (patch)
treee7936e6df79151a0ec27c8d782c1d35a398130af /sci-chemistry/wxmacmolplt
parentversion bump by Triffid Hunter in bug #288993, remove old (diff)
downloadgentoo-2-ce2b39496ff96c77cc52c595311b2aac0a587b55.tar.gz
gentoo-2-ce2b39496ff96c77cc52c595311b2aac0a587b55.tar.bz2
gentoo-2-ce2b39496ff96c77cc52c595311b2aac0a587b55.zip
[sci-chemistry/wxmacmolplt] Initial import #197131
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/wxmacmolplt')
-rw-r--r--sci-chemistry/wxmacmolplt/ChangeLog10
-rw-r--r--sci-chemistry/wxmacmolplt/metadata.xml11
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild33
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/wxmacmolplt/ChangeLog b/sci-chemistry/wxmacmolplt/ChangeLog
new file mode 100644
index 000000000000..e2da1bfbec35
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/wxmacmolplt
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.1 2009/11/01 14:34:22 alexxy Exp $
+
+*wxmacmolplt-7.3 (01 Nov 2009)
+
+ 01 Nov 2009; Alexey Shvetsov <alexxy@gentoo.org> +wxmacmolplt-7.3.ebuild,
+ +metadata.xml:
+ Initial import. Thanks to Reinis Danne
+
diff --git a/sci-chemistry/wxmacmolplt/metadata.xml b/sci-chemistry/wxmacmolplt/metadata.xml
new file mode 100644
index 000000000000..fb69a7dab0b6
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<longdescription>
+wxMacMolPlt is a program for plotting 3D molecular structures and normal modes (vibrations), various orbitals and electron density maps. It reads a variety of file formats including any GAMESS input, log or IRC file directly to create animations. It has a simple GAMESS input (.inp) builder and a primitive molecule builder.
+</longdescription>
+<use>
+ <flag name='flash'>Add support for flash movie generation using <pkg>media-libs/ming</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild
new file mode 100644
index 000000000000..10d413f27f98
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild,v 1.1 2009/11/01 14:34:22 alexxy Exp $
+
+EAPI="2"
+
+inherit base eutils
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/~brett/MacMolPlt/"
+
+SRC_URI="http://www.scl.ameslab.gov/~brett/MacMolPlt/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="flash"
+
+DEPEND="x11-libs/wxGTK[opengl]
+ flash? ( media-libs/ming )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with flash ming)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN}.png "Science;Education"
+}