summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-26 14:20:18 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-26 14:20:18 +0000
commit0244217cc47cd56a68e4ae9b5bf08eebf4e18c40 (patch)
tree7ba806323946b575e4b3672a92a2be6e65358743 /sci-chemistry
parentMask experimental udisks2 support for kde-base/kdelibs, bug #424157. (diff)
downloadgentoo-2-0244217cc47cd56a68e4ae9b5bf08eebf4e18c40.tar.gz
gentoo-2-0244217cc47cd56a68e4ae9b5bf08eebf4e18c40.tar.bz2
gentoo-2-0244217cc47cd56a68e4ae9b5bf08eebf4e18c40.zip
sci-chemistry/eden: Respect the CFLAGS everywhere, #428190; fix some implicit declarations; bump EAPI to 4
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/eden/ChangeLog7
-rw-r--r--sci-chemistry/eden/eden-5.3-r1.ebuild25
-rw-r--r--sci-chemistry/eden/files/5.3-makefile-fixes.patch7
-rw-r--r--sci-chemistry/eden/files/eden-5.3-impl-dec.patch28
-rw-r--r--sci-chemistry/eden/metadata.xml8
5 files changed, 57 insertions, 18 deletions
diff --git a/sci-chemistry/eden/ChangeLog b/sci-chemistry/eden/ChangeLog
index 9ddd24986916..c40fdbdb1254 100644
--- a/sci-chemistry/eden/ChangeLog
+++ b/sci-chemistry/eden/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/eden
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/eden/ChangeLog,v 1.17 2012/05/04 07:02:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/eden/ChangeLog,v 1.18 2012/07/26 14:20:18 jlec Exp $
+
+ 26 Jul 2012; Justin Lecher <jlec@gentoo.org> files/5.3-makefile-fixes.patch,
+ eden-5.3-r1.ebuild, +files/eden-5.3-impl-dec.patch, metadata.xml:
+ Respect the CFLAGS everywhere, #428190; fix some implicit declarations; bump
+ EAPI to 4
04 May 2012; Jeff Horelick <jdhore@gentoo.org> eden-5.3-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-chemistry/eden/eden-5.3-r1.ebuild b/sci-chemistry/eden/eden-5.3-r1.ebuild
index 880de464bd15..98faa94be3d5 100644
--- a/sci-chemistry/eden/eden-5.3-r1.ebuild
+++ b/sci-chemistry/eden/eden-5.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/eden/eden-5.3-r1.ebuild,v 1.5 2012/05/04 07:02:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/eden/eden-5.3-r1.ebuild,v 1.6 2012/07/26 14:20:18 jlec Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="2"
@@ -32,10 +32,13 @@ EDENHOME="${EPREFIX}/usr/$(get_libdir)/eden"
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
- epatch "${FILESDIR}"/${PV}-makefile-fixes.patch
+ epatch \
+ "${FILESDIR}"/${PV}-makefile-fixes.patch \
+ "${FILESDIR}"/${P}-impl-dec.patch
sed -i \
-e "s:^\(FFTW.*=\).*:\1 ${EPREFIX}/usr:g" \
@@ -54,22 +57,22 @@ src_prepare() {
}
src_compile() {
- emake CC=$(tc-getCC) -C ${SRC} || die "emake failed"
+ emake CC=$(tc-getCC) -C ${SRC}
}
src_install() {
- emake -C ${SRC} install || die "install failed"
+ emake -C ${SRC} install
exeinto ${EDENHOME}/python
- doexe python/* || die
+ doexe python/*
insinto ${EDENHOME}/help
- doins help/* || die
+ doins help/*
insinto ${EDENHOME}/tools
- doins tools/* || die
+ doins tools/*
- dodoc manual/UserManual.pdf || die
+ dodoc manual/UserManual.pdf
cat >> "${T}"/eden <<- EOF
#!/bin/bash
@@ -77,7 +80,7 @@ src_install() {
${EXE} \$*
EOF
- dobin "${T}"/eden || die
+ dobin "${T}"/eden
cat >> "${T}"/ieden <<- EOF
#!/bin/bash
@@ -85,7 +88,7 @@ src_install() {
$(PYTHON) -O \${EDENHOME}/python/eden.py
EOF
- dobin "${T}"/ieden || die
+ dobin "${T}"/ieden
}
pkg_postinst() {
diff --git a/sci-chemistry/eden/files/5.3-makefile-fixes.patch b/sci-chemistry/eden/files/5.3-makefile-fixes.patch
index e42cbb48a9aa..632358341784 100644
--- a/sci-chemistry/eden/files/5.3-makefile-fixes.patch
+++ b/sci-chemistry/eden/files/5.3-makefile-fixes.patch
@@ -1,5 +1,8 @@
+ source/Makefile | 17 ++++++++++-------
+ 1 files changed, 10 insertions(+), 7 deletions(-)
+
diff --git a/source/Makefile b/source/Makefile
-index 46d89cc..56c09a7 100644
+index 46d89cc..aa751c7 100644
--- a/source/Makefile
+++ b/source/Makefile
@@ -78,8 +78,10 @@ CFLAGS = -Wall -pipe -g3
@@ -41,7 +44,7 @@ index 46d89cc..56c09a7 100644
fbyteswap: fbyteswap.c
- $(CC) -o $@ $^
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
install: all
+ mkdir -p $(BIN)
diff --git a/sci-chemistry/eden/files/eden-5.3-impl-dec.patch b/sci-chemistry/eden/files/eden-5.3-impl-dec.patch
new file mode 100644
index 000000000000..af67508d090e
--- /dev/null
+++ b/sci-chemistry/eden/files/eden-5.3-impl-dec.patch
@@ -0,0 +1,28 @@
+ source/fbyteswap.c | 1 +
+ source/util.c | 1 +
+ 2 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/source/fbyteswap.c b/source/fbyteswap.c
+index 83015b9..c9033c3 100644
+--- a/source/fbyteswap.c
++++ b/source/fbyteswap.c
+@@ -39,6 +39,7 @@ and shall not be used for advertising or product endorsement purposes.
+
+ #include <stdio.h>
+ #include <fcntl.h>
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ void byteswap();
+diff --git a/source/util.c b/source/util.c
+index 6fff179..ca7a957 100644
+--- a/source/util.c
++++ b/source/util.c
+@@ -89,6 +89,7 @@ and shall not be used for advertising or product endorsement purposes.
+
+ *******************************************************************************/
+ #include <sys/time.h> /* ... for picking up date & time */
++#include <time.h>
+ #include <signal.h> /* ... for capturing kill */
+ #include "util.h"
+
diff --git a/sci-chemistry/eden/metadata.xml b/sci-chemistry/eden/metadata.xml
index 44f051fffcea..8c65886ace97 100644
--- a/sci-chemistry/eden/metadata.xml
+++ b/sci-chemistry/eden/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<use>
- <flag name='double-precision'>More precise calculations at the expense of
+ <herd>sci-chemistry</herd>
+ <use>
+ <flag name="double-precision">More precise calculations at the expense of
speed</flag>
-</use>
+ </use>
</pkgmetadata>