summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-19 20:56:27 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-19 20:56:27 +0000
commit44b7ad4fa1722c38bc33cf1fe7cdc977870366bf (patch)
tree22b46a07195391ecb96485e32f5c848485694940 /sci-chemistry
parentx86 stable wrt security bug #340807 (diff)
downloadgentoo-2-44b7ad4fa1722c38bc33cf1fe7cdc977870366bf.tar.gz
gentoo-2-44b7ad4fa1722c38bc33cf1fe7cdc977870366bf.tar.bz2
gentoo-2-44b7ad4fa1722c38bc33cf1fe7cdc977870366bf.zip
Fix for fortran detection, thanks alexxy poiting to it
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gamess/gamess-20090112.1-r1.ebuild6
-rw-r--r--sci-chemistry/gamess/gamess-20101001.1.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild b/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild
index d550ac8fd970..2ec28f655ca0 100644
--- a/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild
+++ b/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild,v 1.9 2010/12/16 15:31:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20090112.1-r1.ebuild,v 1.10 2010/12/19 20:56:27 jlec Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -46,7 +46,7 @@ pkg_nofetch() {
pkg_setup() {
# currently amd64 is only supported with gfortran
- if [[ "${ARCH}" == "amd64" ]] && [[ "$(tc-getFC)" != "gfortran" ]];
+ if [[ "${ARCH}" == "amd64" ]] && [[ "$(tc-getFC)" != *gfortran* ]];
then die "You will need gfortran to compile gamess on amd64"
fi
@@ -79,7 +79,7 @@ src_unpack() {
# for hardened-gcc let't turn off ssp, since it breakes
# a few routines
- if use hardened && [[ "$(tc-getFC)" = "g77" ]]; then
+ if use hardened && [[ "$(tc-getFC)" =~ g77 ]]; then
FFLAGS="${FFLAGS} -fno-stack-protector-all"
fi
diff --git a/sci-chemistry/gamess/gamess-20101001.1.ebuild b/sci-chemistry/gamess/gamess-20101001.1.ebuild
index 15f64ddd2062..07dc01f1cc95 100644
--- a/sci-chemistry/gamess/gamess-20101001.1.ebuild
+++ b/sci-chemistry/gamess/gamess-20101001.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20101001.1.ebuild,v 1.4 2010/12/16 15:31:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20101001.1.ebuild,v 1.5 2010/12/19 20:56:27 jlec Exp $
EAPI="3"
@@ -55,7 +55,7 @@ pkg_nofetch() {
pkg_setup() {
# currently amd64 is only supported with gfortran
- if [[ "${ARCH}" == "amd64" ]] && [[ "$(tc-getFC)" != "gfortran" ]];
+ if [[ "${ARCH}" == "amd64" ]] && [[ "$(tc-getFC)" != *gfortran* ]];
then die "You will need gfortran to compile gamess on amd64"
fi
@@ -105,7 +105,7 @@ src_prepare() {
# for hardened-gcc let't turn off ssp, since it breakes
# a few routines
- if use hardened && [[ "$(tc-getFC)" = "g77" ]]; then
+ if use hardened && [[ "$(tc-getFC)" =~ g77 ]]; then
FFLAGS="${FFLAGS} -fno-stack-protector-all"
fi