summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-17 06:54:03 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-17 06:54:03 +0000
commit453e96bf7f19325df26e337df4d5d45167524279 (patch)
treea3df94d78744e3da5f740ca7e303ab04f294e62e /sci-chemistry
parentFix format-security warning. Bug #524934 (diff)
downloadgentoo-2-453e96bf7f19325df26e337df4d5d45167524279.tar.gz
gentoo-2-453e96bf7f19325df26e337df4d5d45167524279.tar.bz2
gentoo-2-453e96bf7f19325df26e337df4d5d45167524279.zip
sci-chemistry/pymol: Version Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol/ChangeLog8
-rw-r--r--sci-chemistry/pymol/files/pymol-1.7.3.1-maeffplugin.cpp.patch11
-rw-r--r--sci-chemistry/pymol/pymol-1.7.3.1.ebuild106
3 files changed, 124 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index ca274c591808..eadece7d5c3c 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.118 2014/09/15 08:20:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.119 2014/10/17 06:54:03 jlec Exp $
+
+*pymol-1.7.3.1 (17 Oct 2014)
+
+ 17 Oct 2014; Justin Lecher <jlec@gentoo.org> +pymol-1.7.3.1.ebuild,
+ +files/pymol-1.7.3.1-maeffplugin.cpp.patch:
+ Version Bump
*pymol-1.7.3.0 (15 Sep 2014)
diff --git a/sci-chemistry/pymol/files/pymol-1.7.3.1-maeffplugin.cpp.patch b/sci-chemistry/pymol/files/pymol-1.7.3.1-maeffplugin.cpp.patch
new file mode 100644
index 000000000000..cd4650bbf4e0
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.7.3.1-maeffplugin.cpp.patch
@@ -0,0 +1,11 @@
+--- contrib/uiuc/plugins/molfile_plugin/src/maeffplugin_orig.cpp 2014-02-07 19:50:50.132261610 -0800
++++ contrib/uiuc/plugins/molfile_plugin/src/maeffplugin.cpp 2014-02-07 19:52:12.527797099 -0800
+@@ -1983,7 +1983,7 @@
+ }
+ }
+ catch (std::exception &e) {
+- fprintf(stderr, e.what());
++ fprintf(stderr, "%s", e.what());
+ return MOLFILE_ERROR;
+ }
+ return MOLFILE_SUCCESS;
diff --git a/sci-chemistry/pymol/pymol-1.7.3.1.ebuild b/sci-chemistry/pymol/pymol-1.7.3.1.ebuild
new file mode 100644
index 000000000000..37b77d5f35be
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.7.3.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.7.3.1.ebuild,v 1.1 2014/10/17 06:54:03 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 fdo-mime versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://www.pymol.org/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${PN}-1.7.0.0.png.xz
+ http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz
+"
+# mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV}.tar.bz2
+# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="apbs web"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pmw[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-libs/freetype:2
+ media-libs/glew
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ media-libs/freeglut
+ apbs? (
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
+ )
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-maeffplugin.cpp.patch
+ )
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -e "/import/s:argparse:argparseX:g" \
+ -i setup.py || die
+
+ rm ./modules/pmg_tk/startup/apbs_tools.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --pymol-path="${EPREFIX}/usr/share/pymol"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_export python2_7 EPYTHON
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="$(python_get_sitedir)/${PN}"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.7.0.0.png ${PN}.png
+ make_desktop_entry ${PN} PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}