summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-05 08:46:50 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-05 08:46:50 +0000
commit9aebf9c6d28827c292264c9dde03bc7e4b8e0ffa (patch)
treef8b8321cfa288d044683f800b6ba6fde289a580c /sci-chemistry
parentAdd missing test dep, bug #547784 (diff)
downloadgentoo-2-9aebf9c6d28827c292264c9dde03bc7e4b8e0ffa.tar.gz
gentoo-2-9aebf9c6d28827c292264c9dde03bc7e4b8e0ffa.tar.bz2
gentoo-2-9aebf9c6d28827c292264c9dde03bc7e4b8e0ffa.zip
Fix linking problems, bug #547522
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/ball/ChangeLog6
-rw-r--r--sci-chemistry/ball/ball-1.4.2.ebuild3
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-underlinking.patch16
3 files changed, 23 insertions, 2 deletions
diff --git a/sci-chemistry/ball/ChangeLog b/sci-chemistry/ball/ChangeLog
index ca73a7139c4c..89bf135f4452 100644
--- a/sci-chemistry/ball/ChangeLog
+++ b/sci-chemistry/ball/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/ball
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ChangeLog,v 1.16 2015/04/08 18:22:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ChangeLog,v 1.17 2015/05/05 08:46:50 jlec Exp $
+
+ 05 May 2015; Justin Lecher <jlec@gentoo.org>
+ +files/ball-1.4.2-underlinking.patch, ball-1.4.2.ebuild:
+ Fix linking problems, bug #547522
08 Apr 2015; Michał Górny <mgorny@gentoo.org> ball-1.4.2.ebuild:
Drop old Python implementations
diff --git a/sci-chemistry/ball/ball-1.4.2.ebuild b/sci-chemistry/ball/ball-1.4.2.ebuild
index 37c37dbb3ceb..9ab4927161d5 100644
--- a/sci-chemistry/ball/ball-1.4.2.ebuild
+++ b/sci-chemistry/ball/ball-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.2.ebuild,v 1.2 2015/04/08 18:22:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.2.ebuild,v 1.3 2015/05/05 08:46:50 jlec Exp $
EAPI=5
@@ -53,6 +53,7 @@ PATCHES=(
"${FILESDIR}"/${P}-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch
"${FILESDIR}"/${PN}-1.4.1-BondOrder.xml.patch
"${FILESDIR}"/${P}-Fix-compilation-of-sipModularWidget.patch
+ "${FILESDIR}"/${P}-underlinking.patch
)
pkg_setup() {
diff --git a/sci-chemistry/ball/files/ball-1.4.2-underlinking.patch b/sci-chemistry/ball/files/ball-1.4.2-underlinking.patch
new file mode 100644
index 000000000000..825f41978c13
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-underlinking.patch
@@ -0,0 +1,16 @@
+ source/APPLICATIONS/BALLVIEW/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/source/APPLICATIONS/BALLVIEW/CMakeLists.txt b/source/APPLICATIONS/BALLVIEW/CMakeLists.txt
+index 6d16212..f94ce76 100644
+--- a/source/APPLICATIONS/BALLVIEW/CMakeLists.txt
++++ b/source/APPLICATIONS/BALLVIEW/CMakeLists.txt
+@@ -85,7 +85,7 @@ IF (UNIX)
+ LIST(APPEND BALLVIEW_SUPPORT_LIBRARIES "pthread")
+ ENDIF ()
+
+-TARGET_LINK_LIBRARIES(BALLView BALL VIEW ${BALLVIEW_SUPPORT_LIBRARIES})
++TARGET_LINK_LIBRARIES(BALLView BALL VIEW ${BALLVIEW_SUPPORT_LIBRARIES} X11)
+
+ #Setup the translations
+ INCLUDE(${CMAKE_SOURCE_DIR}/cmake/BALLViewTranslations.cmake)