summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-09 07:04:48 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-09 07:04:48 +0000
commit9f8ea691dbd8d1e4b0b655f30512cc6b37642251 (patch)
tree6f2b396d59a5cf6821cad373e668618e65624a6c /sci-chemistry
parentversion bump (diff)
downloadgentoo-2-9f8ea691dbd8d1e4b0b655f30512cc6b37642251.tar.gz
gentoo-2-9f8ea691dbd8d1e4b0b655f30512cc6b37642251.tar.bz2
gentoo-2-9f8ea691dbd8d1e4b0b655f30512cc6b37642251.zip
Version Bump, fixes for usage of python.eclass
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol/ChangeLog8
-rw-r--r--sci-chemistry/pymol/files/1.3.0-vmd.patch33
-rw-r--r--sci-chemistry/pymol/pymol-1.2.3-r1.ebuild3
-rw-r--r--sci-chemistry/pymol/pymol-1.3.0.ebuild104
4 files changed, 146 insertions, 2 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index cb15a8826e54..4ed37e366017 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.63 2010/06/09 06:49:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.64 2010/06/09 07:04:48 jlec Exp $
+
+*pymol-1.3.0 (09 Jun 2010)
+
+ 09 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/1.3.0-vmd.patch,
+ pymol-1.2.3-r1.ebuild, +pymol-1.3.0.ebuild:
+ Version Bump, fixes for usage of python.eclass
09 Jun 2010; Justin Lecher <jlec@gentoo.org> -pymol-1.0-r1.ebuild,
-files/pymol-1.0-r1-data-path.patch, -pymol-1.2.2.ebuild,
diff --git a/sci-chemistry/pymol/files/1.3.0-vmd.patch b/sci-chemistry/pymol/files/1.3.0-vmd.patch
new file mode 100644
index 000000000000..0f34a02ea01b
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.3.0-vmd.patch
@@ -0,0 +1,33 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 3908)
++++ setup.py (working copy)
+@@ -130,8 +130,8 @@
+ "/usr/include/freetype2",
+ # "/users/warren/ext/include",
+ # VMD plugin support
+-# "contrib/uiuc/plugins/include",
+-# "contrib/uiuc/plugins/molfile_plugin/src",
++ "contrib/uiuc/plugins/include",
++ "contrib/uiuc/plugins/molfile_plugin/src",
+ "modules/cealign/src",
+ "modules/cealign/src/tnt", ]
+ libs=["GL","GLU","glut","png","z","freetype",
+@@ -151,7 +151,7 @@
+ # Numeric Python support
+ # ("_PYMOL_NUMPY",None),
+ # VMD plugin support
+-# ("_PYMOL_VMD_PLUGINS",None)
++ ("_PYMOL_VMD_PLUGINS",None)
+ ]
+ ext_comp_args=["-ffast-math","-funroll-loops","-O3"]
+ ext_link_args=[]
+@@ -299,7 +299,7 @@
+ "layer5/main.c"
+ # VMD plugin support
+ # switch the 0 to 1 to activate the additional source code
+- ] + 0 * [
++ ] + 1 * [
+ # (incomplete support -- only TRJ, TRR, XTC, DCD so far...)
+ 'contrib/uiuc/plugins/molfile_plugin/src/PlugIOManagerInit.c',
+ 'contrib/uiuc/plugins/molfile_plugin/src/avsplugin.cpp',
diff --git a/sci-chemistry/pymol/pymol-1.2.3-r1.ebuild b/sci-chemistry/pymol/pymol-1.2.3-r1.ebuild
index e7574345d1e0..972ddd0e2075 100644
--- a/sci-chemistry/pymol/pymol-1.2.3-r1.ebuild
+++ b/sci-chemistry/pymol/pymol-1.2.3-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.3-r1.ebuild,v 1.4 2010/05/16 12:52:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.3-r1.ebuild,v 1.5 2010/06/09 07:04:48 jlec Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.6"
PYTHON_USE_WITH="tk"
REV="3891"
diff --git a/sci-chemistry/pymol/pymol-1.3.0.ebuild b/sci-chemistry/pymol/pymol-1.3.0.ebuild
new file mode 100644
index 000000000000..b9f33c3468d1
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.3.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.3.0.ebuild,v 1.1 2010/06/09 07:04:48 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="tk"
+REV="3909"
+
+inherit eutils distutils prefix
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="http://pymol.svn.sourceforge.net/viewvc/pymol/trunk/pymol.tar.gz?view=tar&pathrev=${REV} -> ${P}.tar.gz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="apbs numpy shaders vmd"
+
+DEPEND="
+ dev-python/numpy
+ dev-python/pmw
+ media-libs/freetype:2
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/glut
+ apbs? (
+ dev-libs/maloc
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin
+ )"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.* 2.4 2.5"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.2.2-data-path.patch
+
+ epatch "${FILESDIR}"/1.2.2-prefix.patch && \
+ eprefixify setup.py
+
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though. #299020
+ epatch "${FILESDIR}"/1.2.1/nosplash-gentoo.patch
+
+ # Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py || die "Failed running sed on setup.py"
+
+ use shaders && epatch "${FILESDIR}"/${PN}-1.2.2-shaders.patch
+
+ use vmd && epatch "${FILESDIR}"/${PV}-vmd.patch
+
+ use numpy && \
+ sed \
+ -e '/PYMOL_NUMPY/s:^#::g' \
+ -i setup.py
+
+ rm ./modules/pmg_tk/startup/apbs_tools.py || die
+
+ # python 3.* fix
+ # sed '452,465d' -i setup.py
+ distutils_src_prepare
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ distutils_src_install
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="${EPREFIX}/$(python_get_sitedir -f)/${PN}"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+ cat >> "${T}"/pymol <<- EOF
+ #!/bin/sh
+ $(PYTHON -f) -O \${PYMOL_PATH}/__init__.py \$*
+ EOF
+
+ dobin "${T}"/pymol || die "Failed to install wrapper."
+
+ insinto /usr/share/pymol
+ doins -r test data scripts || die "no shared data"
+
+ insinto /usr/share/pymol/examples
+ doins -r examples || die "Failed to install docs."
+
+ dodoc DEVELOPERS README || die "Failed to install docs."
+}