summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-12-19 20:22:42 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-12-19 20:22:42 +0000
commitbacf3a5bb85be7b8b5395263d3961ff968347350 (patch)
tree51ba5e3196cb036bfdd7be3c76383774b1336061 /sci-chemistry
parentBump to 1.7.0 final release, remove old 1.7.0_rc, remove older versions. (diff)
downloadgentoo-2-bacf3a5bb85be7b8b5395263d3961ff968347350.tar.gz
gentoo-2-bacf3a5bb85be7b8b5395263d3961ff968347350.tar.bz2
gentoo-2-bacf3a5bb85be7b8b5395263d3961ff968347350.zip
Fix bug 250420 thanks to Joel <joel_123@hotmail.com>
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc6 x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mustang/ChangeLog6
-rw-r--r--sci-chemistry/mustang/files/mustang-3-gcc43.patch55
-rw-r--r--sci-chemistry/mustang/mustang-3.ebuild12
3 files changed, 67 insertions, 6 deletions
diff --git a/sci-chemistry/mustang/ChangeLog b/sci-chemistry/mustang/ChangeLog
index 1b4b461b76c0..befb97d8315e 100644
--- a/sci-chemistry/mustang/ChangeLog
+++ b/sci-chemistry/mustang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/mustang
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/ChangeLog,v 1.4 2008/04/29 10:30:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/ChangeLog,v 1.5 2008/12/19 20:22:42 loki_val Exp $
+
+ 19 Dec 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/mustang-3-gcc43.patch, mustang-3.ebuild:
+ Fix bug 250420 thanks to Joel <joel_123@hotmail.com>
29 Apr 2008; Markus Dittrich <markusle@gentoo.org> ChangeLog:
Redigested ebuild to fix broken Manifest (bug #219429).
diff --git a/sci-chemistry/mustang/files/mustang-3-gcc43.patch b/sci-chemistry/mustang/files/mustang-3-gcc43.patch
new file mode 100644
index 000000000000..ef2818b92ed8
--- /dev/null
+++ b/sci-chemistry/mustang/files/mustang-3-gcc43.patch
@@ -0,0 +1,55 @@
+diff -u MUSTANG_v.3.orig/src/ew_2.cpp MUSTANG_v.3/src/ew_2.cpp
+--- MUSTANG_v.3.orig/src/ew_2.cpp 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/ew_2.cpp 2008-12-09 10:47:22.000000000 -0700
+@@ -36,6 +36,7 @@
+ using std::ifstream;
+
+ #include<math.h>
++#include <cstdlib>
+ #include "macros.h"
+ #include "globals.h"
+ #include "ew.h"
+diff -u MUSTANG_v.3.orig/src/multiple_superposition.cpp MUSTANG_v.3/src/multiple_superposition.cpp
+--- MUSTANG_v.3.orig/src/multiple_superposition.cpp 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/multiple_superposition.cpp 2008-12-09 10:49:00.000000000 -0700
+@@ -51,6 +51,7 @@
+ #include "alloc_routines.h"
+ #include "de_alloc_routines.h"
+ #include <cmath>
++#include <cstdlib>
+ #define THRESH 0.0001
+
+ void MOVE_TO_CENTER_OF_GRAVITY( int NSTRUC , int NRES , float ***R , float **CMs )
+diff -u MUSTANG_v.3.orig/src/multiple_superposition.h MUSTANG_v.3/src/multiple_superposition.h
+--- MUSTANG_v.3.orig/src/multiple_superposition.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/multiple_superposition.h 2008-12-09 10:48:11.000000000 -0700
+@@ -25,3 +25,4 @@
+ #define MULT_SUPERPOSE
+ void M_SUPERPOSE( int , int , float***, float** , float*** ) ;
+ #endif
++#include <cstdlib>
+diff -u MUSTANG_v.3.orig/src/pdb_ripper.h MUSTANG_v.3/src/pdb_ripper.h
+--- MUSTANG_v.3.orig/src/pdb_ripper.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/pdb_ripper.h 2008-12-09 10:46:47.000000000 -0700
+@@ -29,4 +29,5 @@
+ void PARSE_ENTIRE_PDB_STRUCTURE( char * , int ) ;
+
+ #endif
++#include <cstdlib>
+
+diff -u MUSTANG_v.3.orig/src/progress_align.h MUSTANG_v.3/src/progress_align.h
+--- MUSTANG_v.3.orig/src/progress_align.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/progress_align.h 2008-12-09 10:47:50.000000000 -0700
+@@ -25,3 +25,4 @@
+ #define PROG_ALGN_H
+ void PROGRESSIVE_ALIGNMENT_USING_EXTENDED_EDGE_WEIGHTS() ;
+ #endif
++#include <cstdlib>
+diff -u MUSTANG_v.3.orig/src/read_structures.h MUSTANG_v.3/src/read_structures.h
+--- MUSTANG_v.3.orig/src/read_structures.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/read_structures.h 2008-12-09 10:46:22.000000000 -0700
+@@ -26,3 +26,4 @@
+ void READ_STRUCTURES( char **paths );
+ void READ_ENTIRE_PDBS( char **paths) ;
+ #endif
++#include <cstdlib>
diff --git a/sci-chemistry/mustang/mustang-3.ebuild b/sci-chemistry/mustang/mustang-3.ebuild
index 549578b67cee..3cc52e09817a 100644
--- a/sci-chemistry/mustang/mustang-3.ebuild
+++ b/sci-chemistry/mustang/mustang-3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/mustang-3.ebuild,v 1.3 2006/12/11 06:21:00 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/mustang-3.ebuild,v 1.4 2008/12/19 20:22:42 loki_val Exp $
-inherit toolchain-funcs
+inherit base toolchain-funcs
MY_PN="MUSTANG"
SRC_P="${PN}_v.${PV}"
@@ -12,12 +12,14 @@ HOMEPAGE="http://www.cs.mu.oz.au/~arun/mustang/"
SRC_URI="${HOMEPAGE}${SRC_P}.tgz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
src_compile() {
emake \
CPP=$(tc-getCXX) \
@@ -32,7 +34,7 @@ src_test() {
src_install() {
newbin bin/MUSTANG_v.3 mustang
- dodoc README.txt
+ mv mustang mustang.1
}
pkg_postinst() {