summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-04 09:27:37 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-04 09:27:37 +0000
commitdcb794ca86f09041f06293043467d8881d50b546 (patch)
tree6185207775b0e8c5bef8d026de5109d575b76501 /sci-chemistry
parentMove versions into slots because they are not compatible and actionpack 3.0.x... (diff)
downloadgentoo-2-dcb794ca86f09041f06293043467d8881d50b546.tar.gz
gentoo-2-dcb794ca86f09041f06293043467d8881d50b546.tar.bz2
gentoo-2-dcb794ca86f09041f06293043467d8881d50b546.zip
Fix for blas detection
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r1.ebuild5
-rw-r--r--sci-chemistry/apbs/files/apbs-1.3-blas.patch16
3 files changed, 24 insertions, 3 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index eba59b3182cd..21709882e67d 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.49 2011/07/02 08:56:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.50 2011/07/04 09:27:37 jlec Exp $
+
+ 04 Jul 2011; Justin Lecher <jlec@gentoo.org> apbs-1.3-r1.ebuild,
+ +files/apbs-1.3-blas.patch:
+ Fix for blas detection
02 Jul 2011; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
apbs-1.3.ebuild, apbs-1.3-r1.ebuild, metadata.xml:
diff --git a/sci-chemistry/apbs/apbs-1.3-r1.ebuild b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
index 894cf101e429..92d0b44e257d 100644
--- a/sci-chemistry/apbs/apbs-1.3-r1.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.6 2011/07/02 08:56:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.7 2011/07/04 09:27:37 jlec Exp $
EAPI="3"
@@ -65,7 +65,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.2.1b-parallelbuild.patch \
"${FILESDIR}"/${P}-mainroutines.patch \
"${FILESDIR}"/${P}-zlib.patch \
- "${FILESDIR}"/${P}-python.patch
+ "${FILESDIR}"/${P}-python.patch \
+ "${FILESDIR}"/${P}-blas.patch
sed "s:GENTOO_PKG_NAME:${PN}:g" \
-i Makefile.am || die "Cannot correct package name"
# this test is broken
diff --git a/sci-chemistry/apbs/files/apbs-1.3-blas.patch b/sci-chemistry/apbs/files/apbs-1.3-blas.patch
new file mode 100644
index 000000000000..08d99ce6a277
--- /dev/null
+++ b/sci-chemistry/apbs/files/apbs-1.3-blas.patch
@@ -0,0 +1,16 @@
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6020fbf..65dd770 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1021,7 +1021,7 @@ if test x"$with_blas" != "xno" -a -n "$with_blas"; then
+ LDFLAGS_SAVE=${LDFLAGS};
+ CPPFLAGS_SAVE=${CPPFLAGS};
+ LDFLAGS="-L${maloc_lib_path} ${blas_lib}";
+- AC_CHECK_LIB(${blas_name},dscal,
++ AC_CHECK_LIB(m,dscal,
+ [blas_found="yes"],
+ [blas_found=""],
+ [${blas_lib} ${socket_lib} ${nsl_lib} ${math_lib}])