summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-19 08:48:08 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-19 08:48:08 +0000
commite055c403b01476a1e25f48fe40910c79c0901f25 (patch)
treec32608c57c0e6b98ac6492cdd006c32ee216498f /sci-chemistry
parentTake maintainership (proxy user seems inactive) (diff)
downloadgentoo-2-e055c403b01476a1e25f48fe40910c79c0901f25.tar.gz
gentoo-2-e055c403b01476a1e25f48fe40910c79c0901f25.tar.bz2
gentoo-2-e055c403b01476a1e25f48fe40910c79c0901f25.zip
sci-chemistry/shelx: Bump to EAPI=5, add missing die, add prefix support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/shelx/ChangeLog10
-rw-r--r--sci-chemistry/shelx/metadata.xml8
-rw-r--r--sci-chemistry/shelx/shelx-20060317-r2.ebuild75
3 files changed, 87 insertions, 6 deletions
diff --git a/sci-chemistry/shelx/ChangeLog b/sci-chemistry/shelx/ChangeLog
index b75e315a60fa..fd8823cc38b2 100644
--- a/sci-chemistry/shelx/ChangeLog
+++ b/sci-chemistry/shelx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/shelx
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/ChangeLog,v 1.22 2012/10/19 10:29:30 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/ChangeLog,v 1.23 2014/05/19 08:48:08 jlec Exp $
+
+*shelx-20060317-r2 (19 May 2014)
+
+ 19 May 2014; Justin Lecher <jlec@gentoo.org> +shelx-20060317-r2.ebuild,
+ metadata.xml:
+ Bump to EAPI=5, add missing die, add prefix support
19 Oct 2012; Justin Lecher <jlec@gentoo.org> shelx-20060317-r1.ebuild,
metadata.xml:
diff --git a/sci-chemistry/shelx/metadata.xml b/sci-chemistry/shelx/metadata.xml
index 851c78e7d251..dcdde22fade9 100644
--- a/sci-chemistry/shelx/metadata.xml
+++ b/sci-chemistry/shelx/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <use>
- <flag name="dosformat">Use CR/LF to end lines; useful in mixed Linux/Windows
+ <herd>sci-chemistry</herd>
+ <use>
+ <flag name="dosformat">Use CR/LF to end lines; useful in mixed Linux/Windows
environments</flag>
- </use>
+ </use>
</pkgmetadata>
diff --git a/sci-chemistry/shelx/shelx-20060317-r2.ebuild b/sci-chemistry/shelx/shelx-20060317-r2.ebuild
new file mode 100644
index 000000000000..8647755c3a78
--- /dev/null
+++ b/sci-chemistry/shelx/shelx-20060317-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/shelx-20060317-r2.ebuild,v 1.1 2014/05/19 08:48:08 jlec Exp $
+
+EAPI=5
+
+inherit autotools eutils fortran-2 flag-o-matic toolchain-funcs
+
+DESCRIPTION="Programs for crystal structure determination from single-crystal diffraction data"
+HOMEPAGE="http://shelx.uni-ac.gwdg.de/SHELX/"
+SRC_URI="
+ ${P}.tgz
+ openmp? ( ${P}-mp.tgz )"
+
+SLOT="0"
+LICENSE="free-noncomm"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="dosformat openmp"
+
+S="${WORKDIR}/unix"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Go to ${HOMEPAGE}"
+ elog "Fill out the application form, and send it in."
+ elog "Download unix.tgz, rename it to ${P}.tgz,"
+ use openmp && elog "download mp.tgz, rename it to ${P}-mp.tgz,"
+ elog "and place renamed tarballs in ${DISTDIR}."
+}
+
+src_prepare() {
+ EPATCH_OPTS="-p1" \
+ epatch \
+ "${FILESDIR}"/${PV}-autotool.patch \
+ "${FILESDIR}"/${PV}-gfortran.patch
+
+ if use openmp; then
+ for i in shelxh shelxlv; do
+ cp "${WORKDIR}"/mp/${i}_omp.f "${WORKDIR}"/unix/${i}.f || die
+ done
+ fi
+
+ sed -i \
+ -e "s:CIFDIR='/usr/local/bin/':CIFDIR='${EPREFIX}/usr/share/${PN}/':g" \
+ "${S}"/ciftab.f || die
+
+ if use dosformat; then
+ sed -i \
+ -e "s/KD=CHAR(32)/KD=CHAR(13)/g" \
+ "${S}"/*f
+ fi
+
+ cd "${S}" || die
+ eautoreconf
+}
+
+src_configure() {
+ case $(tc-getF77) in
+ *gfortran) append-flags -fopenmp ;;
+ ifort) append-flags -openmp ;;
+ *) ewarn "Please add any necessary OpenMP build flags to F77FLAGS." ;;
+ esac
+
+ econf \
+ FC="$(tc-getFC)"
+}
+
+pkg_info() {
+ use openmp && einfo "Set OMP_NUM_THREADS to the number of threads you want."
+}
+
+pkg_postinst() {
+ pkg_info
+}