summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-15 11:57:15 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-15 11:57:15 +0000
commitef3a61b04f773e705b9795f1eccff45371b854dd (patch)
tree0e2df0111f7c1ae6fd5f539b03dfeb905bbb9159 /sci-chemistry
parentConditionally install experimental python bindings. (diff)
downloadgentoo-2-ef3a61b04f773e705b9795f1eccff45371b854dd.tar.gz
gentoo-2-ef3a61b04f773e705b9795f1eccff45371b854dd.tar.bz2
gentoo-2-ef3a61b04f773e705b9795f1eccff45371b854dd.zip
sci-chemistry/pymol-plugins-bni-tools: Version Bump; move to new python eclasses
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/ChangeLog10
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/metadata.xml11
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild35
3 files changed, 48 insertions, 8 deletions
diff --git a/sci-chemistry/pymol-plugins-bni-tools/ChangeLog b/sci-chemistry/pymol-plugins-bni-tools/ChangeLog
index 6e12d34d76a3..37211af46325 100644
--- a/sci-chemistry/pymol-plugins-bni-tools/ChangeLog
+++ b/sci-chemistry/pymol-plugins-bni-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol-plugins-bni-tools
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-bni-tools/ChangeLog,v 1.3 2010/04/25 11:30:23 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-bni-tools/ChangeLog,v 1.4 2013/07/15 11:57:15 jlec Exp $
+
+*pymol-plugins-bni-tools-0.27 (15 Jul 2013)
+
+ 15 Jul 2013; Justin Lecher <jlec@gentoo.org>
+ +pymol-plugins-bni-tools-0.27.ebuild, metadata.xml:
+ Version Bump; move to new python eclasses
27 Feb 2010; Justin Lecher <jlec@gentoo.org>
pymol-plugins-bni-tools-0.25.1.ebuild:
diff --git a/sci-chemistry/pymol-plugins-bni-tools/metadata.xml b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
index 4aaae064be71..c0432fefe855 100644
--- a/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
+++ b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
@@ -1,10 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- <name>Justin Lecher (jlec)</name>
- </maintainer>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher (jlec)</name>
+ </maintainer>
</pkgmetadata>
-
diff --git a/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild
new file mode 100644
index 000000000000..9abf09d0930d
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild,v 1.1 2013/07/15 11:57:15 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 versionator
+
+MY_PN="${PN#pymol-plugins-}"
+MY_P="${MY_PN}-$(delete_version_separator 1)"
+MY_P_DOT="${MY_PN}-${PV}"
+
+DESCRIPTION="Gives Pymol additional functionalities and presets to the PyMOL GUI"
+HOMEPAGE="http://bni-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${MY_P_DOT}/${MY_P}.zip"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install(){
+ python_moduleinto pmg_tk/startup
+ python_parallel_foreach_impl python_domodule bni-tools.py
+ python_parallel_foreach_impl python_optimize
+ dodoc readme.txt
+ dohtml ShortCommandDescription.html
+}