summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-06-03 06:17:36 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-06-03 06:17:36 +0000
commitffda4e519b185cbeb3ef05fe7228dbdeef4a37e2 (patch)
tree7e1af0b3976a06f419c16cc61ee81415574928f3 /sci-chemistry
parentActually block xorg-server, rather than depending on an older version. (diff)
downloadgentoo-2-ffda4e519b185cbeb3ef05fe7228dbdeef4a37e2.tar.gz
gentoo-2-ffda4e519b185cbeb3ef05fe7228dbdeef4a37e2.tar.bz2
gentoo-2-ffda4e519b185cbeb3ef05fe7228dbdeef4a37e2.zip
Bump to latest. Fix for gcc4 by linking against libf2c in the non-gcc3 case. Keyword ~ppc.
(Portage version: 2.1_rc3-r1)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/platon/ChangeLog11
-rw-r--r--sci-chemistry/platon/files/digest-platon-200605303
-rw-r--r--sci-chemistry/platon/platon-20060530.ebuild70
3 files changed, 82 insertions, 2 deletions
diff --git a/sci-chemistry/platon/ChangeLog b/sci-chemistry/platon/ChangeLog
index f9aed2d2e3e6..ba7440fd7291 100644
--- a/sci-chemistry/platon/ChangeLog
+++ b/sci-chemistry/platon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/platon
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.1 2005/12/16 05:32:46 spyderous Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.2 2006/06/03 06:17:36 spyderous Exp $
+
+*platon-20060530 (03 Jun 2006)
+
+ 03 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +platon-20060530.ebuild:
+ Bump to latest. Fix for gcc4 by linking against libf2c in the non-gcc3 case.
+ Keyword ~ppc.
*platon-20051215 (16 Dec 2005)
diff --git a/sci-chemistry/platon/files/digest-platon-20060530 b/sci-chemistry/platon/files/digest-platon-20060530
new file mode 100644
index 000000000000..1d63c554a930
--- /dev/null
+++ b/sci-chemistry/platon/files/digest-platon-20060530
@@ -0,0 +1,3 @@
+MD5 aaef894560da0da67d4a33d0b6562a1f platon-20060530.tar.gz 6688336
+RMD160 74a98c33b499524b80a3787e06e9eb015fa57d13 platon-20060530.tar.gz 6688336
+SHA256 f41ce66c1035642092391b02de8df64ea59f8358d2cd771cae68a766da1b8d50 platon-20060530.tar.gz 6688336
diff --git a/sci-chemistry/platon/platon-20060530.ebuild b/sci-chemistry/platon/platon-20060530.ebuild
new file mode 100644
index 000000000000..d660d16717cf
--- /dev/null
+++ b/sci-chemistry/platon/platon-20060530.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20060530.ebuild,v 1.1 2006/06/03 06:17:36 spyderous Exp $
+
+inherit fortran toolchain-funcs
+
+FORTRAN="g77 gfortran"
+DESCRIPTION="Versatile, SHELX-97 compatible, multipurpose crystallographic tool"
+HOMEPAGE="http://www.cryst.chem.uu.nl/platon/"
+SRC_URI="${P}.tar.gz"
+RESTRICT="fetch"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+# Can't do libf2c dependent on whether <gcc-4 is selected for the build,
+# so we must always require it
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ dev-libs/libf2c"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Download ${A/-${PV}} from ${HOMEPAGE},"
+ einfo "rename it to ${A} and place it"
+ einfo "in ${DISTDIR}."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gunzip platon.f.Z xdrvr.c.gz
+}
+
+src_compile() {
+ local F2C
+ # Needs signal_ and system_, which g77 and libf2c provide,
+ # but gfortran does not
+ if [[ ${FORTRANC} != g77 ]]; then
+ F2C="-lf2c"
+ fi
+
+ COMMAND="$(tc-getCC) -c ${CFLAGS} xdrvr.c"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of xdrvr.c failed"
+ COMMAND="${FORTRANC} -c ${FFLAGS:- -O2} -fno-second-underscore platon.f"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of platon.f failed"
+ COMMAND="${FORTRANC} -o platon ${LDFLAGS} platon.o xdrvr.o -lX11 ${F2C}"
+ echo ${COMMAND}
+ ${COMMAND} || die "Linking failed"
+}
+
+src_install() {
+ dobin platon
+
+ dosym platon /usr/bin/pluton
+ dosym platon /usr/bin/s
+ dosym platon /usr/bin/cifchk
+ dosym platon /usr/bin/helena
+ dosym platon /usr/bin/stidy
+
+ insinto /usr/lib/platon
+ doins check.def
+
+ echo "CHECKDEF=\"/usr/lib/platon/check.def\"" > ${T}/env.d
+ newenvd ${T}/env.d 50platon
+
+ dodoc README.* VALIDATION.DOC
+}