summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-07-29 13:36:35 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-07-29 13:36:35 +0000
commit76d4b4703781698088df0d193e50aaef18b8ae3d (patch)
tree59957668809865565016b3a6ce8a953f701d9676 /sci-electronics/electric/electric-8.05.ebuild
parentFix building with >= GCC 4.x, bug 153363. Thanks to Maximilian Grothusmann fo... (diff)
downloadgentoo-2-76d4b4703781698088df0d193e50aaef18b8ae3d.tar.gz
gentoo-2-76d4b4703781698088df0d193e50aaef18b8ae3d.tar.bz2
gentoo-2-76d4b4703781698088df0d193e50aaef18b8ae3d.zip
Version bump.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'sci-electronics/electric/electric-8.05.ebuild')
-rw-r--r--sci-electronics/electric/electric-8.05.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-electronics/electric/electric-8.05.ebuild b/sci-electronics/electric/electric-8.05.ebuild
new file mode 100644
index 000000000000..c1df507de6fd
--- /dev/null
+++ b/sci-electronics/electric/electric-8.05.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/electric/electric-8.05.ebuild,v 1.1 2007/07/29 13:36:35 calchan Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="Complete Electronic Design Automation (EDA) system that can handle many forms of circuit design"
+HOMEPAGE="http://www.gnu.org/software/electric/electric.html"
+SRC_URI="mirror://gnu/electric/${PN}Binary-${PV}.jar"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_install() {
+ java-pkg_dojar ${DISTDIR}/${PN}Binary-${PV}.jar
+ newicon com/sun/electric/tool/user/help/helphtml/iconplug.png electric.png
+ make_wrapper electric "java -jar /usr/share/electric/lib/${PN}Binary-${PV}.jar"
+ make_desktop_entry electric "Electric VLSI Design System" electric.png "Application;Engineering;Electronics"
+}