summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2006-04-07 22:40:57 +0000
committerTim Yamin <plasmaroo@gentoo.org>2006-04-07 22:40:57 +0000
commit8615ef540919d0ed1440ec33ba8a849302da46e1 (patch)
tree9651fd3610300ba56e3054ebf69692fd4213a703 /sci-electronics/gnucap
parentRemove ciaranm from metadata.xml. (diff)
downloadgentoo-2-8615ef540919d0ed1440ec33ba8a849302da46e1.tar.gz
gentoo-2-8615ef540919d0ed1440ec33ba8a849302da46e1.tar.bz2
gentoo-2-8615ef540919d0ed1440ec33ba8a849302da46e1.zip
Version bump; fix #125871.
(Portage version: 2.1_pre7)
Diffstat (limited to 'sci-electronics/gnucap')
-rw-r--r--sci-electronics/gnucap/ChangeLog8
-rw-r--r--sci-electronics/gnucap/files/digest-gnucap-200601173
-rw-r--r--sci-electronics/gnucap/files/gnucap-20060117.gcc-4.1.patch26
-rw-r--r--sci-electronics/gnucap/gnucap-20060117.ebuild41
4 files changed, 77 insertions, 1 deletions
diff --git a/sci-electronics/gnucap/ChangeLog b/sci-electronics/gnucap/ChangeLog
index 3723ccbf9851..0a5b575f9300 100644
--- a/sci-electronics/gnucap/ChangeLog
+++ b/sci-electronics/gnucap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/gnucap
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.10 2006/04/07 20:22:38 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.11 2006/04/07 22:40:57 plasmaroo Exp $
+
+*gnucap-20060117 (07 Apr 2006)
+
+ 07 Apr 2006; <plasmaroo@gentoo.org> +gnucap-20060117.ebuild,
+ +files/gnucap-20060117.gcc-4.1.patch:
+ Version bump; fix #125871.
07 Apr 2006; <plasmaroo@gentoo.org> gnucap-0.34.ebuild,
gnucap-20050220.ebuild, gnucap-20050808.ebuild:
diff --git a/sci-electronics/gnucap/files/digest-gnucap-20060117 b/sci-electronics/gnucap/files/digest-gnucap-20060117
new file mode 100644
index 000000000000..e401a4cea992
--- /dev/null
+++ b/sci-electronics/gnucap/files/digest-gnucap-20060117
@@ -0,0 +1,3 @@
+MD5 c76b5893a49d5ba23d41c9cb653e20c7 gnucap-2006-01-17.tar.gz 1331307
+RMD160 ae228bc60ce99108de59c63ae35dfbbfe0bd6bd9 gnucap-2006-01-17.tar.gz 1331307
+SHA256 c2ecbb7241c18b50c0c2c42cfa02e42fa3e5efd27ae4e553f6f388c203f6254c gnucap-2006-01-17.tar.gz 1331307
diff --git a/sci-electronics/gnucap/files/gnucap-20060117.gcc-4.1.patch b/sci-electronics/gnucap/files/gnucap-20060117.gcc-4.1.patch
new file mode 100644
index 000000000000..1f952335478e
--- /dev/null
+++ b/sci-electronics/gnucap/files/gnucap-20060117.gcc-4.1.patch
@@ -0,0 +1,26 @@
+diff -ur gnucap-2006-01-17/src/e_card.h gnucap-2006-01-17-plasmaroo/src/e_card.h
+--- gnucap-2006-01-17/src/e_card.h 2006-01-18 02:52:26.000000000 +0000
++++ gnucap-2006-01-17-plasmaroo/src/e_card.h 2006-04-07 23:10:54.000000000 +0100
+@@ -146,6 +146,8 @@
+ return false;
+ }
+ }
++
++CARD_LIST::fat_iterator findbranch(CS&,CARD_LIST::fat_iterator);
+ /*--------------------------------------------------------------------------*/
+ inline CARD_LIST::fat_iterator findbranch(CS& cmd, CARD_LIST* cl)
+ {
+diff -ur gnucap-2006-01-17/src/e_compon.h gnucap-2006-01-17-plasmaroo/src/e_compon.h
+--- gnucap-2006-01-17/src/e_compon.h 2006-01-18 02:52:26.000000000 +0000
++++ gnucap-2006-01-17-plasmaroo/src/e_compon.h 2006-04-07 23:10:10.000000000 +0100
+@@ -97,6 +98,10 @@
+ mutable const MODEL_CARD* _model;
+ int _attach_count;
+ };
++
++void attach_common(COMMON_COMPONENT* c, COMMON_COMPONENT** to);
++void detach_common(COMMON_COMPONENT** from);
++
+ /*--------------------------------------------------------------------------*/
+ /* note on _attach_count ...
+ * The int argument is the initial _attach_count (default = 0)
diff --git a/sci-electronics/gnucap/gnucap-20060117.ebuild b/sci-electronics/gnucap/gnucap-20060117.ebuild
new file mode 100644
index 000000000000..602a989543cb
--- /dev/null
+++ b/sci-electronics/gnucap/gnucap-20060117.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-20060117.ebuild,v 1.1 2006/04/07 22:40:57 plasmaroo Exp $
+
+inherit eutils
+
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6}"
+
+DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
+SRC_URI="http://geda.seul.org/dist/gnucap-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.geda.seul.org/tools/gnucap"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=""
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack!"
+ epatch ${FILESDIR}/${P}.gcc-4.1.patch || die "Failed to apply GCC 4.1 patch!"
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ insinto /usr/bin
+ doins src/O/gnucap
+ doins ibis/O/gnucap-ibis
+
+ fperms 755 /usr/bin/gnucap
+ fperms 755 /usr/bin/gnucap-ibis
+
+ cd doc
+ doman gnucap.1 gnucap-ibis.1
+}