summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-27 20:01:41 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-27 20:01:41 +0000
commitc05c336c872f5f449bd2f73aa0e547bdd356acde (patch)
tree5fcbae92bf64f3f740bdc0144d6bf89e2fab2476 /sci-electronics/modelsim/modelsim-5.7d.ebuild
parentMoving to sci-electronics/modelsim (diff)
downloadgentoo-2-c05c336c872f5f449bd2f73aa0e547bdd356acde.tar.gz
gentoo-2-c05c336c872f5f449bd2f73aa0e547bdd356acde.tar.bz2
gentoo-2-c05c336c872f5f449bd2f73aa0e547bdd356acde.zip
Moved from app-sci/modelsim to sci-electronics/modelsim.
Diffstat (limited to 'sci-electronics/modelsim/modelsim-5.7d.ebuild')
-rw-r--r--sci-electronics/modelsim/modelsim-5.7d.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-electronics/modelsim/modelsim-5.7d.ebuild b/sci-electronics/modelsim/modelsim-5.7d.ebuild
new file mode 100644
index 000000000000..1a23444fbcb5
--- /dev/null
+++ b/sci-electronics/modelsim/modelsim-5.7d.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/modelsim/modelsim-5.7d.ebuild,v 1.1 2004/12/27 20:01:41 ribosome Exp $
+
+DESCRIPTION="VHDL and mixed-VHDL/Verilog simulator"
+HOMEPAGE="http://www.model.com/"
+SRC_URI="modeltech-base.tar.gz
+ modeltech-linux.exe.gz
+ doc? ( modeltech-docs.tar.gz )"
+
+LICENSE="modelsim"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="-* x86"
+RESTRICT="nostrip fetch"
+
+DEPEND=""
+
+pkg_nofetch() {
+ einfo "You must download the files yourself and put them in ${DISTDIR}"
+ einfo "Goto http://www.model.com/products/release.asp"
+}
+
+src_unpack() {
+ unpack modeltech-base.tar.gz
+ use doc && unpack modeltech-docs.tar.gz
+ gzip -c -d ${DISTDIR}/modeltech-linux.exe.gz > modeltech-linux.exe || die "gzip -c -d"
+ chmod +x modeltech-linux.exe
+ echo -n -e "D\nAgree\n"|./modeltech-linux.exe > /dev/null
+}
+
+src_install() {
+ dodir /opt
+ cp -r ${WORKDIR}/modeltech ${D}/opt/
+ insinto /etc/env.d
+ echo "PATH=/opt/modeltech/bin" > 90modelsimSE
+ doins 90modelsimSE
+}
+
+pkg_postinst() {
+ einfo "Read the installation manual for details of configuring a"
+ einfo "standalone license server, or set LM_LICENSE_FILE=xxxx@host"
+ einfo "if you already have a running license server"
+}