summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-27 20:05:13 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-27 20:05:13 +0000
commit402f9503ec8b24114958857fccfc05d32dbd7496 (patch)
tree4784177bdfd840aa40704a3ecb001f98d215ca25 /sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild
parentMoving to sci-electronics/ng-spice-rework (diff)
downloadgentoo-2-402f9503ec8b24114958857fccfc05d32dbd7496.tar.gz
gentoo-2-402f9503ec8b24114958857fccfc05d32dbd7496.tar.bz2
gentoo-2-402f9503ec8b24114958857fccfc05d32dbd7496.zip
Moved from app-sci/ng-spice-rework to sci-electronics/ng-spice-rework.
Diffstat (limited to 'sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild')
-rw-r--r--sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild b/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild
new file mode 100644
index 000000000000..5520710177a6
--- /dev/null
+++ b/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild,v 1.1 2004/12/27 20:05:13 ribosome Exp $
+
+DESCRIPTION="NGSpice - The Next Generation Spice (Circuit Emulator)"
+SRC_URI="http://www.geda.seul.org/dist/ngspice-rework${PV}.tgz"
+HOMEPAGE="http://ngspice.sourceforge.net"
+
+SLOT="0"
+IUSE=""
+LICENSE="BSD GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ local infoFile
+ for infoFile in doc/ngspice.info*; do
+ echo 'INFO-DIR-SECTION EDA' >> ${infoFile}
+ echo 'START-INFO-DIR-ENTRY' >> ${infoFile}
+ echo '* NGSPICE: (ngspice). Electronic Circuit Simulator.' >> ${infoFile}
+ echo 'END-INFO-DIR-ENTRY' >> ${infoFile}
+ done
+
+ make DESTDIR=${D} install || die
+ dodoc COPYING COPYRIGHT CREDITS ChangeLog README
+}