summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-23 20:56:36 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-23 20:56:36 +0000
commit696e78e364fd769e1546068ac82422785af613c3 (patch)
tree1204b8a72aa5c34ff5cd512aae362717afb7e5da /sci-electronics
parentarm stable, bug #427116 (diff)
downloadgentoo-2-696e78e364fd769e1546068ac82422785af613c3.tar.gz
gentoo-2-696e78e364fd769e1546068ac82422785af613c3.tar.bz2
gentoo-2-696e78e364fd769e1546068ac82422785af613c3.zip
sci-electronics/alliance: Fix implicit declarations of built-in functions
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/alliance/ChangeLog8
-rw-r--r--sci-electronics/alliance/alliance-5.0.20110203.ebuild8
-rw-r--r--sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch119
-rw-r--r--sci-electronics/alliance/metadata.xml4
4 files changed, 132 insertions, 7 deletions
diff --git a/sci-electronics/alliance/ChangeLog b/sci-electronics/alliance/ChangeLog
index 76e4fe422731..4a98a2950ab8 100644
--- a/sci-electronics/alliance/ChangeLog
+++ b/sci-electronics/alliance/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/alliance
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/alliance/ChangeLog,v 1.16 2011/07/25 06:04:27 tomjbe Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/alliance/ChangeLog,v 1.17 2012/07/23 20:56:36 jlec Exp $
+
+ 23 Jul 2012; Justin Lecher <jlec@gentoo.org> alliance-5.0.20110203.ebuild,
+ +files/alliance-5.0.20110203-impl-dec.patch, metadata.xml:
+ Fix implicit declarations of built-in functions
*alliance-5.0.20110203 (25 Jul 2011)
diff --git a/sci-electronics/alliance/alliance-5.0.20110203.ebuild b/sci-electronics/alliance/alliance-5.0.20110203.ebuild
index 1229031f0088..e201be90c77f 100644
--- a/sci-electronics/alliance/alliance-5.0.20110203.ebuild
+++ b/sci-electronics/alliance/alliance-5.0.20110203.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/alliance/alliance-5.0.20110203.ebuild,v 1.1 2011/07/25 06:04:27 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/alliance/alliance-5.0.20110203.ebuild,v 1.2 2012/07/23 20:56:36 jlec Exp $
EAPI=4
@@ -29,7 +29,9 @@ S="${WORKDIR}/${PN}-${UPSTREAM_VERSION}"
src_prepare() {
#fix buffer overrun (bug 340789)
- epatch "${FILESDIR}"/${PN}-${UPSTREAM_VERSION}.20070718-overun.patch
+ epatch \
+ "${FILESDIR}"/${PN}-${UPSTREAM_VERSION}.20070718-overun.patch \
+ "${FILESDIR}"/${P}-impl-dec.patch
}
src_configure() {
diff --git a/sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch b/sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch
new file mode 100644
index 000000000000..c1ef31619167
--- /dev/null
+++ b/sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch
@@ -0,0 +1,119 @@
+ dreal/src/GRD_error.c | 1 +
+ lynx/src/cutelbow.c | 1 +
+ lynx/src/parse.c | 1 +
+ mips_asm/src/mips_util.c | 1 +
+ proof/src/proof_main.c | 1 +
+ proof/src/proof_util.c | 1 +
+ xfsm/src/XFS_error.c | 1 +
+ xgra/src/XGR_error.c | 1 +
+ xsch/src/XSC_error.c | 1 +
+ 9 files changed, 9 insertions(+), 0 deletions(-)
+
+diff --git a/dreal/src/GRD_error.c b/dreal/src/GRD_error.c
+index e3baba6..c00bf13 100644
+--- a/dreal/src/GRD_error.c
++++ b/dreal/src/GRD_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "mph.h"
+ # include "rds.h"
+diff --git a/lynx/src/cutelbow.c b/lynx/src/cutelbow.c
+index 7411f35..306649b 100644
+--- a/lynx/src/cutelbow.c
++++ b/lynx/src/cutelbow.c
+@@ -43,6 +43,7 @@
+ \------------------------------------------------------------*/
+
+ # include <stdio.h>
++# include <string.h>
+
+ # include "mut.h"
+ # include "mlo.h"
+diff --git a/lynx/src/parse.c b/lynx/src/parse.c
+index ed8a2e5..9077c3f 100644
+--- a/lynx/src/parse.c
++++ b/lynx/src/parse.c
+@@ -43,6 +43,7 @@
+ \------------------------------------------------------------*/
+
+ # include <stdio.h>
++# include <string.h>
+
+ # include "mut.h"
+ # include "mlo.h"
+diff --git a/mips_asm/src/mips_util.c b/mips_asm/src/mips_util.c
+index f5fa55f..5ad6a4f 100644
+--- a/mips_asm/src/mips_util.c
++++ b/mips_asm/src/mips_util.c
+@@ -30,6 +30,7 @@
+ /* ###--------------------------------------------------------------### */
+
+ #include <stdio.h>
++#include <string.h>
+ #include "mut.h"
+ #include "log.h"
+ #include "beh.h"
+diff --git a/proof/src/proof_main.c b/proof/src/proof_main.c
+index b6eee94..3d8a91a 100644
+--- a/proof/src/proof_main.c
++++ b/proof/src/proof_main.c
+@@ -32,6 +32,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "mut.h"
+ #include "log.h"
+ #include "beh.h"
+diff --git a/proof/src/proof_util.c b/proof/src/proof_util.c
+index 841937f..fa20ba1 100644
+--- a/proof/src/proof_util.c
++++ b/proof/src/proof_util.c
+@@ -31,6 +31,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "mut.h"
+ #include "log.h"
+diff --git a/xfsm/src/XFS_error.c b/xfsm/src/XFS_error.c
+index 20ccd0a..5aded2b 100644
+--- a/xfsm/src/XFS_error.c
++++ b/xfsm/src/XFS_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "aut.h"
+ # include "abl.h"
+diff --git a/xgra/src/XGR_error.c b/xgra/src/XGR_error.c
+index 3204423..b2d35c5 100644
+--- a/xgra/src/XGR_error.c
++++ b/xgra/src/XGR_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "aut.h"
+ # include "XSB.h"
+diff --git a/xsch/src/XSC_error.c b/xsch/src/XSC_error.c
+index 9bdf65e..b8c5689 100644
+--- a/xsch/src/XSC_error.c
++++ b/xsch/src/XSC_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "aut.h"
+ # include "mlo.h"
diff --git a/sci-electronics/alliance/metadata.xml b/sci-electronics/alliance/metadata.xml
index 5f060ce3ce28..8160b1a44dde 100644
--- a/sci-electronics/alliance/metadata.xml
+++ b/sci-electronics/alliance/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-electronics</herd>
- <longdescription>
+ <herd>sci-electronics</herd>
+ <longdescription>
Alliance is a complete set of free CAD tools and portable libraries for VLSI
design. It includes a VHDL compiler and simulator, logic synthesis tools, and
automatic place and route tools. A complete set of portable CMOS libraries is