summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-10-17 00:33:19 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-10-17 00:33:19 +0000
commita0ba57c789e51e70496905cfbb0c06bb7615e801 (patch)
tree007d1d17160920a2c9f99987f636f2a95e64df74 /sci-electronics
parentChanged dependencies to be x86-specific and added amd64 dependencies for bug ... (diff)
downloadgentoo-2-a0ba57c789e51e70496905cfbb0c06bb7615e801.tar.gz
gentoo-2-a0ba57c789e51e70496905cfbb0c06bb7615e801.tar.bz2
gentoo-2-a0ba57c789e51e70496905cfbb0c06bb7615e801.zip
Add patch for GCC 4.2. Bug #186905 by Kent Fredric.
(Portage version: 2.1.3.14)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ktechlab/ChangeLog6
-rw-r--r--sci-electronics/ktechlab/files/ktechlab-0.3.6-gcc42.patch21
-rw-r--r--sci-electronics/ktechlab/ktechlab-0.3.6.ebuild4
3 files changed, 28 insertions, 3 deletions
diff --git a/sci-electronics/ktechlab/ChangeLog b/sci-electronics/ktechlab/ChangeLog
index a4c960559446..c306895f50d6 100644
--- a/sci-electronics/ktechlab/ChangeLog
+++ b/sci-electronics/ktechlab/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/ktechlab
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ktechlab/ChangeLog,v 1.12 2007/07/18 01:55:33 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ktechlab/ChangeLog,v 1.13 2007/10/17 00:33:18 dirtyepic Exp $
+
+ 17 Oct 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/ktechlab-0.3.6-gcc42.patch, ktechlab-0.3.6.ebuild:
+ Add patch for GCC 4.2. Bug #186905 by Kent Fredric.
18 Jul 2007; Marcus D. Hanwell <cryos@gentoo.org> -ktechlab-0.3.ebuild,
ktechlab-0.3.6.ebuild:
diff --git a/sci-electronics/ktechlab/files/ktechlab-0.3.6-gcc42.patch b/sci-electronics/ktechlab/files/ktechlab-0.3.6-gcc42.patch
new file mode 100644
index 000000000000..77f5c1312396
--- /dev/null
+++ b/sci-electronics/ktechlab/files/ktechlab-0.3.6-gcc42.patch
@@ -0,0 +1,21 @@
+diff -Naur ktechlab-0.3-orig/src/itemdocument.h ktechlab-0.3/src/itemdocument.h
+--- ktechlab-0.3-orig/src/itemdocument.h 2007-08-06 12:52:55.000000000 -0600
++++ ktechlab-0.3/src/itemdocument.h 2007-08-06 12:55:24.000000000 -0600
+@@ -112,7 +112,7 @@
+ * (such as PIC/START) have restrictions, and can only have one instance of
+ * themselves on the canvas, and adds the operation to the undo list
+ */
+- virtual Item* addItem( const QString &id, const QPoint &p, bool newItem ) = 0l;
++ virtual Item* addItem( const QString &id, const QPoint &p, bool newItem ) = 0;
+ /**
+ * @returns A pointer to the canvas
+ */
+@@ -215,7 +215,7 @@
+ * Set the given QCanvasItem (which will attempt to be casted to known
+ * items to be deleted.
+ */
+- virtual void appendDeleteList( QCanvasItem * ) = 0l;
++ virtual void appendDeleteList( QCanvasItem * ) = 0;
+ /**
+ * Save the current state of the document to the undo/redo history.
+ * @param actionTicket if this is non-negative, and the last state save
diff --git a/sci-electronics/ktechlab/ktechlab-0.3.6.ebuild b/sci-electronics/ktechlab/ktechlab-0.3.6.ebuild
index 9b9806c8ee6c..598cebeda930 100644
--- a/sci-electronics/ktechlab/ktechlab-0.3.6.ebuild
+++ b/sci-electronics/ktechlab/ktechlab-0.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ktechlab/ktechlab-0.3.6.ebuild,v 1.2 2007/07/18 01:55:33 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ktechlab/ktechlab-0.3.6.ebuild,v 1.3 2007/10/17 00:33:18 dirtyepic Exp $
inherit kde
@@ -22,4 +22,4 @@ UNSERMAKE=""
S="${WORKDIR}/${PN}-0.3"
-PATCHES="${FILESDIR}/${PN}-0.3-gcc-4.1.patch"
+PATCHES="${FILESDIR}/${PN}-0.3-gcc-4.1.patch ${FILESDIR}/${P}-gcc42.patch"