summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-01-30 20:37:45 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-01-30 20:37:45 +0000
commitc164cccb44ab4e43eb39f4404330c0f61d231599 (patch)
tree1185b437f2e57e6d16ec80a2a32409580f630d7b /sci-electronics
parentInitial import thanks to Steven De Bock <steven_debock@yahoo.com> and masterd... (diff)
downloadgentoo-2-c164cccb44ab4e43eb39f4404330c0f61d231599.tar.gz
gentoo-2-c164cccb44ab4e43eb39f4404330c0f61d231599.tar.bz2
gentoo-2-c164cccb44ab4e43eb39f4404330c0f61d231599.zip
Version bump.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/ChangeLog9
-rw-r--r--sci-electronics/kicad/files/digest-kicad-200701156
-rw-r--r--sci-electronics/kicad/kicad-20070115.ebuild101
3 files changed, 114 insertions, 2 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index f11c5e8f1032..bd502af862c9 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/kicad
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.13 2006/10/15 16:23:34 calchan Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.14 2007/01/30 20:37:45 calchan Exp $
+
+*kicad-20070115 (30 Jan 2007)
+
+ 30 Jan 2007; Denis Dupeyron <calchan@gentoo.org> +kicad-20070115.ebuild:
+ Version bump.
15 Oct 2006; Denis Dupeyron <calchan@gentoo.org> -kicad-20060626.ebuild:
Removed old ebuild.
diff --git a/sci-electronics/kicad/files/digest-kicad-20070115 b/sci-electronics/kicad/files/digest-kicad-20070115
new file mode 100644
index 000000000000..1d77f23282b4
--- /dev/null
+++ b/sci-electronics/kicad/files/digest-kicad-20070115
@@ -0,0 +1,6 @@
+MD5 d1530c44a44c620894ff0c98fd582a02 kicad-2007-01-15.tgz 61333975
+RMD160 122313a847ab78bc8e7c796956b7df84e8c789d7 kicad-2007-01-15.tgz 61333975
+SHA256 10a2ada595dd84d54fbe013f3230894999996660916698eae78773fd168b4ba1 kicad-2007-01-15.tgz 61333975
+MD5 b49d0cb1a64334807c6c615bde9f0c67 kicad-20070115.tar.bz2 11653448
+RMD160 3ca516324aabb8fd7b6038fba34603298bf612de kicad-20070115.tar.bz2 11653448
+SHA256 0c9cfb0241714207498a71122570e453389d977ad33942bac68cec154cfbed35 kicad-20070115.tar.bz2 11653448
diff --git a/sci-electronics/kicad/kicad-20070115.ebuild b/sci-electronics/kicad/kicad-20070115.ebuild
new file mode 100644
index 000000000000..ffc3a8c0321f
--- /dev/null
+++ b/sci-electronics/kicad/kicad-20070115.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.1 2007/01/30 20:37:45 calchan Exp $
+
+inherit wxwidgets
+
+UPSTREAM_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+DESCRIPTION="Electronic schematic and PCB design tools."
+HOMEPAGE="http://www.lis.inpg.fr/realise_au_lis/kicad/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ !minimal? ( ftp://iut-tice.ujf-grenoble.fr/cao/${PN}-${UPSTREAM_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="unicode doc examples minimal"
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ media-gfx/wings"
+
+pkg_setup() {
+ # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
+ WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+
+ # Check for proper wxGTK USE flags.
+ if use unicode; then
+ need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
+ else
+ need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
+ fi
+ built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+
+ # Use the chosen wx-config executable
+ sed -i -e "s:wx-config:${WX_CONFIG}:" libs.* || die "sed failed"
+ sed -i -e "s:wx-config:${WX_CONFIG}:" */makefile.* || die "sed failed"
+}
+
+src_compile() {
+ # Build the main executables
+ emake -f makefile.gtk || die "make failed (main)"
+
+ # Minizip needs to be built independently
+ cd kicad/minizip
+ emake -f makefile.unx || die "make failed (minizip)"
+}
+
+src_install() {
+ # kicad doesn't use the autotools yet
+ exeinto /usr/lib/${PN}/linux
+ doexe eeschema/eeschema
+ doexe pcbnew/pcbnew
+ doexe cvpcb/cvpcb
+ doexe kicad/kicad
+ doexe kicad/minizip/minizip
+ doexe gerbview/gerbview
+ exeinto /usr/lib/${PN}/linux/plugins
+ doexe eeschema/plugins/netlist_form_pads-pcb
+ newicon kicad_icon.png kicad.png
+ make_wrapper kicad "/usr/lib/${PN}/linux/kicad"
+ make_desktop_entry kicad Kicad kicad.png Electronics
+
+ # kicad requires everything to be in the same place
+ cp -pPR library ${D}/usr/lib/${PN}
+ cp -pPR internat ${D}/usr/lib/${PN}
+ cp -pPR template ${D}/usr/lib/${PN}
+ cp -pPR help ${D}/usr/lib/${PN}
+ if ! use minimal ; then
+ cp -pPR ${WORKDIR}/kicad/library ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/modules ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/template ${D}/usr/lib/${PN}
+ if use doc ; then
+ cp -pPR ${WORKDIR}/kicad/help ${D}/usr/lib/${PN}
+ fi
+ if use examples ; then
+ cp -pPR ${WORKDIR}/kicad/demos ${D}/usr/lib/${PN}
+ fi
+ fi
+ dodoc author.txt copyright.txt news.txt contrib.txt version.txt
+}
+
+pkg_postinst() {
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you open old projects,"
+ ewarn "you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ else
+ elog "Please note that the PDF datasheets that can be linked to components from the default libraries"
+ elog "cannot be mirrored by Gentoo for legal reasons."
+ elog "If you want them, you need to download them yourself from :"
+ elog "${HOMEPAGE}"
+ elog "and install them manually."
+ fi
+}