summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-06-13 09:20:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-06-13 09:20:01 +0000
commitbab87906bef3b54585b3a1850ee7cfbb246a0ab1 (patch)
tree0a4d40c3783196870256dd5fe8cae2ee63703edb /sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
parentUnmask latest grass. (diff)
downloadgentoo-2-bab87906bef3b54585b3a1850ee7cfbb246a0ab1.tar.gz
gentoo-2-bab87906bef3b54585b3a1850ee7cfbb246a0ab1.tar.bz2
gentoo-2-bab87906bef3b54585b3a1850ee7cfbb246a0ab1.zip
Detect grass using pkgconfig. Also this package should be removed in favor of gdal[grass] in future.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild')
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..78c8150e3f12
--- /dev/null
+++ b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild,v 1.1 2010/06/13 09:20:01 scarabeus Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="GDAL plugin to access GRASS data"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="sci-libs/gdal
+ >=sci-geosciences/grass-6.4.0_rc6"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_configure() {
+ econf --with-grass=$(pkg-config grass --variable grassdir) --with-gdal
+}
+
+src_install() {
+ #pass the right variables to 'make install' to prevent a sandbox access violation
+ emake DESTDIR="${D}" \
+ GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
+ AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
+ install || die "emake install failure"
+}