summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-01 19:59:04 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-01 19:59:04 +0000
commit7a71626eacb26f85f3ceb06aa6997d148685ed5e (patch)
tree3c71254a31c367fc298ec837d0373cb339705721 /sci-geosciences/geocode-glib
parentUpdate multilib dependencies for libiconv, jpeg, and libpng. Drop dependency ... (diff)
downloadgentoo-2-7a71626eacb26f85f3ceb06aa6997d148685ed5e.tar.gz
gentoo-2-7a71626eacb26f85f3ceb06aa6997d148685ed5e.tar.bz2
gentoo-2-7a71626eacb26f85f3ceb06aa6997d148685ed5e.zip
Version bump and skip tests as they need network (#424719 by flameeyes)
(Portage version: 2.1.13.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sci-geosciences/geocode-glib')
-rw-r--r--sci-geosciences/geocode-glib/ChangeLog7
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-0.99.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-geosciences/geocode-glib/ChangeLog b/sci-geosciences/geocode-glib/ChangeLog
index d71efb2ba026..7eb5b167c242 100644
--- a/sci-geosciences/geocode-glib/ChangeLog
+++ b/sci-geosciences/geocode-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/geocode-glib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/geocode-glib/ChangeLog,v 1.10 2013/03/31 19:07:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/geocode-glib/ChangeLog,v 1.11 2013/08/01 19:59:04 pacho Exp $
+
+*geocode-glib-0.99.1 (01 Aug 2013)
+
+ 01 Aug 2013; Pacho Ramos <pacho@gentoo.org> +geocode-glib-0.99.1.ebuild:
+ Version bump and skip tests as they need network (#424719 by flameeyes)
31 Mar 2013; Pacho Ramos <pacho@gentoo.org> geocode-glib-0.99.0.ebuild:
Adapt to libsoup-2.42 dropping gnome USE and splitting (#463702)
diff --git a/sci-geosciences/geocode-glib/geocode-glib-0.99.1.ebuild b/sci-geosciences/geocode-glib/geocode-glib-0.99.1.ebuild
new file mode 100644
index 000000000000..a27b79f00a54
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-0.99.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/geocode-glib/geocode-glib-0.99.1.ebuild,v 1.1 2013/08/01 19:59:04 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no" # --enable-debug does not do anything useful
+
+inherit gnome2
+
+DESCRIPTION="GLib geocoding library that uses the Yahoo! Place Finder service"
+HOMEPAGE="http://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection test"
+
+RDEPEND="
+ dev-libs/geoip
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/json-glib-0.14[introspection?]
+ gnome-base/gvfs[http]
+ net-libs/libsoup:2.4[introspection?]
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.3
+ || ( >=net-libs/libsoup-2.42:2.4 net-libs/libsoup-gnome:2.4[introspection] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.41.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+RESTRICT="test" # Need network #424719
+
+#src_test() {
+# export GVFS_DISABLE_FUSE=1
+# export GIO_USE_VFS=gvfs
+# ewarn "Tests require network access to http://where.yahooapis.com"
+# dbus-launch emake check || die "tests failed"
+#}