summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-03 10:28:54 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-03 10:28:54 +0000
commit28afff1e24ecd81d851c0eb764c6834c288b7adb (patch)
treeb634ed220780ddb145e46042e6970011727cd960 /sci-geosciences/gpsbabel
parentBugfix release; double FD closure patch by Jaco Kroon finally applied upstrea... (diff)
downloadgentoo-2-28afff1e24ecd81d851c0eb764c6834c288b7adb.tar.gz
gentoo-2-28afff1e24ecd81d851c0eb764c6834c288b7adb.tar.bz2
gentoo-2-28afff1e24ecd81d851c0eb764c6834c288b7adb.zip
Version bump (bug 412271, non-maint commit)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gpsbabel')
-rw-r--r--sci-geosciences/gpsbabel/ChangeLog8
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch12
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild97
3 files changed, 116 insertions, 1 deletions
diff --git a/sci-geosciences/gpsbabel/ChangeLog b/sci-geosciences/gpsbabel/ChangeLog
index 5c67d73b1a19..7d13a0749c68 100644
--- a/sci-geosciences/gpsbabel/ChangeLog
+++ b/sci-geosciences/gpsbabel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gpsbabel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/ChangeLog,v 1.25 2012/04/24 05:00:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/ChangeLog,v 1.26 2012/05/03 10:28:53 xmw Exp $
+
+*gpsbabel-1.4.3 (03 May 2012)
+
+ 03 May 2012; Michael Weber <xmw@gentoo.org> +gpsbabel-1.4.3.ebuild,
+ +files/gpsbabel-1.4.3-fix_binary_name.patch:
+ Version bump (bug 412271, non-maint commit)
24 Apr 2012; Justin Lecher <jlec@gentoo.org> gpsbabel-1.4.2.ebuild,
metadata.xml:
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch
new file mode 100644
index 000000000000..2ab8d5e10c69
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch
@@ -0,0 +1,12 @@
+Rename gpsbabelfe binary.
+--- gpsbabel-1.4.3/gui/app.pro
++++ gpsbabel-1.4.3/gui/app.pro
+@@ -30,7 +30,7 @@
+ TARGET=GPSBabelFE
+ QMAKE_LFLAGS_RELEASE += -static-libgcc
+ }
+-unix:TARGET=gpsbabelfe-bin
++unix:TARGET=gpsbabelfe
+ mac:TARGET=GPSBabelFE
+
+ FORMS += aboutui.ui
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild
new file mode 100644
index 000000000000..1417413a73c2
--- /dev/null
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild,v 1.1 2012/05/03 10:28:53 xmw Exp $
+
+EAPI=4
+
+inherit qt4-r2 base autotools
+
+DESCRIPTION="GPS waypoints, tracks and routes converter"
+HOMEPAGE="http://www.gpsbabel.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ doc? ( http://www.gpsbabel.org/style3.css -> gpsbabel.org-style3.css )"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc qt4"
+
+RDEPEND="
+ dev-libs/expat
+ sci-libs/shapelib
+ virtual/libusb:0
+ qt4? (
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4
+ )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-lang/perl
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.1.2
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable_statistic_uploading.patch"
+ "${FILESDIR}/${PN}-disable_update_check.patch"
+ "${FILESDIR}/${PN}-disable_version_check.patch"
+ "${FILESDIR}/${P}-fix_binary_name.patch"
+ "${FILESDIR}/${PN}-freebsd.patch"
+ "${FILESDIR}/${PN}-use_system_shapelib.patch"
+ "${FILESDIR}/${PN}-xmldoc.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ rm -rf shapelib || die
+
+ use doc && cp "${DISTDIR}/gpsbabel.org-style3.css" "${S}"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with doc doc "${S}"/doc/manual) \
+ --with-zlib=system
+
+ if use qt4; then
+ pushd "${S}/gui" > /dev/null
+ lrelease *.ts || die
+ eqmake4
+ popd > /dev/null
+ fi
+}
+
+src_compile() {
+ emake
+ if use qt4; then
+ pushd "${S}/gui" > /dev/null
+ emake
+ popd > /dev/null
+ fi
+
+ if use doc; then
+ perl xmldoc/makedoc
+ emake gpsbabel.html
+ fi
+}
+
+src_install() {
+ default
+ dodoc README*
+
+ if use qt4; then
+ dobin gui/objects/gpsbabelfe
+ insinto /usr/share/qt4/translations/
+ doins gui/gpsbabel*_*.qm
+ newicon gui/images/appicon.png ${PN}.png
+ make_desktop_entry gpsbabelfe ${PN} ${PN} "Science;Geoscience"
+ fi
+
+ if use doc; then
+ dohtml gpsbabel.*
+ fi
+}