summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-20 06:59:00 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-20 06:59:00 +0000
commitedac957afb85b2292a88318e7393792da3c0928d (patch)
treee903866cf973dd3481565891465b852623e10e1e /sci-geosciences/gpsd
parentForgot flag-o-matic to inherit line when testing stuff. Punt it for last commit. (diff)
downloadgentoo-2-edac957afb85b2292a88318e7393792da3c0928d.tar.gz
gentoo-2-edac957afb85b2292a88318e7393792da3c0928d.tar.bz2
gentoo-2-edac957afb85b2292a88318e7393792da3c0928d.zip
Version bump #380883 by Andreas K. Hüttel and Ed Wildgoose. Add USE=X support for #369261 by Patrick.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/ChangeLog10
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.3-release-rev.patch39
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.3-setup.py17
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.3-udev-install.patch31
-rw-r--r--sci-geosciences/gpsd/gpsd-3.3.ebuild148
5 files changed, 244 insertions, 1 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 59e2246cc41f..b09049f0cd1a 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.73 2011/07/18 07:09:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.74 2011/11/20 06:59:00 vapier Exp $
+
+*gpsd-3.3 (20 Nov 2011)
+
+ 20 Nov 2011; Mike Frysinger <vapier@gentoo.org> +gpsd-3.3.ebuild,
+ +files/gpsd-3.3-release-rev.patch, +files/gpsd-3.3-setup.py,
+ +files/gpsd-3.3-udev-install.patch:
+ Version bump #380883 by Andreas K. Hüttel and Ed Wildgoose. Add USE=X
+ support for #369261 by Patrick.
18 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org> gpsd-2.96-r1.ebuild:
Add sys-devel/bc as test dep. Fixes bug #363203.
diff --git a/sci-geosciences/gpsd/files/gpsd-3.3-release-rev.patch b/sci-geosciences/gpsd/files/gpsd-3.3-release-rev.patch
new file mode 100644
index 000000000000..29415590caee
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.3-release-rev.patch
@@ -0,0 +1,39 @@
+taken from upstream repo & tweaked; drop with 3.4 release
+
+From c96ffb7733b56a8c5c20d473d8fd83b62b6abfde Mon Sep 17 00:00:00 2001
+From: Bernd Zeimetz <bernd@bzed.de>
+Date: Thu, 10 Nov 2011 22:18:07 +0100
+Subject: [PATCH] SConstruct: Use gpsd_version as revision for releases.
+
+---
+ SConstruct | 13 ++++++++-----
+ 1 files changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index d367403..3d95e7e 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -978,12 +978,15 @@ env.Command(target="ais_json.i", source="jsongen.py", action='''\
+ chmod a-w $TARGET''')
+
+ # generate revision.h
+-(st, rev) = commands.getstatusoutput('git describe')
+-if st != 0:
+- from datetime import datetime
+- rev = datetime.now().isoformat()[:-4]
++if 'dev' in gpsd_version:
++ (st, rev) = commands.getstatusoutput('git describe')
++ if st != 0:
++ from datetime import datetime
++ rev = datetime.now().isoformat()[:-4]
++else:
++ rev = gpsd_version
+ revision='#define REVISION "%s"\n' %(rev.strip(),)
+-env.NoClean(env.Textfile(target="revision.h", source=[revision]))
++env.Textfile(target="revision.h", source=[revision])
+
+ # generate pps_pin.h
+ pps_pin = env['pps_pin']
+--
+1.7.6.1
+
diff --git a/sci-geosciences/gpsd/files/gpsd-3.3-setup.py b/sci-geosciences/gpsd/files/gpsd-3.3-setup.py
new file mode 100644
index 000000000000..93cc5e8f2149
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.3-setup.py
@@ -0,0 +1,17 @@
+from distutils.core import setup, Extension
+
+setup(
+ name = "gps",
+ version = @VERSION@,
+ description = 'Python libraries for the gpsd service daemon',
+ url = @URL@,
+ author = 'the GPSD project',
+ author_email = @EMAIL@,
+ license = "BSD",
+ ext_modules=[
+ Extension("gps.packet", @GPS_PACKET_SOURCES@, include_dirs=["."]),
+ Extension("gps.clienthelpers", @GPS_CLIENT_SOURCES@, include_dirs=["."]),
+ ],
+ packages = ['gps'],
+ scripts = @SCRIPTS@,
+)
diff --git a/sci-geosciences/gpsd/files/gpsd-3.3-udev-install.patch b/sci-geosciences/gpsd/files/gpsd-3.3-udev-install.patch
new file mode 100644
index 000000000000..ef000bc27068
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.3-udev-install.patch
@@ -0,0 +1,31 @@
+From b0513cd2e44705058ffdaa7a9c3f32371e9fcd5b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 17 Nov 2011 23:44:06 -0500
+Subject: [PATCH] use DESTDIR with udev install
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ SConstruct | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index 1f99740..b7a98e4 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1505,9 +1505,10 @@ if env['python']:
+ # is plugged in.
+
+ Utility('udev-install', '', [
+- 'cp $SRCDIR/gpsd.rules /lib/udev/rules.d/25-gpsd.rules',
+- 'cp $SRCDIR/gpsd.hotplug /lib/udev/',
+- 'chmod a+x /lib/udev/gpsd.hotplug',
++ 'mkdir -p ' + DESTDIR + '/lib/udev/rules.d',
++ 'cp $SRCDIR/gpsd.rules ' + DESTDIR + '/lib/udev/rules.d/25-gpsd.rules',
++ 'cp $SRCDIR/gpsd.hotplug ' + DESTDIR + '/lib/udev/',
++ 'chmod a+x ' + DESTDIR + '/lib/udev/gpsd.hotplug',
+ ])
+
+ Utility('udev-uninstall', '', [
+--
+1.7.6.1
+
diff --git a/sci-geosciences/gpsd/gpsd-3.3.ebuild b/sci-geosciences/gpsd/gpsd-3.3.ebuild
new file mode 100644
index 000000000000..3d2ffa32c9c9
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-3.3.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.3.ebuild,v 1.1 2011/11/20 06:59:00 vapier Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="python? 2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+SCONS_MIN_VERSION="1.2.1"
+
+inherit eutils user multilib distutils scons-utils toolchain-funcs
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
+HOMEPAGE="http://catb.org/gpsd/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+GPSD_PROTOCOLS=(
+ ashtech aivdm clientdebug earthmate evermore fv18 garmin
+ garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
+ oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
+ tripmate tnt ubx
+)
+IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 test udev usb X"
+REQUIRED_USE="X? ( python )"
+
+RDEPEND="X? ( dev-python/pygtk:2 )
+ ncurses? ( sys-libs/ncurses )
+ bluetooth? ( net-wireless/bluez )
+ usb? ( virtual/libusb:1 )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ntp? ( net-misc/ntp )
+ qt4? ( x11-libs/qt-gui )"
+# xml packages are for man page generation
+DEPEND="${RDEPEND}
+ app-text/xmlto
+ =app-text/docbook-xml-dtd-4.1*
+ test? ( sys-devel/bc )"
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-release-rev.patch
+ epatch "${FILESDIR}"/${P}-udev-install.patch
+
+ # Avoid useless -L paths to the install dir
+ sed -i \
+ -e '/env.Prepend.*LIBPATH=.*installdir/s:env.*:pass:' \
+ -e '/env.Prepend.*RPATH=/s:env.*:pass:' \
+ SConstruct || die
+
+ # Extract python info out of SConstruct so we can use saner distribute
+ if use python ; then
+ pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
+ local pybins=$(pyvar python_progs)
+ local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
+ local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
+ local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
+ sed \
+ -e "s|@VERSION@|$(pyvar gpsd_version)|" \
+ -e "s|@URL@|$(pyvar website)|" \
+ -e "s|@EMAIL@|$(pyvar devmail)|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
+ -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
+ -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
+ "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
+ distutils_src_prepare
+ fi
+}
+
+src_configure() {
+ myesconsargs=(
+ prefix=/usr
+ libdir="/$(get_libdir)"
+ gpsd_user=gpsd
+ gpsd_group=uucp
+ strip=False
+ python=False
+ $(use_scons bluetooth bluez)
+ $(use_scons cxx libgpsmm)
+ $(use_scons debug)
+ $(use_scons dbus dbus-export)
+ $(use_scons ipv6)
+ $(use_scons ncurses)
+ $(use_scons ntp ntpshm)
+ $(use_scons ntp pps)
+ $(use_scons qt4 libQgpsmm)
+ $(use_scons usb)
+ )
+
+ # enable specified protocols
+ local protocol
+ for protocol in ${GPSD_PROTOCOLS[@]} ; do
+ myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
+ done
+}
+
+src_compile() {
+ export CHRPATH=true
+ tc-export CC CXX
+ export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
+ escons
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ DESTDIR="${D}" escons install $(usex udev udev-install "")
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd
+
+ if use python ; then
+ distutils_src_install
+ # Delete all X related packages if user doesn't want them
+ if ! use X ; then
+ local p
+ for p in $(grep -Il 'import .*pygtk' *) ; do
+ find "${D}"/usr/bin -name "${p}*" -delete
+ done
+ fi
+ fi
+}
+
+pkg_preinst() {
+ # Run the gpsd daemon as gpsd and group uucp; create it here
+ # as it doesn't seem to be needed during compile/install ...
+ enewuser gpsd -1 -1 -1 "uucp"
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}