summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-10 23:21:53 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-10 23:21:53 +0000
commit5eb288a37134f297174238a3b49841666a00c10a (patch)
tree70334ab978854feda2793794d49025ad67787f5b /sci-geosciences/grass
parentmoved from USE flag tcltk to tcl, see bug 17808 (diff)
downloadgentoo-2-5eb288a37134f297174238a3b49841666a00c10a.tar.gz
gentoo-2-5eb288a37134f297174238a3b49841666a00c10a.tar.bz2
gentoo-2-5eb288a37134f297174238a3b49841666a00c10a.zip
moved from tcltk USE flag to tk, see bug 17808
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog5
-rw-r--r--sci-geosciences/grass/grass-6.0.1.ebuild39
2 files changed, 23 insertions, 21 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 5e82ca789de5..6a63e7be04e9 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-geosciences/grass
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.31 2007/01/29 01:57:03 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.32 2007/02/10 23:21:53 opfer Exp $
+
+ 10 Feb 2007; Christian Faulhammer <opfer@gentoo.org> grass-6.0.1.ebuild:
+ moved from tcltk USE flag to tk, see bug 17808
*grass-6.2.0-r1 (29 Jan 2007)
diff --git a/sci-geosciences/grass/grass-6.0.1.ebuild b/sci-geosciences/grass/grass-6.0.1.ebuild
index 9b69f621e3de..552bb0804f2f 100644
--- a/sci-geosciences/grass/grass-6.0.1.ebuild
+++ b/sci-geosciences/grass/grass-6.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.0.1.ebuild,v 1.11 2007/01/29 01:57:03 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.0.1.ebuild,v 1.12 2007/02/10 23:21:53 opfer Exp $
inherit eutils
@@ -16,7 +16,7 @@ KEYWORDS="amd64 ppc sparc x86"
# To-do: get ppc64 gdal deps fixed up
# add gdal back to use flags once grass is fixed
-IUSE="fftw jpeg motif mysql nls odbc opengl png postgres readline tcltk tiff truetype"
+IUSE="fftw jpeg motif mysql nls odbc opengl png postgres readline tk tiff truetype"
RESTRICT="nostrip"
@@ -41,26 +41,25 @@ RDEPEND=">=sys-devel/make-3.80
truetype? ( >=media-libs/freetype-2.0 )
nls? ( x11-terms/mlterm )
opengl? ( virtual/opengl )
- tcltk? ( >=dev-lang/tcl-8.3.4
- >=dev-lang/tk-8.3.4 )
+ tk? ( >=dev-lang/tk-8.3.4 )
motif? ( x11-libs/openmotif )
|| (
- ( x11-libs/libXmu
- x11-libs/libXext
- x11-libs/libXp
- x11-libs/libX11
- x11-libs/libXt
- x11-libs/libSM
- x11-libs/libICE
- x11-libs/libXpm
- x11-libs/libXaw )
+ ( x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXp
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXpm
+ x11-libs/libXaw )
virtual/x11
)"
DEPEND="${RDEPEND}
|| (
- ( x11-proto/xproto x11-proto/xextproto )
- virtual/x11
+ ( x11-proto/xproto x11-proto/xextproto )
+ virtual/x11
)"
src_unpack() {
@@ -85,15 +84,15 @@ src_compile() {
|| MYCONF="${MYCONF} --without-mysql"
if use opengl; then
- MYCONF="${MYCONF} --with-opengl-libs=/usr/$(get_libdir)/opengl/xorg-x11/lib/"
+ MYCONF="${MYCONF} --with-opengl-libs=/usr/$(get_libdir)/opengl/xorg-x11/lib/"
fi
# apparently gdal isn't optional with this version
# we'll temporarily make it a hard dep for now
# if use gdal; then
-# MYCONF="${MYCONF} --with-gdal=/usr/bin/gdal-config"
+# MYCONF="${MYCONF} --with-gdal=/usr/bin/gdal-config"
# else
-# MYCONF="${MYCONF} --without-gdal"
+# MYCONF="${MYCONF} --without-gdal"
# fi
export LD_LIBRARY_PATH="/${WORKDIR}/image/usr/grass60/$(get_libdir):${LD_LIBRARY_PATH}"
@@ -109,7 +108,7 @@ src_compile() {
`use_enable amd64 64bit` \
`use_with opengl` \
`use_with readline` \
- `use_with tcltk` \
+ $(use_with tk tcltk) \
${MYCONF} || die "Error: configure failed!"
emake -j1 || die "Error: emake failed!"
}
@@ -117,7 +116,7 @@ src_compile() {
src_install() {
make install \
prefix=${D}/usr UNIX_BIN=${D}/usr/bin BINDIR=${D}/usr/bin PREFIX=${D}/usr \
- || die "Error: make install failed!"
+ || die "Error: make install failed!"
sed -i "s:^GISBASE=.*$:GISBASE=/usr/grass60:" \
${D}/usr/bin/grass60