summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-06-08 04:51:05 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-06-08 04:51:05 +0000
commitf6067e9b8e5fead43940aa93e3d9c29f5b4d33d4 (patch)
tree785a28e42938c4858161676f27e02bb1bf88518f /sci-geosciences/grass
parentonly use the -j part of MAKEOPTS (diff)
downloadgentoo-2-f6067e9b8e5fead43940aa93e3d9c29f5b4d33d4.tar.gz
gentoo-2-f6067e9b8e5fead43940aa93e3d9c29f5b4d33d4.tar.bz2
gentoo-2-f6067e9b8e5fead43940aa93e3d9c29f5b4d33d4.zip
Updated with additional C++ include for bug #270916.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog9
-rw-r--r--sci-geosciences/grass/files/grass-6.3.0-gcc44.patch11
-rw-r--r--sci-geosciences/grass/grass-6.3.0.ebuild5
3 files changed, 23 insertions, 2 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 6214f991f6b2..59ee79781be4 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/grass
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.67 2009/03/23 03:51:42 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.68 2009/06/08 04:51:04 nerdboy Exp $
+
+ 08 Jun 2009; Steve Arnold <nerdboy@gentoo.org>
+ +files/grass-6.3.0-gcc44.patch, grass-6.3.0.ebuild:
+ Updated with additional C++ include for bug #270916 (thanks to
+ Jiří Moravec <qjim@volny.cz> for the patch). I still don't have
+ gcc 4.4 yet, but the benign nature of the patch and building with
+ gcc 4.3.3 should suffice.
23 Mar 2009; Steve Arnold <nerdboy@gentoo.org>
+files/grass-6.3.0-o_creat.patch, grass-6.3.0.ebuild:
diff --git a/sci-geosciences/grass/files/grass-6.3.0-gcc44.patch b/sci-geosciences/grass/files/grass-6.3.0-gcc44.patch
new file mode 100644
index 000000000000..d90f074283cd
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-6.3.0-gcc44.patch
@@ -0,0 +1,11 @@
+diff -Nupr grass-6.3.0/imagery/i.atcorr/Output.h~ grass-6.3.0/imagery/i.atcorr/Output.h
+--- grass-6.3.0/imagery/i.atcorr/Output.h~ 2009-04-29 20:49:42.000000000 +0000
++++ grass-6.3.0/imagery/i.atcorr/Output.h 2009-04-29 20:49:50.000000000 +0000
+@@ -1,6 +1,7 @@
+ #ifndef MY_OUTPUT_H
+ #define MY_OUTPUT_H
+
++#include <cstdio>
+ #include <iostream>
+ #include <sstream>
+ #include <string>
diff --git a/sci-geosciences/grass/grass-6.3.0.ebuild b/sci-geosciences/grass/grass-6.3.0.ebuild
index ce7a140538da..21d3f6e3ad7b 100644
--- a/sci-geosciences/grass/grass-6.3.0.ebuild
+++ b/sci-geosciences/grass/grass-6.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.6 2009/03/23 03:51:42 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.7 2009/06/08 04:51:04 nerdboy Exp $
inherit eutils distutils fdo-mime versionator wxwidgets
@@ -110,6 +110,9 @@ src_unpack() {
epatch rpm/fedora/grass-readline.patch
# fix the fortify_source and buffer issues (see bug #261283)
epatch "${FILESDIR}"/${P}-o_creat.patch
+ # and update for gcc 4.4 C++ changes (see bug #270916)
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+
sed -i -e "s:buff\[12:buff\[16:g" general/g.parser/main.c \
|| die "sed failed"