summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-10 20:45:55 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-10 20:45:55 +0000
commit181ef46a3c47e2887dd04b5b91339b23933495eb (patch)
tree3c09b8b0f189c8e34fe618b2b9b3b1b13c7471db /sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-181ef46a3c47e2887dd04b5b91339b23933495eb.tar.gz
gentoo-2-181ef46a3c47e2887dd04b5b91339b23933495eb.tar.bz2
gentoo-2-181ef46a3c47e2887dd04b5b91339b23933495eb.zip
initial import wrt #214867
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild')
-rw-r--r--sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild b/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
new file mode 100644
index 000000000000..3aeea2f8a1a1
--- /dev/null
+++ b/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild,v 1.1 2013/02/10 20:45:55 hasufell Exp $
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${PN}-${PV/_p/-r}
+DESCRIPTION="Library for reading and writing Tide Constituent Database (TCD) files"
+HOMEPAGE="http://www.flaterco.com/xtide/libtcd.html"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND=">=sci-geosciences/harmonics-dwf-free-20120302"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P%_*}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ use doc && dohtml libtcd.html
+}