summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-21 22:37:12 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-21 22:37:12 +0000
commit08e372eb569cf830f6f24c834c23cf793ec8bbd3 (patch)
tree11b8f9792cf0765863b7c058c2c47317286611ba /sci-geosciences
parentDo not regen man pages since the tarball includes them. (diff)
downloadgentoo-2-08e372eb569cf830f6f24c834c23cf793ec8bbd3.tar.gz
gentoo-2-08e372eb569cf830f6f24c834c23cf793ec8bbd3.tar.bz2
gentoo-2-08e372eb569cf830f6f24c834c23cf793ec8bbd3.zip
Version bump.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog8
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.5-clock.patch42
-rw-r--r--sci-geosciences/gpsd/gpsd-3.5.ebuild163
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild9
4 files changed, 217 insertions, 5 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 892b408792f9..f460f0c0b9b5 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.84 2012/05/21 22:36:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.85 2012/05/21 22:37:12 vapier Exp $
+
+*gpsd-3.5 (21 May 2012)
+
+ 21 May 2012; Mike Frysinger <vapier@gentoo.org> +files/gpsd-3.5-clock.patch,
+ +gpsd-3.5.ebuild, gpsd-9999.ebuild:
+ Version bump.
21 May 2012; Mike Frysinger <vapier@gentoo.org> gpsd-3.4.ebuild,
+files/gpsd-3.4-no-man-gen.patch:
diff --git a/sci-geosciences/gpsd/files/gpsd-3.5-clock.patch b/sci-geosciences/gpsd/files/gpsd-3.5-clock.patch
new file mode 100644
index 000000000000..478b12a48194
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.5-clock.patch
@@ -0,0 +1,42 @@
+From f9f9bb6c10102f3d69a7f50e758a3a9256bf8744 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 21 May 2012 16:27:36 -0400
+Subject: [PATCH] fix building with clock_gettime and newer glibc
+
+Building with recent glibc versions fails in gpsutils.c due to missing
+definitions related to clock_gettime. This is because we define the
+_XOPEN_SOURCE macro, but not to a new enough value. So set it to a
+recent spec value that satisfies both strptime and clock_gettime.
+
+Example build failure with glibc-2.15:
+gpsutils.c: In function 'timestamp':
+gpsutils.c:299:22: error: storage size of 'ts' isn't known
+gpsutils.c:300:14: warning: implicit declaration of function 'clock_gettime' [-Wimplicit-function-declaration]
+gpsutils.c:300:34: error: 'CLOCK_REALTIME' undeclared (first use in this function)
+gpsutils.c:300:34: note: each undeclared identifier is reported only once for each function it appears in
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ gpsutils.c | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/gpsutils.c b/gpsutils.c
+index 523838a..3b4990a 100644
+--- a/gpsutils.c
++++ b/gpsutils.c
+@@ -5,8 +5,10 @@
+ */
+
+ /* The strptime prototype is not provided unless explicitly requested.
+- * So add the define that POSIX says to to avoid: */
+-#define _XOPEN_SOURCE
++ * We also need to set the value high enough to signal inclusion of
++ * newer features (like clock_gettime). See the POSIX spec for more info:
++ * http://pubs.opengroup.org/onlinepubs/9699919799/functions/V2_chap02.html#tag_15_02_01_02 */
++#define _XOPEN_SOURCE 600
+
+ #include <stdio.h>
+ #include <time.h>
+--
+1.7.8.6
+
diff --git a/sci-geosciences/gpsd/gpsd-3.5.ebuild b/sci-geosciences/gpsd/gpsd-3.5.ebuild
new file mode 100644
index 000000000000..66dd7e2984a7
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-3.5.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.5.ebuild,v 1.1 2012/05/21 22:37:12 vapier Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="python? 2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+SCONS_MIN_VERSION="1.2.1"
+
+inherit eutils user multilib distutils scons-utils toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
+ inherit git-2
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
+HOMEPAGE="http://catb.org/gpsd/"
+
+LICENSE="BSD"
+SLOT="0"
+
+GPSD_PROTOCOLS=(
+ ashtech aivdm clientdebug earthmate evermore fv18 garmin
+ garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
+ oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
+ tripmate tnt ubx
+)
+IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 +shm +sockets test udev usb X"
+REQUIRED_USE="X? ( python )"
+
+RDEPEND="X? ( dev-python/pygtk:2 )
+ ncurses? ( sys-libs/ncurses )
+ bluetooth? ( net-wireless/bluez )
+ usb? ( virtual/libusb:1 )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ntp? ( net-misc/ntp )
+ qt4? ( x11-libs/qt-gui )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/bc )"
+
+# xml packages are for man page generation
+if [[ ${PV} == "9999" ]] ; then
+ DEPEND+="
+ app-text/xmlto
+ =app-text/docbook-xml-dtd-4.1*"
+fi
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.3-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-3.4-chrpath.patch
+ epatch "${FILESDIR}"/${PN}-3.4-always-install-man-pages.patch
+ epatch "${FILESDIR}"/${PN}-3.5-clock.patch
+ epatch "${FILESDIR}"/${PN}-3.4-no-man-gen.patch
+
+ # Avoid useless -L paths to the install dir
+ sed -i \
+ -e '/^env.Prepend(LIBPATH=.installdir(.libdir.).)$/d' \
+ -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
+ SConstruct || die
+
+ # Extract python info out of SConstruct so we can use saner distribute
+ if use python ; then
+ pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
+ local pybins=$(pyvar python_progs)
+ local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
+ local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
+ local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
+ sed \
+ -e "s|@VERSION@|$(pyvar gpsd_version)|" \
+ -e "s|@URL@|$(pyvar website)|" \
+ -e "s|@EMAIL@|$(pyvar devmail)|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
+ -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
+ -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
+ "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
+ distutils_src_prepare
+ fi
+}
+
+src_configure() {
+ myesconsargs=(
+ prefix="${EPREFIX}/usr"
+ libdir="\$prefix/$(get_libdir)"
+ gpsd_user=gpsd
+ gpsd_group=uucp
+ strip=False
+ python=False
+ $(use_scons bluetooth bluez)
+ $(use_scons cxx libgpsmm)
+ $(use_scons debug)
+ $(use_scons dbus dbus_export)
+ $(use_scons ipv6)
+ $(use_scons ncurses)
+ $(use_scons ntp ntpshm)
+ $(use_scons ntp pps)
+ $(use_scons shm shm_export)
+ $(use_scons sockets socket_export)
+ $(use_scons qt4 libQgpsmm)
+ $(use_scons usb)
+ )
+
+ # enable specified protocols
+ local protocol
+ for protocol in ${GPSD_PROTOCOLS[@]} ; do
+ myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
+ done
+}
+
+src_compile() {
+ export CHRPATH=
+ tc-export CC CXX PKG_CONFIG
+ export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
+ escons
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ DESTDIR="${D}" escons install $(usex udev udev-install "")
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd
+
+ if use python ; then
+ distutils_src_install
+ # Delete all X related packages if user doesn't want them
+ if ! use X ; then
+ local p
+ for p in $(grep -Il 'import .*pygtk' *) ; do
+ find "${D}"/usr/bin -name "${p}*" -delete
+ done
+ fi
+ fi
+}
+
+pkg_preinst() {
+ # Run the gpsd daemon as gpsd and group uucp; create it here
+ # as it doesn't seem to be needed during compile/install ...
+ enewuser gpsd -1 -1 -1 "uucp"
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 49a95f9c21b7..64b570cd867e 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-9999.ebuild,v 1.1 2012/02/09 22:14:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-9999.ebuild,v 1.2 2012/05/21 22:37:12 vapier Exp $
EAPI="4"
@@ -61,9 +61,10 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-3.3-ldflags.patch
- epatch "${FILESDIR}"/${PN}-3.4-strptime.patch
epatch "${FILESDIR}"/${PN}-3.4-chrpath.patch
epatch "${FILESDIR}"/${PN}-3.4-always-install-man-pages.patch
+ epatch "${FILESDIR}"/${PN}-3.5-clock.patch
+ epatch "${FILESDIR}"/${PN}-3.4-no-man-gen.patch
# Avoid useless -L paths to the install dir
sed -i \
@@ -93,8 +94,8 @@ src_prepare() {
src_configure() {
myesconsargs=(
- prefix=/usr
- libdir="/$(get_libdir)"
+ prefix="${EPREFIX}/usr"
+ libdir="\$prefix/$(get_libdir)"
gpsd_user=gpsd
gpsd_group=uucp
strip=False