summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-30 20:45:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-30 20:45:30 +0000
commit09e4a045a6e9900d302c80e7699f0ef317d47f25 (patch)
tree091efa439d842902bb705df073b3afabac7e4ef8 /sci-geosciences
parentFix calls to python_mod_optimize() and python_mod_cleanup(). (diff)
downloadgentoo-2-09e4a045a6e9900d302c80e7699f0ef317d47f25.tar.gz
gentoo-2-09e4a045a6e9900d302c80e7699f0ef317d47f25.tar.bz2
gentoo-2-09e4a045a6e9900d302c80e7699f0ef317d47f25.zip
Delete calls to deprecated distutils_python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/ChangeLog6
-rw-r--r--sci-geosciences/grass/grass-6.3.0.ebuild6
-rw-r--r--sci-geosciences/grass/grass-6.4.0_rc5.ebuild4
3 files changed, 8 insertions, 8 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index c134a72135a0..7e9572c6bda7 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/grass
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.80 2010/05/04 10:53:41 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.81 2010/05/30 20:45:30 arfrever Exp $
+
+ 30 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ grass-6.3.0.ebuild, grass-6.4.0_rc5.ebuild:
+ Delete calls to deprecated distutils_python_version().
04 May 2010; Tomáš Chvátal <scarabeus@gentoo.org>
grass-6.4.0_rc6.ebuild, metadata.xml:
diff --git a/sci-geosciences/grass/grass-6.3.0.ebuild b/sci-geosciences/grass/grass-6.3.0.ebuild
index 0aa7ad99d57d..8f2841289a3e 100644
--- a/sci-geosciences/grass/grass-6.3.0.ebuild
+++ b/sci-geosciences/grass/grass-6.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.13 2010/02/03 20:56:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.14 2010/05/30 20:45:30 arfrever Exp $
inherit eutils distutils fdo-mime versionator wxwidgets
@@ -131,8 +131,6 @@ src_unpack() {
src_compile() {
local myconf
addpredict /var/cache/fontconfig
- # wxwindows needs python (see bug #237495)
- use wxwindows && distutils_python_version
myconf="--prefix=/usr --with-cxx --enable-shared \
--with-gdal=$(type -P gdal-config) --with-curses --with-proj \
@@ -157,7 +155,7 @@ src_compile() {
# The following lib should be there, based on the above and the
# wxpython dependency (in theory). I still need a good way to
# query for the location...
- LIBGDI="/usr/$(get_libdir)/python${PYVER}/site-packages/wx-${WX_GTK_VER}-gtk2-unicode/wx/_gdi_.so"
+ LIBGDI="$(python_get_sitedir)/wx-${WX_GTK_VER}-gtk2-unicode/wx/_gdi_.so"
myconf="${myconf} --with-python --with-wxwidgets=${WX_CONFIG}"
else
# USE=python must be enabled above if wxwindows is enabled
diff --git a/sci-geosciences/grass/grass-6.4.0_rc5.ebuild b/sci-geosciences/grass/grass-6.4.0_rc5.ebuild
index a9be56251109..a4e203c07875 100644
--- a/sci-geosciences/grass/grass-6.4.0_rc5.ebuild
+++ b/sci-geosciences/grass/grass-6.4.0_rc5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0_rc5.ebuild,v 1.2 2010/02/17 16:48:21 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0_rc5.ebuild,v 1.3 2010/05/30 20:45:30 arfrever Exp $
EAPI="2"
@@ -134,8 +134,6 @@ src_prepare() {
src_configure() {
local myconf
addpredict /var/cache/fontconfig
- # wxwindows needs python (see bug #237495)
- use wxwindows && distutils_python_version
myconf="--prefix=/usr --with-cxx --enable-shared \
--with-gdal=$(type -P gdal-config) --with-curses --with-proj \