summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-06 10:50:05 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-06 10:50:05 +0000
commit101c8349db4c1732c6a9897ffb27253b2084323d (patch)
treed285383e4e5af2e79e43a7e5183ed87ad6eb7d25 /sci-libs/alglib
parentVersion bump, wrt bug #493342, thanks to Aaron Bauman <aaron AT flappyport.com> (diff)
downloadgentoo-2-101c8349db4c1732c6a9897ffb27253b2084323d.tar.gz
gentoo-2-101c8349db4c1732c6a9897ffb27253b2084323d.tar.bz2
gentoo-2-101c8349db4c1732c6a9897ffb27253b2084323d.zip
sci-libs/alglib: Version BUmp
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/alglib')
-rw-r--r--sci-libs/alglib/ChangeLog8
-rw-r--r--sci-libs/alglib/alglib-3.8.2.ebuild27
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt-3.8.232
3 files changed, 66 insertions, 1 deletions
diff --git a/sci-libs/alglib/ChangeLog b/sci-libs/alglib/ChangeLog
index 83643aa737a7..736a68f37cb6 100644
--- a/sci-libs/alglib/ChangeLog
+++ b/sci-libs/alglib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/alglib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/alglib/ChangeLog,v 1.1 2013/06/22 12:08:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/alglib/ChangeLog,v 1.2 2013/12/06 10:50:04 jlec Exp $
+
+*alglib-3.8.2 (06 Dec 2013)
+
+ 06 Dec 2013; Justin Lecher <jlec@gentoo.org> +alglib-3.8.2.ebuild,
+ +files/CMakeLists.txt-3.8.2:
+ Version BUmp
*alglib-3.7.0 (22 Jun 2013)
diff --git a/sci-libs/alglib/alglib-3.8.2.ebuild b/sci-libs/alglib/alglib-3.8.2.ebuild
new file mode 100644
index 000000000000..67ebbfe740c2
--- /dev/null
+++ b/sci-libs/alglib/alglib-3.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/alglib/alglib-3.8.2.ebuild,v 1.1 2013/12/06 10:50:04 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical analysis and data processing library"
+HOMEPAGE="http://www.alglib.net/"
+SRC_URI="http://www.alglib.net/translator/re/${P}.cpp.tgz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+"
+
+S="${WORKDIR}"/cpp/
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt-${PV} CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
diff --git a/sci-libs/alglib/files/CMakeLists.txt-3.8.2 b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
new file mode 100644
index 000000000000..0b1c5f51150d
--- /dev/null
+++ b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
@@ -0,0 +1,32 @@
+project(alglib CXX)
+cmake_minimum_required(VERSION 2.8)
+
+INCLUDE(GNUInstallDirs)
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
+SET(VERSION 3.8.2)
+SET(SOVERSION 3.8)
+
+FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
+FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
+
+ADD_LIBRARY(alglib SHARED ${ALGLIB_SRC_LIB})
+SET_TARGET_PROPERTIES(alglib PROPERTIES
+ VERSION ${VERSION}
+ SOVERSION ${SOVERSION})
+
+INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
+INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+#===========================================================
+ADD_EXECUTABLE(test_c tests/test_c.cpp)
+TARGET_LINK_LIBRARIES(test_c alglib)
+#INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+#===========================================================
+ADD_EXECUTABLE(test_i tests/test_i.cpp)
+TARGET_LINK_LIBRARIES(test_i alglib)
+#INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+#===========================================================
+
+enable_testing()
+add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
+add_test( test_i ${CMAKE_BUILD_DIR}/test_i)