summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-02-15 17:04:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-02-15 17:04:32 +0000
commit2df8a0e9f307dd76e221fcbcba75bb20e2cb5f9f (patch)
tree5cde9d3c71fd80f30baad32e54b85eb55bc79194 /sci-libs/armadillo
parentVersion bump (diff)
downloadgentoo-2-2df8a0e9f307dd76e221fcbcba75bb20e2cb5f9f.tar.gz
gentoo-2-2df8a0e9f307dd76e221fcbcba75bb20e2cb5f9f.tar.bz2
gentoo-2-2df8a0e9f307dd76e221fcbcba75bb20e2cb5f9f.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog9
-rw-r--r--sci-libs/armadillo/armadillo-2.4.3.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index fc73af9ddf14..1cd26585f9b5 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/armadillo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.7 2011/12/20 06:37:48 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.8 2012/02/15 17:04:32 bicatali Exp $
+
+*armadillo-2.4.3 (15 Feb 2012)
+
+ 15 Feb 2012; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-2.4.3.ebuild:
+ Version bump
*armadillo-2.4.2 (20 Dec 2011)
diff --git a/sci-libs/armadillo/armadillo-2.4.3.ebuild b/sci-libs/armadillo/armadillo-2.4.3.ebuild
new file mode 100644
index 000000000000..01726623f330
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-2.4.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-2.4.3.ebuild,v 1.1 2012/02/15 17:04:32 bicatali Exp $
+
+EAPI=4
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas blas doc lapack"
+
+RDEPEND=">=dev-libs/boost-1.34
+ atlas? ( sci-libs/lapack-atlas )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ )
+ fi
+ if use atlas; then
+ mycmakeargs=(
+ -DCBLAS_FOUND=ON
+ -DCLAPACK_FOUND=ON
+ -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+ -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+ -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*pdf
+}