summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-06 19:23:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-06 19:23:25 +0000
commitcd2999a50f860ffc47319913ace16dfa5aa5fa58 (patch)
treee114c4fe5b4e45a943f0954ae93a5a1610d8da4c /sci-libs/armadillo
parentAdded Prefix keywords (diff)
downloadgentoo-2-cd2999a50f860ffc47319913ace16dfa5aa5fa58.tar.gz
gentoo-2-cd2999a50f860ffc47319913ace16dfa5aa5fa58.tar.bz2
gentoo-2-cd2999a50f860ffc47319913ace16dfa5aa5fa58.zip
Version bump. Import to the main tree. Rewrote from scratch.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog15
-rw-r--r--sci-libs/armadillo/armadillo-1.1.6.ebuild60
-rw-r--r--sci-libs/armadillo/metadata.xml21
3 files changed, 96 insertions, 0 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
new file mode 100644
index 000000000000..254e59df8cbe
--- /dev/null
+++ b/sci-libs/armadillo/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sci-libs/armadillo
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.1 2011/03/06 19:23:25 bicatali Exp $
+
+*armadillo-1.1.6 (06 Mar 2011)
+
+ 06 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-1.1.6.ebuild,
+ +metadata.xml:
+ Version bump. Import to the main tree. Rewrote from scratch.
+
+*armadillo-1.0.0 (13 Dec 2010)
+
+ 13 December 2010; Nico Schlömer <nico.schloemer@gmail.com>
+ +metadata.xml, +armadillo-1.0.0.ebuild:
+ Initial import.
diff --git a/sci-libs/armadillo/armadillo-1.1.6.ebuild b/sci-libs/armadillo/armadillo-1.1.6.ebuild
new file mode 100644
index 000000000000..d588206e7ba1
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-1.1.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-1.1.6.ebuild,v 1.1 2011/03/06 19:23:25 bicatali Exp $
+
+EAPI="3"
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas blas doc lapack"
+
+RDEPEND=">=dev-libs/boost-1.34
+ atlas? ( sci-libs/lapack-atlas )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ )
+ fi
+ if use atlas; then
+ mycmakeargs=(
+ -DCBLAS_FOUND=ON
+ -DCLAPACK_FOUND=ON
+ -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+ -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+ -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*pdf
+}
diff --git a/sci-libs/armadillo/metadata.xml b/sci-libs/armadillo/metadata.xml
new file mode 100644
index 000000000000..9dc9f77e8504
--- /dev/null
+++ b/sci-libs/armadillo/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Armadillo is a C++ linear algebra library (matrix maths) aiming
+ towards a good balance between speed and ease of use. Integer,
+ floating point and complex numbers are supported, as well as a
+ subset of trigonometric and statistics functions. Various matrix
+ decompositions are provided through optional integration with LAPACK
+ and ATLAS libraries.
+ A delayed evaluation approach is employed (during compile time) to
+ combine several operations into one and reduce (or eliminate) the
+ need for temporaries. This is accomplished through recursive
+ templates and template meta-programming.
+</longdescription>
+<use>
+ <flag name='atlas'>Link with ATLAS libraries for cblas and clapack (needs <pkg>sci-libs/lapack-atlas</pkg>)</flag>
+</use>
+</pkgmetadata>
+