summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 14:24:01 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 14:24:01 +0000
commit19bfffa960c5131c9709f1f513d928702aef7810 (patch)
treeb5997549a573a7c56622a27730ea9c4b34dd2019 /sci-libs/blas-goto/blas-goto-1.22-r1.ebuild
parentUnquoted Variable on line (diff)
downloadgentoo-2-19bfffa960c5131c9709f1f513d928702aef7810.tar.gz
gentoo-2-19bfffa960c5131c9709f1f513d928702aef7810.tar.bz2
gentoo-2-19bfffa960c5131c9709f1f513d928702aef7810.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/blas-goto/blas-goto-1.22-r1.ebuild')
-rw-r--r--sci-libs/blas-goto/blas-goto-1.22-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sci-libs/blas-goto/blas-goto-1.22-r1.ebuild b/sci-libs/blas-goto/blas-goto-1.22-r1.ebuild
index e98748b1bc0a..b3abdd99a6e3 100644
--- a/sci-libs/blas-goto/blas-goto-1.22-r1.ebuild
+++ b/sci-libs/blas-goto/blas-goto-1.22-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.22-r1.ebuild,v 1.7 2009/08/18 14:22:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.22-r1.ebuild,v 1.8 2010/12/16 14:24:01 jlec Exp $
-inherit eutils fortran flag-o-matic toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs
MY_PN="GotoBLAS"
MY_P="${MY_PN}-${PV}"
@@ -23,7 +23,6 @@ DEPEND="app-admin/eselect-blas
>=sys-devel/binutils-2.17"
S="${WORKDIR}/${MY_PN}"
-FORTRAN="gfortran g77 ifc"
ESELECT_PROF=goto
@@ -43,12 +42,12 @@ src_unpack() {
C_COMPILER=GNU
# Set up FORTRAN 77 compiler
- case ${FORTRANC} in
+ case $(tc-getFC) in
g77) F_COMPILER=G77;;
gfortran) F_COMPILER=GFORTRAN;;
ifc|ifort) F_COMPILER=INTEL;;
*)
- die "Invalid Fortran compiler: ${FORTRANC}; valid are ${FORTRAN}."
+ die "Invalid Fortran compiler: $(tc-getFC); valid are ${FORTRAN}."
esac
# Set up compilers