summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-10 17:53:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-10 17:53:49 +0000
commit37cba64cdef333de5ff54c08be202694e44a1883 (patch)
treebf89698c8ea99ca6e5c256b2ff23f23a43c74178 /sci-libs/cholmod
parent * New version for GNOME 2.24. Mostly bug fixes and performance improvments. (diff)
downloadgentoo-2-37cba64cdef333de5ff54c08be202694e44a1883.tar.gz
gentoo-2-37cba64cdef333de5ff54c08be202694e44a1883.tar.bz2
gentoo-2-37cba64cdef333de5ff54c08be202694e44a1883.zip
Fixed a syntax error in the minimal flag, and added blas configuration in the supernodal mode
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-libs/cholmod')
-rw-r--r--sci-libs/cholmod/ChangeLog7
-rw-r--r--sci-libs/cholmod/cholmod-1.6.0-r1.ebuild12
2 files changed, 14 insertions, 5 deletions
diff --git a/sci-libs/cholmod/ChangeLog b/sci-libs/cholmod/ChangeLog
index b6addf76ef02..bfd78c101041 100644
--- a/sci-libs/cholmod/ChangeLog
+++ b/sci-libs/cholmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/cholmod
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.10 2008/08/07 06:20:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.11 2008/10/10 17:53:49 bicatali Exp $
+
+ 10 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ cholmod-1.6.0-r1.ebuild:
+ Fixed a syntax error in the minimal flag, and added blas configuration in
+ the supernodal mode
07 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
index fd104791682f..b029703eea02 100644
--- a/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
+++ b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild,v 1.6 2008/05/22 01:26:28 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild,v 1.7 2008/10/10 17:53:49 bicatali Exp $
inherit autotools eutils
@@ -53,18 +53,22 @@ src_unpack() {
s:\(#define\) \(CHOLMOD_CONFIG_H\)\n:\1 \2\n\1 NPARTITION 1\n:}' \
Include/cholmod_config.h
fi
-
eautoreconf
}
src_compile() {
local lapack_libs=no
- use supernodal && lapack_libs=$(pkg-config --libs lapack)
+ local blas_libs=no
+ if use supernodal; then
+ blas_libs=$(pkg-config --libs blas)
+ lapack_libs=$(pkg-config --libs lapack)
+ fi
econf \
+ --with-blas="${blas_libs}" \
--with-lapack="${lapack_libs}" \
$(use_enable supernodal mod-supernodal) \
$(use_enable !minimal mod-modify) \
- $(use_enable !minimal mod-matrix-ops) \
+ $(use_enable !minimal mod-matrixops) \
$(use_enable metis mod-partition) \
|| die "econf failed"
emake || die "emake failed"