summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-11 20:38:27 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-11 20:38:27 +0000
commit06fd4e0fc31f6c2af24221af08ef2935e01df402 (patch)
treeff4840d788f4d1ecffde583fdd05ae245edebd79 /sci-libs/cifparse-obj
parentVersion bump. (diff)
downloadgentoo-2-06fd4e0fc31f6c2af24221af08ef2935e01df402.tar.gz
gentoo-2-06fd4e0fc31f6c2af24221af08ef2935e01df402.tar.bz2
gentoo-2-06fd4e0fc31f6c2af24221af08ef2935e01df402.zip
sci-libs/cifparse-obj: Bump EAPI and fix linking
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/cifparse-obj')
-rw-r--r--sci-libs/cifparse-obj/ChangeLog10
-rw-r--r--sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild51
-rw-r--r--sci-libs/cifparse-obj/metadata.xml2
3 files changed, 60 insertions, 3 deletions
diff --git a/sci-libs/cifparse-obj/ChangeLog b/sci-libs/cifparse-obj/ChangeLog
index 8374a7c4f431..e2b569bf24dd 100644
--- a/sci-libs/cifparse-obj/ChangeLog
+++ b/sci-libs/cifparse-obj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/cifparse-obj
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cifparse-obj/ChangeLog,v 1.15 2012/06/02 12:57:09 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cifparse-obj/ChangeLog,v 1.16 2015/01/11 20:38:27 jlec Exp $
+
+*cifparse-obj-7.025-r1 (11 Jan 2015)
+
+ 11 Jan 2015; Justin Lecher <jlec@gentoo.org> +cifparse-obj-7.025-r1.ebuild,
+ metadata.xml:
+ Bump EAPI and fix linking
02 Jun 2012; Justin Lecher <jlec@gentoo.org> cifparse-obj-7.025.ebuild,
+files/cifparse-obj-7.025-gcc4.7.patch:
diff --git a/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild b/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
new file mode 100644
index 000000000000..b1a6d7b6e222
--- /dev/null
+++ b/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild,v 1.1 2015/01/11 20:38:27 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-v${PV}-prod-src"
+
+DESCRIPTION="Provides an object-oriented application interface to information in mmCIF format"
+HOMEPAGE="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/index.html"
+SRC_URI="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/source/${MY_P}.tar.gz"
+
+LICENSE="PDB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-gcc4.3.patch \
+ "${FILESDIR}"/${P}-gcc4.7.patch
+
+ sed \
+ -e "s:^\(CC=\).*:\1$(tc-getCC):g" \
+ -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
+ -e "s:^\(F77=\).*:\1${FORTRANC}:g" \
+ -e "s:^\(F77_LINKER=\).*:\1${FORTRANC}:g" \
+ -e "s:-static::g" \
+ -i "${S}"/etc/make.* || die "Failed to fix makefile"
+}
+
+src_compile() {
+ # parallel make fails
+ emake -j1
+}
+
+src_install() {
+ dolib.a lib/*
+ insinto /usr/include/${PN}
+ doins include/*
+}
diff --git a/sci-libs/cifparse-obj/metadata.xml b/sci-libs/cifparse-obj/metadata.xml
index e42d0af60f42..51fdedab1b38 100644
--- a/sci-libs/cifparse-obj/metadata.xml
+++ b/sci-libs/cifparse-obj/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>