summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-11 16:29:15 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-11 16:29:15 +0000
commit280f08a36f90f029fecb2ecc37747eb8cad0e658 (patch)
tree7fd252a38692b73f1180be80ead904226de90957 /sci-libs/clipper
parentMarked ppc stable for bug #227209. (diff)
downloadgentoo-2-280f08a36f90f029fecb2ecc37747eb8cad0e658.tar.gz
gentoo-2-280f08a36f90f029fecb2ecc37747eb8cad0e658.tar.bz2
gentoo-2-280f08a36f90f029fecb2ecc37747eb8cad0e658.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/clipper')
-rw-r--r--sci-libs/clipper/ChangeLog7
-rw-r--r--sci-libs/clipper/clipper-20100511.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sci-libs/clipper/ChangeLog b/sci-libs/clipper/ChangeLog
index c1542234a20d..ec053795e354 100644
--- a/sci-libs/clipper/ChangeLog
+++ b/sci-libs/clipper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/clipper
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/ChangeLog,v 1.8 2010/04/25 11:32:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/ChangeLog,v 1.9 2010/05/11 16:29:15 jlec Exp $
+
+*clipper-20100511 (11 May 2010)
+
+ 11 May 2010; Justin Lecher <jlec@gentoo.org> +clipper-20100511.ebuild:
+ Version Bump
*clipper-20100416 (16 Apr 2010)
diff --git a/sci-libs/clipper/clipper-20100511.ebuild b/sci-libs/clipper/clipper-20100511.ebuild
new file mode 100644
index 000000000000..85efa14ab7aa
--- /dev/null
+++ b/sci-libs/clipper/clipper-20100511.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/clipper-20100511.ebuild,v 1.1 2010/05/11 16:29:15 jlec Exp $
+
+EAPI="3"
+
+WANT_AUTOMAKE="1.11"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Object-oriented libraries for the organisation of crystallographic data and the performance of crystallographic computation"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper.html"
+# Transform 4-digit year to 2 digits
+SRC_URI="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper-2.1-${PV:2:${#PV}}-ac.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ sci-libs/fftw
+ sci-libs/mmdb"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-2.1
+
+src_prepare() {
+ epatch "${FILESDIR}"/20091215-missing-var.patch
+
+ # ccp4 provides these, and more.
+ sed -i -e "s:examples::g" "${S}"/Makefile.am
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_configure() {
+ # Recommended on ccp4bb/coot ML to fix crashes when calculating maps
+ # on 64-bit systems
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --enable-ccp4 \
+ --enable-cif \
+ --enable-cns \
+ --enable-contrib \
+ --enable-minimol \
+ --enable-mmdb \
+ --enable-phs \
+ --with-mmdb="${EPREFIX}"/usr \
+ $(use_enable debug)
+}
+
+src_test() {
+ emake \
+ -C examples \
+ check || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README ChangeLog NEWS || die
+}