summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-28 18:15:50 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-28 18:15:50 +0000
commitb5ebecf622f0ee4925ec35ab5f7026ac721b4338 (patch)
tree5e99baee8fa760b14679b4129036d3bfb0022721 /sci-libs/clipper
parentStable for HPPA (bug #471456). (diff)
downloadgentoo-2-b5ebecf622f0ee4925ec35ab5f7026ac721b4338.tar.gz
gentoo-2-b5ebecf622f0ee4925ec35ab5f7026ac721b4338.tar.bz2
gentoo-2-b5ebecf622f0ee4925ec35ab5f7026ac721b4338.zip
sci-libs/clipper: Rename for new version schema
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/clipper')
-rw-r--r--sci-libs/clipper/ChangeLog11
-rw-r--r--sci-libs/clipper/clipper-2.1_p100511-r1.ebuild58
-rw-r--r--sci-libs/clipper/files/2.1_p100511-makefile.patch23
-rw-r--r--sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch16
-rw-r--r--sci-libs/clipper/metadata.xml2
5 files changed, 107 insertions, 3 deletions
diff --git a/sci-libs/clipper/ChangeLog b/sci-libs/clipper/ChangeLog
index 8710558d85e7..66383ab5c22b 100644
--- a/sci-libs/clipper/ChangeLog
+++ b/sci-libs/clipper/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/clipper
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/ChangeLog,v 1.21 2012/07/10 18:55:01 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/ChangeLog,v 1.22 2013/05/28 18:15:50 jlec Exp $
+
+*clipper-2.1_p100511-r1 (28 May 2013)
+
+ 28 May 2013; Justin Lecher <jlec@gentoo.org> +clipper-2.1_p100511-r1.ebuild,
+ +files/2.1_p100511-makefile.patch,
+ +files/clipper-2.1_p100511-outofsourcebuild.patch, metadata.xml:
+ Rename for new version schema
10 Jul 2012; Justin Lecher <jlec@gentoo.org> -clipper-20100511.ebuild:
Cleaned old
diff --git a/sci-libs/clipper/clipper-2.1_p100511-r1.ebuild b/sci-libs/clipper/clipper-2.1_p100511-r1.ebuild
new file mode 100644
index 000000000000..90689594bf8a
--- /dev/null
+++ b/sci-libs/clipper/clipper-2.1_p100511-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/clipper-2.1_p100511-r1.ebuild,v 1.1 2013/05/28 18:15:50 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils flag-o-matic
+
+MY_PV=${PV/_p/-}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Object-oriented libraries for crystallographic data and crystallographic computation"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper.html"
+SRC_URI="http://www.ysbl.york.ac.uk/~cowtan/clipper/${MY_P}-ac.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="debug static-libs"
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ sci-libs/fftw
+ sci-libs/mmdb"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-2.1
+
+PATCHES=(
+ "${FILESDIR}"/20091215-missing-var.patch
+ "${FILESDIR}"/${PV}-makefile.patch
+ "${FILESDIR}"/${P}-outofsourcebuild.patch
+ )
+
+src_configure() {
+ # Recommended on ccp4bb/coot ML to fix crashes when calculating maps
+ # on 64-bit systems
+ append-flags -fno-strict-aliasing
+
+ local myeconfargs=(
+ --enable-ccp4
+ --enable-cif
+ --enable-cns
+ --enable-contrib
+ --enable-minimol
+ --enable-mmdb
+ --enable-phs
+ --with-mmdb="${EPREFIX}/usr"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ emake -C "${AUTOTOOLS_BUILD_DIR}"/examples check
+}
diff --git a/sci-libs/clipper/files/2.1_p100511-makefile.patch b/sci-libs/clipper/files/2.1_p100511-makefile.patch
new file mode 100644
index 000000000000..d933e88f7c7e
--- /dev/null
+++ b/sci-libs/clipper/files/2.1_p100511-makefile.patch
@@ -0,0 +1,23 @@
+ Makefile.am | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 745824d..0da0ddd 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,12 +1,12 @@
+ # -*- mode: Makefile; mode: font-lock -*-
+ AUTOMAKE_OPTIONS = foreign
+-SUBDIRS = config clipper examples dox
+-DIST_SUBDIRS = config clipper examples dox
++SUBDIRS = config clipper dox
++DIST_SUBDIRS = config clipper dox
+ EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL NEWS README
+ bin_SCRIPTS = clipper-config
+ # pkgconfigdir = $(libdir)/pkgconfig
+ # pkgconfig_DATA = clipper.pc
+ if DEBUG
+-AM_CXXFLAGS = -g -DDEBUG
++AM_CXXFLAGS = -DDEBUG
+ endif
+ ACLOCAL_AMFLAGS = -I config
diff --git a/sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch b/sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch
new file mode 100644
index 000000000000..2db566b7b799
--- /dev/null
+++ b/sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch
@@ -0,0 +1,16 @@
+ examples/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index 203ce96..2b65f1c 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -27,7 +27,7 @@ maketestdata_SOURCES = maketestdata.cpp
+
+ TESTS = maketestdata
+
+-INCLUDES = -I.. $(FFTW_CXXFLAGS) $(MMDB_CXXFLAGS) $(CCP4_CXXFLAGS) $(CCTBX_CXXFLAGS) $(BOOST_CXXFLAGS)
++INCLUDES = -I$(top_srcdir) $(FFTW_CXXFLAGS) $(MMDB_CXXFLAGS) $(CCP4_CXXFLAGS) $(CCTBX_CXXFLAGS) $(BOOST_CXXFLAGS)
+
+ LIBS = $(FFTW_LIBS) $(CCP4_LIBS) $(MMDB_LIBS) $(CCTBX_LIBS)
+
diff --git a/sci-libs/clipper/metadata.xml b/sci-libs/clipper/metadata.xml
index e42d0af60f42..51fdedab1b38 100644
--- a/sci-libs/clipper/metadata.xml
+++ b/sci-libs/clipper/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>