summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-15 08:33:30 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-15 08:33:30 +0000
commitbcdba148334fc3ecf48b8450b0c471e93c57e5e9 (patch)
treeed31a482675088f8d3810791cc37dea7f92e596c /sci-libs/colamd
parentAdd die after external commands (diff)
downloadgentoo-2-bcdba148334fc3ecf48b8450b0c471e93c57e5e9.tar.gz
gentoo-2-bcdba148334fc3ecf48b8450b0c471e93c57e5e9.tar.bz2
gentoo-2-bcdba148334fc3ecf48b8450b0c471e93c57e5e9.zip
Moved to autotools-utils.eclass in order to handle .la files, #394079
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/colamd')
-rw-r--r--sci-libs/colamd/ChangeLog5
-rw-r--r--sci-libs/colamd/colamd-2.7.3.ebuild17
2 files changed, 13 insertions, 9 deletions
diff --git a/sci-libs/colamd/ChangeLog b/sci-libs/colamd/ChangeLog
index 432ce0c25775..9a4a55ba1b54 100644
--- a/sci-libs/colamd/ChangeLog
+++ b/sci-libs/colamd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/colamd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/ChangeLog,v 1.18 2011/12/14 22:01:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/ChangeLog,v 1.19 2011/12/15 08:33:30 jlec Exp $
+
+ 15 Dec 2011; Justin Lecher <jlec@gentoo.org> colamd-2.7.3.ebuild:
+ Moved to autotools-utils.eclass in order to handle .la files, #394079
14 Dec 2011; Agostino Sarubbo <ago@gentoo.org> colamd-2.7.3.ebuild:
Stable for AMD64, wrt bug #394079
diff --git a/sci-libs/colamd/colamd-2.7.3.ebuild b/sci-libs/colamd/colamd-2.7.3.ebuild
index 4f470ac3495c..11b363ea79db 100644
--- a/sci-libs/colamd/colamd-2.7.3.ebuild
+++ b/sci-libs/colamd/colamd-2.7.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/colamd-2.7.3.ebuild,v 1.3 2011/12/14 22:01:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colamd/colamd-2.7.3.ebuild,v 1.4 2011/12/15 08:33:30 jlec Exp $
EAPI=4
-inherit autotools eutils
+inherit autotools-utils eutils
MY_PN=COLAMD
DESCRIPTION="Column approximate minimum degree ordering algorithm"
@@ -18,15 +18,16 @@ IUSE="static-libs"
DEPEND="sci-libs/ufconfig"
RDEPEND="${DEPEND}"
-DOCS="README.txt Doc/ChangeLog"
+
+DOCS=( README.txt Doc/ChangeLog )
S="${WORKDIR}/${MY_PN}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.1-autotools.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.7.1-autotools.patch
+ autotools-utils_src_prepare
eautoreconf
}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}