summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-07-12 01:52:16 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-07-12 01:52:16 +0000
commitbf24303ef3b2ba02ddf615ef60c6f9745901c451 (patch)
tree070918dd913f1885e69f1941bcb4d188e8ae2aff /sci-libs/itpp/itpp-3.10.3.ebuild
parentNew ustream version (diff)
downloadgentoo-2-bf24303ef3b2ba02ddf615ef60c6f9745901c451.tar.gz
gentoo-2-bf24303ef3b2ba02ddf615ef60c6f9745901c451.tar.bz2
gentoo-2-bf24303ef3b2ba02ddf615ef60c6f9745901c451.zip
New revision and pruned old versions. This fixes bug #139992.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'sci-libs/itpp/itpp-3.10.3.ebuild')
-rw-r--r--sci-libs/itpp/itpp-3.10.3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/itpp/itpp-3.10.3.ebuild b/sci-libs/itpp/itpp-3.10.3.ebuild
new file mode 100644
index 000000000000..a6262d0a6b06
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.10.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.3.ebuild,v 1.1 2006/07/12 01:52:16 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="blas cblas debug doc fftw lapack"
+
+DEPEND="fftw? ( >=sci-libs/fftw-3.0.0 )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "$myconf" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || \
+ die "failed to install docs"
+}